GetSimple Support Forum

Full Version: Private pages show 404 error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello , 

We are using online plugin for Get Simple (on ubuntu). 

When we create/set a private page we take the 404 error on the browser. 

Does anyone know how to fix that error ?
(2017-10-24, 18:01:50)akindini Wrote: [ rel="nofollow" -> ]Hello , 

We are using online plugin for Get Simple (on ubuntu). 

When we create/set a private page we take the 404 error on the browser. 

Does anyone know how to fix that error ?

Which plugin do you mean with "online plugin"?

Alex
(2017-10-25, 02:39:28)Alexander_ Wrote: [ rel="nofollow" -> ]
(2017-10-24, 18:01:50)akindini Wrote: [ rel="nofollow" -> ]Hello , 

We are using online plugin for Get Simple (on ubuntu). 

When we create/set a private page we take the 404 error on the browser. 

Does anyone know how to fix that error ?

Which plugin do you mean with "online plugin"?

Alex


Hello , 

I mean that we are using our domain/admin and opens the cms
Are you logged in when you browse the private page?
(2017-10-25, 23:02:29)Carlos Wrote: [ rel="nofollow" -> ]Are you logged in when you browse the private page?

Hello , 

Yes, i'm logged in when i try to browse private page. 

It was working before but now i switch my pc to linux and is not working
file permission issue
(2017-10-26, 18:08:43)Bigin Wrote: [ rel="nofollow" -> ]file permission issue

What you mean with that? 

I have administrator rule
0755 (folder) and 0644 (file)
(2017-10-26, 19:33:51)Bigin Wrote: [ rel="nofollow" -> ]0755 (folder) and 0644 (file)

Where can i find those files?
I meant all files in GS installation directory. Some files like .htaccess, need to be strictly permissions 644
Have you read the Step by Step Install Procedure instructions?
http://get-simple.info/wiki/installation

What happens if you deactivate checkbox/select "private" page, do you then have access to it in the frontend?

PS: Enable error reporting, look into the log files.
(2017-11-02, 17:35:11)Bigin Wrote: [ rel="nofollow" -> ]I meant all files in GS installation directory. Some files like .htaccess, need to be strictly permissions 644
Have you read the Step by Step Install Procedure instructions?
http://get-simple.info/wiki/installation

What happens if you deactivate checkbox/select "private" page, do you then have access to it in the frontend?

PS: Enable error reporting, look into the log files.

Actually i can't see private pages only from my pc which i have Ubuntu. But i can access and see private pages from other computer so i don't think so that has to do with permissions. 

Will setup error reporting, generate some errors and post them here
Ahh, I misunderstood it, I thought was two separate installations. But try to disable private checkbox anyway.
Maybe there's a browser issue on your Linux machine? Are you sure that you are logged in into the admin with the Linux machine, when you are trying to access the page?
(2017-11-02, 18:27:53)Bigin Wrote: [ rel="nofollow" -> ]Ahh, I misunderstood it, I thought was two separate installations. But try to disable private checkbox anyway.
Maybe there's a browser issue on your Linux machine? Are you sure that you are logged in into the admin with the Linux machine, when you are trying to access the page?

Yes , i'm 100% sure :Smile

I have also checked different browsers, clear my cache but nothing changed.
It can be caused by the following two reasons:
  1. If your admin cookie isn't set
  2. The entered page url is unknown

and that's all I can imagine.
Check if, when browsing the page, you are using the exact domain you specified in Settings -> Website URL (with or without www prefix, or whatever)
(2017-11-02, 22:40:49)Bigin Wrote: [ rel="nofollow" -> ]It can be caused by the following two reasons:
  1. If your admin cookie isn't set
  2. The entered page url is unknown

and that's all I can imagine.

Hello again , how can i set my admin cookie?
@carlos i've using the correct domain as in the settings
It should happen automatically when you log in to the admin area.