GetSimple Support Forum

Full Version: GetSimple 3.3.14 beta
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Shawn has released a beta for GS 3.3.14
https://github.com/GetSimpleCMS/GetSimpl.../v3.3.14b1

- By default, extensions of uploaded files are now converted to lowercase, e.g. .jpg instead of .JPG (unless GSUPLOADSLC is set to false in gsconfig)
- Improved security of salted passwords in PHP 5.3+ (CVE 2017-8081)
- Fixed issues with PHP 7 in some sites (with scripts or plugins that use function menu_data())
thanks!
I do not quite understand. There will be no more error warnings when using PHP 7, which appeared when using plugins from Martin?
on the local server produces an error
http://prntscr.com/hqqrfb
errors associated with Martin's plugins and PHP 7 seems to have disappeared
Thank you

You need to replace the damaged file ajax_dark.gif
GetSimpleCMS-3.3.14b1\admin\template\images\ajax_dark.gif
ajax_dark.gif size = 102 kb
That file has been there since GS 3.2.0
@Oleg, what errors did you have with I18N and PHP7?
(2017-12-22, 05:45:24)shawn_a Wrote: [ rel="nofollow" -> ]thanks!

Thank you for your work! keep it up!
(2017-12-23, 03:19:50)Carlos Wrote: [ rel="nofollow" -> ]@Oleg, what errors did you have with I18N and PHP7?

Yes, Carlos, there were reports that some code in PHP 7 is no longer in use.
(2017-12-23, 03:19:50)Carlos Wrote: [ rel="nofollow" -> ]@Oleg, what errors did you have with I18N and PHP7?

Yes, Carlos, there were reports that some code in PHP 7 is no longer in use.
I think I wrote to Martin.
oleg what version of php on that error ? 7?
Yes 7
Oleg, if you could find the message you sent to Martin and post what kind of errors or issues you had, it could be very interesting to know.
(2017-12-23, 21:20:04)Carlos Wrote: [ rel="nofollow" -> ]Oleg, if you could find the message you sent to Martin and post what kind of errors or issues you had, it could be very interesting to know.

Code:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; I18nNavigationItem has a deprecated constructor in /[...]/plugins/i18n_navigation/frontend.class.php on line 349

included now the debug and the message appeared
can you check hotfixes branch, see if that fixes that error for you
Shawn, this is a different thing. Oleg had 2 issues with PHP7. One was the generate_salt issue, and the other one was with the I18N plugin. I asked him about this just in case it could be related to GS, but by the error it seems it isn't., so it's just something that should be modified in the plugin.
I meant the first issue screen shot

That deprecation warning should be turned off for prod sites anyway.
(2017-12-22, 08:09:41)Oleg06 Wrote: [ rel="nofollow" -> ]on the local server produces an error
http://prntscr.com/hqqrfb

Oleg,
Shawn asked you to try with the updated 3.3.14 beta (hotfixes), to check if you no longer have the error in the screenshot.
You can download it here:
https://github.com/GetSimpleCMS/GetSimpl...3bec5d.zip
Shawn,

Lowercase extensions on uploads working fine, as expected.

Disabling with define('GSUPLOADSLC', false); also ok.
sweet
(2017-12-30, 00:51:11)Carlos Wrote: [ rel="nofollow" -> ]
(2017-12-22, 08:09:41)Oleg06 Wrote: [ rel="nofollow" -> ]on the local server produces an error
http://prntscr.com/hqqrfb

Oleg,
Shawn asked you to try with the updated 3.3.14 beta (hotfixes), to check if you no longer have the error in the screenshot.
You can download it here:
https://github.com/GetSimpleCMS/GetSimpl...3bec5d.zip

no, the message has not disappeared
it may be easier to make changes to the plugin?
Strangely enough this message behaves, it will disappear, it will appear, I tried on different pages.
Do you still get the error "Call to undefined function openssl_random_pseudo_bytes() ..." ?
no, I did not see this message
So the only messages you're seeing now are those related to the I18N plugin? ("Deprecated...")
Pages: 1 2