GetSimple Support Forum

Full Version: Cannot login - redirects back to login page - no errors
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi

I have a vanilla installation of 3.3.13 on a XAMPP localhost server (Windows 10).

Installation went fine but I cannot login to admin pages.
As soon as I submit login form it just redirects back to the login page.
Address in the address bar is: http://localhost/domain.tld/admin/index.php?redirect=pages.php?

There's no errors on Apache log, PHP log nor in GetSimple logs.

What to do? Huh
Enable debug mode and check if you get any error.
Well, seems like there's a ton of code errors.

I'm using cardinal theme and there's a few wrong paths.
But most of the errors seem to be in the files under /admin/templates.

Too much to fix so maybe I'll try some other non-db CMS.
How did you set up Cardinal as the default theme? To change that you have to be logged in the admin interface. Normally you start with default theme Innovation, which you can change in the admin interface to Cardinal.

If you post (some of) the errors, we might be able to point you in the right direction. They might all just have one specific reason that is easy to fix.
Id delete it all and redo it
And still have this problem.

Now I can say that it is related to Firefox since within Chrome I can login and use admin as usually.

What could be so different in Firefox?
First I access login page /gs/cms/ and after submit I get redirected to/gs/cms/index.php?redirect=pages.php?

EDIT: And this is a new site.
Here's the log for Firefox in which admin login does not work:
Code:
::1 - - [15/Sep/2018:20:47:40 +0300] "POST /gs/admin/ HTTP/1.1" 302 - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0"
::1 - - [15/Sep/2018:20:47:40 +0300] "GET /gs/admin/pages.php HTTP/1.1" 302 - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0"
::1 - - [15/Sep/2018:20:47:40 +0300] "GET /gs/admin/index.php?redirect=pages.php? HTTP/1.1" 200 6366 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0"
And "same" for Chrome in which admin login works:
Code:
::1 - - [15/Sep/2018:20:58:30 +0300] "POST /gs/admin/index.php HTTP/1.1" 302 - "http://localhost/gs/admin/index.php" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.16 Safari/537.36"
::1 - - [15/Sep/2018:20:58:30 +0300] "GET /gs/admin/pages.php HTTP/1.1" 200 25622 "http://localhost/gs/admin/index.php" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.16 Safari/537.36"
have you set your root url to http://localhost/gs in the settings page?
(2018-09-16, 04:53:04)n00dles101 Wrote: [ rel="nofollow" -> ]have you set your root url to http://localhost/gs in the settings page?

U mean the "Website url" field? Yes, it matches and I've tried it with and without trailing slash.

I can confirm that I can login with all other browsers IE, Opera, Chrome and even Tor.

But seems like the solution was to use IP address instead of hostname since http://127.0.0.1/gs/admin/ fixed this problem.
Try with Firefox in a private browser window. If it still doesn't work, try with a new Firefox profile.
(2018-09-16, 17:59:57)Carlos Wrote: [ rel="nofollow" -> ]Try with Firefox in a private browser window. If it still doesn't work, try with a new Firefox profile.

Noup, didn't make any difference.
Just tried Codepen site when I suddenly got an notice: "CodePen requires a referrer to render this. Your browser isn't sending one.".

Could this be related to problems with GetSimple?
I have the problem. Is there no solution?
If I uninstall i18n, then everything is fine again.
Did you just upgrade?
The problem before the update on. It is not tragic. It's just annoying.
I just change from ../admin/pages.php in ../admin/load.php or ../admin/plugins.php and see everything again.

I hoped that there would be a simple solution.
Its an unknown problem that we have never heard before. Would have to debug or look at your logs to find a hint
Is this also firefox only?
The problem occurs with Chrome.
Everything ok with Edge.
A new installation helped me on.

Nevertheless many thanks.
(2018-10-11, 03:23:44)huetes Wrote: [ rel="nofollow" -> ]A new installation helped me on.

Nevertheless many thanks.

What was the difference with the new installation?

How did you do the installation?