GetSimple Support Forum

Full Version: Problem with installing 3.3.14
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi!

I installed clean 3.3.14 Get-Simple and hosted it on my MacBook pro OS integrated webserver. Works fine with PHP 7.1.16. Now I moved the site to my webhost which has PHP version: 5.6.36-0+deb8u1, it says error 500 for the site and admin. Only way to get around this was to comment all in .htaccess's REWRITE section and Options +FollowSymLinks -line. Commenting only +FollowSymLinks -line the site opens but admin still says error 500. 
For the record, RewriteBase is typed the right way: /subdirectory/

Older 3.3.13 versions work fine with same options and server has rewrite enabled.

Is it something I do wrong or something to do with PHP version or version 3.3.14 itself?

Anyway, thanks for the support and great CMS  Big Grin
This is your host configuration most likely and not GS or PHP

possibly they do not allow those directives in htaccess
you can check error log for php errors, but if it works when removing htaccess then its most likely your host
(2018-09-06, 00:36:37)shawn_a Wrote: [ rel="nofollow" -> ]This is your host configuration most likely and not GS or PHP

possibly they do not allow those directives in htaccess
you can check error log for php errors, but if it works when removing htaccess then its most likely your host

Okey, but 3.3.13 and rewrite works fine in same environment. 

Example:
I have GS 3.3.13 working on subdirectory "www.mydomain.com/test1/" and 3.3.14 working on "www.mydomain.com/test2/". 3.3.13 works fine with rewrites but 3.3.14 wont.
Looks like you are right. They have done something and/or updated the webserver:

Options +FollowSymLinks must be commented with #. Otherwise there will be error 500.
RewriteRules are ok and Fancy URLConfused work now.

Strange.. worked before today Smile

Thanks!
maybe has something to do with file pemissions, probably not