GetSimple Support Forum

Full Version: uploadify: Error #2038
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ooops, when I try to upload files over the files manager I get an #2038 Error from Uploadify.
Happens with Firefox 6.02 and I.E. 8, but not with Safari 5.0.5, under Windows Vista.
Any ideas?
your's
felix
what is the server config?
I'm using a hosing service in Germany (Strato).
Don't know, how to get the server config.
Where is it usually located?
your's
felix
ether log in to your GS admin and go to support->health check or create a php page that has this code, then run it:

Code:
<?php phpinfo(); ?>
The first step is to upload a phpinfo.php, call it in the browser, save the results and delete that file after use again, it is not good to have it at the server

Code:
<?php
phpinfo();
?>

The second step is to contact the support of the hoster, as it is their job to help you

Third, there is some info on Strato hosting in our wiki, maybe it helps:
http://get-simple.info/wiki/installation:strato.de

Tschüß, Connie
Thanks for your help!
I had the phpinfo.php running and got the configuration:
This is a lot of stuff - Which of it is relevant for my problem?
And why has it to do with php backend settings, if it is working in I.E. 8?

your's felix

b.t.w.
The ZipArchive is not working either - but I don't mind of this for now.
felixhelix Wrote:ZipArchive is not working either
support->health check should probably tell you that ziparchive isnt installed. It should also giv eyou the server details. This is a better option than phpinfo() unless you understand the jibberish on it.
Yeah, I'm a php newbie :-)
But the health check tell's me everything - but the ziArchive - is fine :-|

I talked to the provider, and according to them SimpleXML, Curl und GD Library are not available in my hosting package.
But this cannot be completely true, for SimpleXML is required and GS is working fine - so far (hope they don't find out it's working and cut it off).

your's
felix
I'm confronted with similar problem: IO error occured while uploading a file.
[Image: ioerror.jpg]

Website settings are fully correct:
[Image: settings.jpg]

So, what's the problem?
what are the permissions on the /uploads/ folder? Who is the owner of that folder?
ccagle8 Wrote:what are the permissions on the /uploads/ folder? Who is the owner of that folder?
The uploads permissions are 777. And its subfolders created by GetSimple have 755 perms. I tried to use all of these dirs to upload files. Unsuccessfully.
About the folder owner... I'm difficulty in it.
I had same problems Error 2038 on my site.
someone found a solution for it ?
can´t upload images.
gugu Wrote:I had same problems Error 2038 on my site.
someone found a solution for it ?
can´t upload images.

I made the following settings in gsconfig.php file:

# Use Uploadify to upload files?
define('GSNOUPLOADIFY', 1);

I works otherwise but it does =)
mogilka Wrote:I made the following settings in gsconfig.php file

Thanks.
I have the same problem on my GetSimple 3.1 installation on Dreamhost
(I've had similar troubles in other CMS tools and I believe it's related to Flash upload).

Workaround: If you disable flash or JavaScript on your browser, you can upload files using the old school HTML form upload Smile
Suddenly I had the same problem when I want to upload a file and it becomes "solved" by changing GSNOUPLOADIFY, like above.
*Thanx!*

Some weeks before, I changed the path to the sites-folders from
http://www.myfirstdomain.tld/gestsimpletest/
to
http://www.newdomain.tld/

I think, that might cause that error.
There must be any place in the config, that doesn´t catch that change.
In the website-check, everything "is green".

regards, Bell.