GetSimple Support Forum

Full Version: Anchor issue and Elementspath
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I've just a small questions to ask if I may.

I've added the Anchor icon to my CKeditor toolbar by using the following gsconfig.php setting.

When clicked on the Anchor icon the insert anchor window pops up OK, I type in a some anchor text (eg "anch1") but nothing happens when I click OK. The window stays there stubbornly. the Cancel button works OK.

To troubleshoot this I installed a fresh install of GS (except for the GSconfig.php setting). I also tried it on CKEDITORS website and all seems to work OK there. I have also tried searching for the issue on this forum and CKEDITORS forum with no luck.

Would someone please try this out to see if it's me that's doing something (or not doing something) wrong.


I run a test:

I wrote some text. I marked text, clicked on the anchor icon, entered the anchor name (Connie) and got an unexpected result:

<a name="Connie"></a>

overwrote the marked text.

1) at least I can confirm that the dialogue does not stay open, OK closes it
2) after closing the dialogue I found no chance to enter the text which should be enclosed in the anchor link
only in HTML mode

I can't help you, but I also see no sense in this

this is a CKEditor-problem, not GS ... ;=(
Thanks Connie for your test. I just wanted confirmation that it's pointing to CKeditor or maybe something to do with my setup.

Even though you came across a diferent issue your could not replicate mine. The mystry deepens Smile

Will investagte further and do some more research and post back here if I found out something useful.

Not a biggie in the scheme of things but I just like to dot all the I's.
stryker Wrote:Not a biggie in the scheme of things but I just like to dot all the I's.

Stryker, that is a very funny expression. I like it!

Well, I once run into problems with dialogue windows not opening or closing
that time I logged out, cleared the cache and logged in again

did you do that?

Did you try with different browsers? Which browser you used? I was using FF 10

Cheers, Connie
Thanks Connie,

Looking back on it this issue had the markings of a "browser" type problem.

I've now discovered that that it only occurs in IE9 (even after cache is deleted) but in combatibility mode the problem is solved.

Less of an issue now that there is a quick woraround. Just another one of those IE things I suppose - Getting quite a list now Smile
Hallo Stryker,

that's why I completely this browser from hell, since it first came out I only used to test when I felt bored
I was sure I will find some incompatibility or unexpected behaviour which will cost me nightshifts -- and I always was right ;=U(