GetSimple Support Forum

Full Version: Updater - keep your GetSimple installation and plugins up to date
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Keep your GetSimple installation and plugins up to date.

Download Updater from GetSimple Extend

Get the latest source for Updater from GitHub

[h]Features[/h]
  • Update your out-of-date plugins with a single click
  • Update your GetSimple installation to the latest version

[h]Installation[/h]
  1. Extract the zip file into your website's plugins/ directory
  2. In the Plugins page in your admin panel, there will be a new menu entry: Updater

[h]Notes[/h]
I cannot guarantee that the automatic updating process will work with every plugin in Extend - it expects that plugins will follow the conventions laid out in plugins:creation - Standard for File & Folder Creation, and will refuse to install / update plugins that don't. Exceptions to this can be configured if desired; see updater/inc/config.php in the source.

As always, make backups (shameless plug for Simple Backups) of your site / plugins, just in case!
Version 1.0.1 of Updater has been released on Extend - this is a bugfix release for anyone running PHP versions older than 5.3.0.
Works great!

Updater updated updater. WHA... I DONT EVEN...

Seriously though, this is so so so handy.
Updater isn't working for me at all. I get the initial interface, but when i choose the plugins i want to update, either "all" or individually, I just get a blank box that says "Updater" and nothing happens. Is this a permissions issue?

On a side note, simple bakup crashes my dashboard when I install it... related issue maybe?

These both sound like useful plug ins and I hope I can get them working.

Any ideas?
eataudio Wrote:Works great!

Updater updated updater. WHA... I DONT EVEN...

Seriously though, this is so so so handy.

Thanks! Glad you like it Smile
Dominic Wrote:Updater isn't working for me at all. I get the initial interface, but when i choose the plugins i want to update, either "all" or individually, I just get a blank box that says "Updater" and nothing happens. Is this a permissions issue?

On a side note, simple bakup crashes my dashboard when I install it... related issue maybe?

These both sound like useful plug ins and I hope I can get them working.

Any ideas?

Hi Dominic,

Sorry about that Sad

If you haven't already, can you please enable debug mode for your GetSimple website, and see if that shows any errors when running Updater?

I've had several people report Simple Backups causing their site to WSOD, when running PHP 5.2 (I was using some PHP 5.3 only features) - updating to PHP 5.3 seems to fix it for them, and I've just released a new version fixing (hopefully) the last of the 5.2-related bugs. If you are running PHP 5.2, please try the new version, and let me know if it's still not working Smile
Quote:If you haven't already, can you please enable debug mode for your GetSimple website, and see if that shows any errors when running Updater?

I've had several people report Simple Backups causing their site to WSOD, when running PHP 5.2 (I was using some PHP 5.3 only features) - updating to PHP 5.3 seems to fix it for them, and I've just released a new version fixing (hopefully) the last of the 5.2-related bugs. If you are running PHP 5.2, please try the new version, and let me know if it's still not working Smile

I had the most recent versions of both installed. I enabled DEBUG mode and got this error when I tried to update some plugins:

"Fatal error: Class 'ZipArchive' not found in /home/dominicwhitestudio/newenglanddrawings.com/plugins/updater/inc/plugins.php on line 96"

I use the dreamhost one-click install of GS and have never been able to figure out how to get ZipArchive to install.
Dominic Wrote:I had the most recent versions of both installed. I enabled DEBUG mode and got this error when I tried to update some plugins:

"Fatal error: Class 'ZipArchive' not found in /home/dominicwhitestudio/newenglanddrawings.com/plugins/updater/inc/plugins.php on line 96"

I use the dreamhost one-click install of GS and have never been able to figure out how to get ZipArchive to install.

Ahh. ZipArchive support usually has to be compiled into PHP by whoever runs your sever -- in this case, that would be DreamHost. You'll need to contact them, and ask if they can add it for you.
Hi,

currently the Updater page shows "Upgrade Check Failed ! " for all plugins.
Maybe this is related to the recent GetSimple site move to a new hoster?

Thanks
Holger
Does health check also fail to check?
No, health check works fine. No errors, everthing "ok".
btw, this happens with an GS 3.2 installation as well as the newest 3.2.1.
Has no one else this problem?Huh
Any ideas?
Any other(better) options to keep your plugins updated?

Holger
Nah I didn't even know this existed .
(2013-05-02, 07:39:19)hd Wrote: [ rel="nofollow" -> ]Has no one else this problem?Huh
Holger

I am having the exact same problem. I'm running Updater 1.0.1 on GetSimple 3.2.1 and having the same "Upgrade Check Failed." error. My system check is all okay.
do you get this for every plugin? or specific ones ?
(2013-05-03, 01:10:19)shawn_a Wrote: [ rel="nofollow" -> ]do you get this for every plugin? or specific ones ?

Every plugin except MLD Newsletter which has an error that says it's version .7 when it's really .8.


PLUGIN INSTALLED LATEST
Innovation Theme Plugin 1.2 1.1 Latest version installed
Send Anonymous Data 1.0 Upgrade Check Failed ! 1.0
I18N Base 3.0.5 Upgrade Check Failed ! 3.0.5
I18N Custom Fields 1.8.11 Upgrade Check Failed ! 1.8.1
I18N Gallery 2.0 Upgrade Check Failed ! 2.0
I18N Navigation 3.0.5 Upgrade Check Failed ! 3.0.5
I18N Search 2.8 Upgrade Check Failed ! 2.8
I18N Special Pages 1.0 Upgrade Check Failed ! 1.0
MLD newsletter 0.7 0.8 Upgrade Recommended 0.8
p01-contact 0.9.1 Upgrade Check Failed ! 0.9.1
Theme Highlighter 1.1 Upgrade Check Failed ! 1.1
Updater 1.0.1 Upgrade Check Failed ! 1.0.1
looks more or less the same for me. GetSimple, Innovation theme and MLD newsletter work, all others get "Upgrade check failed".
Hi Guys, we have a problem on the Extend/API backend which is causing a problem.
Were working on it and hope to have it fixed this evening...
Awesome, thank you! And thank you for all your hard work on GetSimple!

Speaking of updaters... is there any plan to make GetSimple itself automatically updatable at the push of a button?
Yes, many thanks for this great CMS and your support!
Should work now, I do not have an htaccess file for images however, so no icons.

It appears that this plugin has backwards htaccess rules.
Denys in all folders , no allows.

I believe plugins is already deny all. So this should be reversed.
Hi Shawn,

it works for more plugins for me now, but not for all:

Plugin Installed Latest
Innovation Theme Plugin 1.2 1.1 Latest version installed
Send Anonymous Data 1.0 Upgrade Check Failed ! 1.0
Mp3 Player Ultimate 0.2e 0.2e Latest version installed
HitCount 2.1 Upgrade Check Failed ! 2.1
i18n_base.php disabled Upgrade Check Failed ! disabled
i18n_navigation.php disabled Upgrade Check Failed ! disabled
kt block login 2.0 2.0 Latest version installed
MLD newsletter 0.8 0.8 Latest version installed
Auto-open Page Options 1.0 Upgrade Check Failed ! 1.0
Updater 1.0.1 1.0.1 Latest version installed
Multi User 1.8.2 Upgrade Check Failed ! 1.8.2
SEO Manager 1.0 Upgrade Check Failed ! 1.0

Thanks
Holger
it should be sorted now, the files are cached on the server , try again in a few hours any they should all be updated.

If you still have a problem in the morning, post the results again and I'll investigate the problem ones...
(2013-05-03, 09:04:45)n00dles101 Wrote: [ rel="nofollow" -> ]it should be sorted now, the files are cached on the server , try again in a few hours any they should all be updated.

If you still have a problem in the morning, post the results again and I'll investigate the problem ones...

Still getting the same errors but will wait till morning and check again.
(2013-05-03, 08:43:44)hd Wrote: [ rel="nofollow" -> ]it works for more plugins for me now, but not for all:
i18n_base.php disabled Upgrade Check Failed ! disabled
i18n_navigation.php disabled Upgrade Check Failed ! disabled

These will continue to fail, as it's two plugin files packed into one zip (with a different name) - because of technical reasons. But in the meantime I have found some workarounds around the limitations of GetSimple, so I might try to merge them again.
Pages: 1 2