GetSimple Support Forum

Full Version: Can't log in to admin panel
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I'm trying to log in to Admin panel, after pressing button "Login" I'm being redirected to a blank page and the link looks like - .com/admin/index.php?
Dafuq?
Try enabling debug mode to see if there are errors
http://get-simple.info/wiki/doku.php?id=debugging
What is your browser and OS? I was experiencing this issue in Google Chrome with Windows 8.
Windows 7, FireFox.

After enabling debug mode I see this in my home page:

Strict Standards: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/plugins/news_manager/inc/functions.php on line 18

Strict Standards: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/plugins/news_manager/inc/functions.php on line 18

Strict Standards: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/plugins/news_manager/inc/site.php on line 97

Strict Standards: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/plugins/news_manager/inc/site.php on line 97

Strict Standards: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/plugins/news_manager/inc/functions.php on line 86

Strict Standards: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/plugins/news_manager/inc/functions.php on line 86

***

I actually deleted something about time from (if I remember correctly) theme's files...
I restored deleted line, but it won't helped
We have been seeing alot of these reports.
Try clearing your cookies ?

Not really sure what the exact cause is. But none of those errors are fatal.
I also can't use BB tags here at forum.

At admin index page I see nothing but this:

Strict Standards: SimpleXMLElement::__construct() [simplexmlelement.--construct]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/admin/inc/logging.class.php on line 44

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: Entity: line 2: parser error : Input is not proper UTF-8, indicate encoding ! Bytes: 0x8D 0x61 0x72 0x64 in /home/***/domains/***/public_html/admin/inc/logging.class.php on line 44

Strict Standards: SimpleXMLElement::__construct() [simplexmlelement.--construct]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains***/public_html/admin/inc/logging.class.php on line 44

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: ate><IP_Address><![CDATA[***]]></IP_Address><Username><![CDATA[ri&Auml; in /home/***/domains/***/public_html/admin/inc/logging.class.php on line 44

Strict Standards: SimpleXMLElement::__construct() [simplexmlelement.--construct]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /home/***/domains/***/public_html/admin/inc/logging.class.php on line 44

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: ^ in /home/***/domains/***/public_html/admin/inc/logging.class.php on line 44

Strict Standards: Unknown: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in Unknown on line 0

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /home/***/domains/***/public_html/admin/inc/logging.class.php:44 Stack trace: #0 /home/***/domains/***/public_html/admin/inc/logging.class.php(44): SimpleXMLElement->__construct('<?xml version="...') #1 /home/***/domains/***/public_html/admin/inc/login_functions.php(36): GS_Logging_Class->__construct('failedlogins.lo...') #2 /home/***/domains/***/public_html/admin/inc/common.php(249): include_once('/home/***/...') #3 /home/***/domains/***/public_html/admin/index.php(14): include('/home/***/...') #4 {main} thrown in /home/***/domains/***/public_html/admin/inc/logging.class.php on line 44

***

I haven't changed anything in logging.class.php file.
Have you changed anything in GetSimple's core files?
What's your PHP version?
This is due to a headers already sent issue.
If you modified any php files or installed any new plugins try disabling them.

Its possible a php file has an empty line after the closing tag, or a BOM character.
You can remove any of this in any files you edited to see if it fixes it.
Php 5.2.17

All I have changed is theme via theme editor in admin panel. Well, I could also change something in News plugin, but I'm not sure about that because I don't remember that. Anyway I will try to remember...

PS. Maybe it's because I edit files with WordPad?

Or I will just reinstall all Smile It's not a big problem
If you have to edit GS or plugin files, forget about Wordpad or similar: use an editor that allows you to save as UTF-8 without BOM, e.g. Notepad++
yes use notepad and remove all whitespace or remove the php closing tags.
Anyway it's a good idea to delete everything and reinstall (if you're just testing) before posting your problems, especially if you have been modifying core or plugin files, even if you use a proper editor.

It's very difficult or impossible to troubleshoot if code has been modified and we don't know what. Results can be unpredictable.

Does it work now?
Yep, sry, I reinstalled all and now I'm using Notepad++. All are working fine, I'm just looking for simple CMS for my personal blog/page, and I rly like Get-Simple Heart

Administrators can delete this "dirty" topic since it hasn't got any value Big Grin

Thx for fast responses, u have really nice community here Smile
We won't delete it, because it might be useful to others with the same problem.
But glad it worked Smile and thanks for using GetSimple!
I believe some of the admin login problems are caused by the browser time being different from the time() time used when setting up the cookie.
There is a timezone setting in the admin area. Default is empty. We should force the user to select their time zone.
the issue is maybe due to the multiuser plugin.
When we create a new user we can manage the timezone too.
Clear cache and cookies. Or use different browser. Sometimes it's helpful to delete all pages files from data folder. Then you HAVE TO set up timezone.
Usually deleting all pages (except for index) from data folder helps with troubles in accessing admin. Then just add one page at a time until you find which one makes troubles.
You should never have to delete pages for any reason.
Hi,
i'm having the same problem on 3.2 - 3.0 works just fine. I also see the time warning. I tried to re-install multiple times and using different browsers - i'm not able to login. I'm back 3.0 for now.
Any suggestions?
Please be more explanatory.
Hi,

I can't login either, it redirects me to the same admin page
Did you try anything posted?
Debug mode? Errors? Clear cookies?
Hi,

Yes everything. What else can I do? I made backups regulary, how can I transfer the backup? Will that work?

Or can I overwrite something with the original version?

(2013-03-06, 00:15:29)shawn_a Wrote: [ rel="nofollow" -> ]Did you try anything posted?
Debug mode? Errors? Clear cookies?
Hi,

i got this:

Warning: file_get_contents() [function.file-get-contents]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/recordst/public_html/Thomas/admin/inc/template_functions.php on line 1055

in all my plugins...


(2013-03-06, 01:06:17)Thomas_ Wrote: [ rel="nofollow" -> ]Hi,

Yes everything. What else can I do? I made backups regulary, how can I transfer the backup? Will that work?

Or can I overwrite something with the original version?

(2013-03-06, 00:15:29)shawn_a Wrote: [ rel="nofollow" -> ]Did you try anything posted?
Debug mode? Errors? Clear cookies?