GetSimple Support Forum

Full Version: I can not access the admin panel
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello. My problem is:

I downloaded the latest version of the get-Simple 3.1.2
Installed correctly
I changed the admin password, the first visits.
Wrote "Hello" on the main page
Deactivate plugins (2 by default)
Clean all of the cookies in the browser
And now I can not log in to the admin panel
I enter the correct data, but no error message is presented. And again there is the authorization form.

Please help me, I don `t know what to do. I tried to put all the folders and files on the right 777, tried to use the password recovery. Tried to delete all the contents of the plugins. When you turn on debug mode, check any error messages on the site is not displayed.

admin panel:
user: admin
pswd: 661080
admin panel:
user: admin
pswd: 661080"

i had no trouble entering with my browser [safari]. You might try using a diff browser from the one you normal use. If that doesn't help, all i can suggest is a new-install.
I tried these browsers:
Chrome - not authenticated
Opera - not authenticated
Firefox - will be logged
Safari - not authenticated
IE - not authenticated

All browsers are updated to the latest versions, except IE.
Unfortunately I was not able to identify the problem.
Wrong password?
You have to clear cookies.
For the record - I have experienced this problem, that is totally locked out of the backend. Realised that I wasn't getting the red box that warns of a wrong password or username, just the same invitation to login again and again, endlessly.

With ftp I removed linkjuice.php from the plugins folder. Then I could log in. put the plugin back, locked out again; deleted the plugin, logged in again. Something to do with redirects, then?
Whats linkjuice ?
Check your error log
Linkjuice is a plugin from extend:
which eliminates 404 errors.

Everything is working without it.

My error log, did you want to see it? It's long. I can see this repeated many times which might be for each failed login:

[13-Jun-2013 15:05:08 UTC] PHP Warning: file_get_contents( [<a href=''>function.file-get-contents</a>]: failed to open stream: no suitable wrapper could be found in /users/timbowgs/www/admin/inc/template_functions.php on line 1055
[13-Jun-2013 15:05:10 UTC] PHP Warning: file_get_contents() [<a href=''>function.file-get-contents</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /users/timbowgs/www/admin/inc/template_functions.php on line 1055
[13-Jun-2013 15:05:10 UTC] PHP Warning:
Looks like your api checks are failing and you do not have curl. It would be somewhere else in the log, thats cluttering it up. This is fixed in 3.2.2, well the errors that is.

404 redirection did change a bit in 3.2.1. hmm i wonder what this plugin does.
It uses index-pretemplate hook and we moved it i think.
checking now.
Works for me, 3.2.1, latest linkjuice, login just fine.

You didn't say which version, but i am guessing its some wierd combination that causes this, the plugin doesn't do much and is unprecise, it will redirect anything that is not the same host and since _SERVER is not very reliable, this might break on virtual hosts, it also uses find_url, which varies depending on if prettyurls is on or not and what your permalink structure is.

This plugin is wrapped with a big ole backend filter which is the hook pre-template, so I have no idea how it would interfere on the back end, so everything I said before is probably invalid.
Shawn, thanks for looking. It isn't a big issue for me. I put this plugin on several sites and that is the only one broken. Plus I know now what the problem is if it happens again.
Yeah thats strange its almost as if the login was redirecting you back to the front end or a template file for it to even fire that hook. Of course it could be some fatal error being thrown also.