GetSimple Support Forum

Full Version: Wiki mainpage
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I tried to ad 2 things to the main page in the wiki, but now the styling is all wrong. I think I did it following the right approach qua code, but now it's f#cked up. I tried to restore the code from Noodles, but that didn't work.

Sorry!

I try to fix it later, after some reading. But if someone wants to look into it, that would be nice.

Edit:
Quote:Paragraphs are created from blank lines. If you want to force a newline without a paragraph, you can use two backslashes followed by a whitespace or the end of line.

This is some text with some linebreaks
Note that the two backslashes are only recognized at the end of a line
or followed by
a whitespace \\this happens without it.

This is some text with some linebreaks\\ Note that the
two backslashes are only recognized at the end of a line\\
or followed by\\ a whitespace \\this happens without it.
You should use forced newlines only if really needed.

I tried this in the playground of the wiki-editor. but the editor is just removing the second \ , this can be seen in a preview. Actually if you click another time on the preview button the first \ is also removed.

This does seem to work with the playground of the dokuwiki site:
https://www.dokuwiki.org/playground:playground
Wait what?
Edit: I see, very odd.
Edit2: Hmm, I don't know how to fix it Sad Perhaps somebody who actually knows how to use DokuWiki could look. Perhaps you messed up the Syntax.
(2013-03-02, 04:11:38)shovenose Wrote: [ rel="nofollow" -> ]Wait what?
Edit: I see, very odd.
Edit2: Hmm, I don't know how to fix it Sad Perhaps somebody who actually knows how to use DokuWiki could look. Perhaps you messed up the Syntax.

The DokuWiki editor seems to remove backslashes automatically.
Can't you just undo your edits
(2013-03-02, 05:52:10)shawn_a Wrote: [ rel="nofollow" -> ]Can't you just undo your edits

I don't think I can. I can go back to an earlyer revision:

Quote:These are the older revisons of the current document. To revert to an old revision, select it from below, click Edit this page and save it.
If I edit the older revision and save it, the editor removes the backslashes anyway. Is this some bug, or could it be browser related? I'm using Chrome in Windows 7. Edit: same behavior in Firefox.

What I said, the editor is removing the backslashes, not even the ones I added, all of them. Two \\ after some text, means linebreak. So if that's all removed you get what's seen on the wiki at the moment.
Ahhh, does reverting get corrupt to?
please go back to an earlier version and recover the main page

all lists are gone, that is not good

if you broke the complete layout, you have to go back until everything is ok without your additions
then you can start to add new content
before you publish, please do a preview!!
Did you even bother to read his posts, Connie ?
I did, but maybe I am too limited to understand

at least: who can repair that deseaster? I compared versions and there are versions where the layout is kept ...

so maybe recover these?
I too had found the formatting of new lines not obvious when I went to try out wiki editing in the playground. I assumed it would become clear to me how it worked, I don't know if it was a malfunction.

Anyway there is nothing resembling a desaster. I had intended to have a go at making a new wiki index page in the near future, maybe leaving the old one intact as well while doing the new work. What is needed is some careful thought to make a new hierarchy of links and headings, and some consensus from users too. If the old table of contents can't be restored it is no matter because it was well overdue for replacement.
Well we could re-organize it, yes it's overdue, great, but my concern is what actually caused the problem and how will we prevent it from recurring again in the future.
(2013-03-02, 12:18:10)shawn_a Wrote: [ rel="nofollow" -> ]Ahhh, does reverting get corrupt to?

Yes

I was editing it to improve some sections:

http://get-simple.info/wiki/how_to move the pages under Theme Management to the main Theme table-cel on the main page. And after that, remove this page: http://get-simple.info/wiki/themes

What version of Dokuwiki is this site using? Maybe it's a bug in that version.

I think using this table in a wiki is not perfect, because it is difficult to edit and style.
Maybe the main page can be styled with something like this: https://www.dokuwiki.org/plugin:dwmenu
Or this: https://www.dokuwiki.org/plugin:wrap
Yes it's very non optimal.
Yeah do not edit anything there is something wrong here.
ok i've manually edited the file on the backend and restored all the linebreaks which are being removed by dokuwiki for some reason.

I'll disable editing until we can figure this out...
although I've disabled future logins and edits to the wiki if you have already got a cookie you'll still be able to edit.

Will hopefully get this sorted soon....
(2013-03-03, 09:32:24)n00dles101 Wrote: [ rel="nofollow" -> ]although I've disabled future logins and edits to the wiki if you have already got a cookie you'll still be able to edit.

Will hopefully get this sorted soon....

Thanks
Noodles, thank for your work! Now the starting page looks ok and usable again

I could log in, but I will not edit in near time, promised...
The Wiki should be available and editable again.

Problem was due to authentication with MyBB forum which was stripping the slashes....
Stripping the tags?
Oops, meant slashes...