GetSimple Support Forum

Full Version: Fancy Url Works for Pages, not Blog Posts
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I installed gsBlog on my website, and while fancypants url generation works for pages, it's giving me a 404 on blog posts. Same issue with clicking on tags as well.

If it was .htaccess then it wouldn't work for either page type, so I don't believe that's the issue. But stranger things have happened. Here's what my file contains:

Code:
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule /?([A-Za-z0-9_-]+)/?$ index.php?id=$1 [QSA,L]

Did I miss a configuration in the admin?
For blog plugins you have to add the plugins rules also for the rewrites.
(2013-05-15, 11:38:56)shawn_a Wrote: [ rel="nofollow" -> ]For blog plugins you have to add the plugins rules also for the rewrites.

Is that mentioned in any of the wikis? I don't see it in the plug-in page for this.
(2013-05-20, 00:32:43)el_fuerte Wrote: [ rel="nofollow" -> ]
(2013-05-15, 11:38:56)shawn_a Wrote: [ rel="nofollow" -> ]For blog plugins you have to add the plugins rules also for the rewrites.

Is that mentioned in any of the wikis? I don't see it in the plug-in page for this.

isn't there an instruction in the settings?
As far as I remember you have to define that you want PERMALINKS for the blog posts and after that you will get the code which you have to add to your .htaccess file

check the settings of the plugin
Gs blog even has them listed on its settings page when you enable fancy urls. You can't miss it not sure how you did.
I am an idiot; I missed the hyperlink at the bottom of the blog settings page. Sorry about that.
no sorry ;=)

it#s good that it is working for you now!

Cheers. Connie