GetSimple Support Forum

Full Version: installation syntax error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
first of all I like your kick ass CMS a lot Smile

A problem encountered:
I installed getsimple on one of my servers without problems, very smoothly.
I installed the same version - 1.4 - on another server of mine and I got this:

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in
{URL}/getsimple/admin/inc/basic.php on line 85

(I put here{URL} instead of the complete address for privacy)

Any idea?

Thanks in advance!
Is this while you are installing or after you have completed the install and are messing with other functions?
It comes instead of the installation.
I tried to load again, I tried to load the 1.3 version too with the same result.
This is by IX servers, where I installed OsCommerce and WordPress without problems.
It sounds like the XML files are getting corrupted or not parsed correctly. Just try chmod'ding everything to 777 and try it again.
Gameover- do you see any xml files in the /data/other foler on your server?
ccagle8 Wrote:Gameover- do you see any xml files in the /data/other foler on your server?

Not at all.
Try the CHMODding thing, it sounds like it's trying to load/create the files, and it is erroring because it doesn't have the permissions. Would test myself but really backed up at work today
I just tried set up of GetSimple and I had the same problem on my web hosting.
I fixed that problem.

I guess your web server is running with php4.x
I think you need to force php5, maybe in a .htaccess in root directory of getsimple (if you don't have access to the php.ini).

Put that in a .htaccess file

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
Thank you littlebzh... I dont know how I would have been able to diagnose this since I dont have a php4 host to test with.

I'm glad to help you.
Your CMS is exactly what I want to set up a little and fast web site.
Maybe it would be a good idea to put that information in your documentation ou put a .htaccess in GetSimple's directory.
In my experience, some hosts have both PHP 4 and PHP 5, but in order to get 5 you need to "force" it as littlebzh states. However there are some hosts that are only running PHP4, so "forcing" it will do nothing.
@littlebzh - running on GoDaddy?
Maybe just write in documentation that php5 is a requirement ?
and that a .htaccess is a good solution to select php5 on your host.
It seems GetSimple can't directly run on php4.

no, my web site is running on which provides php4 (default) and php5.
@littlebzh - I think it says PHP 5.1.3 *is* a requirement on the home page of the site Wink
So did you get it running now?
badcat Wrote:@littlebzh - I think it says PHP 5.1.3 *is* a requirement on the home page of the site Wink

Arf... I need to RTFM first;o)
The REQs should probably be repeated on the Installation page. (a note for Chris... The Readme actually states the Req is for PHP 5.2+, while the Home page states 5.1.3+)
Good point badcat. I will get these fixed in the next release.