GetSimple Support Forum

Full Version: Can`t enter in the admin panel
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Login and password are correct.
Hoster has LiteSpeed WEB server (not apache).
Please advise what can be done?
(2013-06-09, 07:22:36)Roman Wrote: [ rel="nofollow" -> ]Please advise what can be done?
About what ? Are you unable o log in or what ?
It's just a warning. You can disable apache check. Just edit the content of gsconfig file.
We should hide that on front pages.

Is there another error when logging in?

Turn on debug mode check for errors and error.log
I am not unable to log in.
So it is impossible turn on debug mode in the admin panel.
There are no other errors when logging in.
You don't enable debug mode in the admin panel, but in gsconfig.
See here: http://get-simple.info/wiki/debugging
ок i turned on debug mode ( define('GSDEBUG', TRUE); ) and tried to log in,
but error.log is not created
Any errors (warnings, notices) would be displayed in the page (or its source code) with debug mode on.

What happens if you try to reset your password? ("forgot your password?" link)
if i try to reset my password, i just get a new password without any problems
And you cannot log in with that new password?
absolutely true
Does your username contain any non a-z, 0-9 characters? (e.g. spaces or other symbols, non-English letters...)
Username containes just a-z characters.
Domain name consists of Cyrillic letters.
Maybe the problem is related to the localization.
It may be the domain name.
If you entered the website base url with cyrillic characters, GS may have trouble. I think it should have e.g. "xn--b1agh1afp", not "Привет"
If so, it's a pity!
GetSimple looks very good...
We use the site name for the cookie so quite possibly. Hmm can you pm me and get us a copy of your website.xml and user file?
Or modify and confirm at least?
Thanks a lot. It sems cookie block access to the admin panel if domain name is not in english.
So i can log in if cookies are disabled in browser.
ok so for some reason there was no error thrown, and we have a problem with what cryllic host names ?
This might be related to actual cryllic domain names, because it works fine with siteurls.
Perhaps suggest_site_path() has an issue.
eg
PHP Code:
        $fullpath $protocol."://"htmlentities($_SERVER['SERVER_NAME'], ENT_QUOTES) . $port "/"

I would need to test further or create a cryllic virtual host or alias to test with.
Problem is we have no actual error message to start with , I bet something is supressed with @

Carlos any other ideas?
I think that's not the issue. Roman should do more tests, with other browsers, and report.

Yesterday I could log in to the site's admin panel without trouble (with the user/pass he/she sent me). I checked the website url and it was correct (xn--... domain), so there should be no problem, it's just 7bit ASCII.
I think he changed it to get it working, thats not the real url. That info does not help us at all.
Hm, strangely
I can`t log in with Internet Explorer & Opera
And log in with Google Chrome
In Internet Explorer аfter a failed attempt to log in, i see a forwarding address:
http://возврат-комиссии..../pages.php
I bet there is an error being hidden somewhere with a @ or a redirect is hiding it.
hmm
There is described a similar problem in Russian-speaking users GetSimple:
http://webdev.wakh.ru/2012-10-02/getsimple-error-login
http://get-simple.ru/forum/viewtopic.php?id=84
(Sorry, I can only offer google translate for this)
I can log in, log out, log in again. No problems.
Firefox, Chrome and IE8.
Pages: 1 2