GetSimple Support Forum

Full Version: Problem in menu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I need your help. I've tried to solve this problem during few days but no way.

As you can see in my attachment[attachment=221], my start page does not display the menu ! Why ? In all other pages, menu is displayed.

I do not find the correct configuration to display the menu on the start page.... Am I stupid ? maybe...

Thank you for your help
Do you have several templates?

- If yes, does the one assigned to the index page have a get_navigation tag?

- If not, what is your get_navigation tag like? Is it standard (<?php get_navigation(return_page_slug()); ?>), or is there something different there? (or is it enclosed between some conditional...?)
Mmhh problem is that I am a real rookie on Get-Simple. I just need to modify a website done by a old teammate. So I'm not sure to understand your question. What do you mean by template ?

I'm using theme SimpleBusiness.

Where can I find response to your question ?

By changing "Thème" from index to sidebar-left, i can display the menu as you can see [attachment=222] but then there is not content on my page ...
A theme can have several templates, that define the layout of the page.
A page is assigned by default the template.php Default template, but can be assigned a different one.

It seems your index page has a custom template with content stuffed in it.

You can edit your templates (if you're comfortable with html code) in admin -> themes -> edit theme

By what you say, your index's template seems to be missing the <?php get_navigation(return_page_slug()); ?> template tag (or similar -- take a look at it in your sidebar-left template).

I suggest you do a backup before changing anything, if you're not used to GS. I also suggest you take a look at the wiki (if you're going to this yourself)
Here is the code for my index's template. Do you see something wrong ?

Please note that my others pages have :

<ul id="navigation">
<li id="hover"></li>
<?php get_i18n_navigation(return_page_slug()); ?>
</ul><!-- /#navigation -->

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title><?php get_page_clean_title(); ?> | <?php get_site_name(); ?></title>
<?php get_header();?>
<link rel="stylesheet" href="<?php get_theme_url(); ?>/css/reset.css" type="text/css" />
<link rel="stylesheet" href="<?php get_theme_url(); ?>/css/text.css" type="text/css" />
<link rel="stylesheet" href="<?php get_theme_url(); ?>/css/style.css" type="text/css" />
<script src="<?php get_theme_url(); ?>/js/jquery-1.3.2.min.js" type="text/javascript"></script>
<script src="<?php get_theme_url(); ?>/js/jquery-ui-1.7.2.custom.min.js" type="text/javascript"></script>
<script src="<?php get_theme_url(); ?>/js/jquery.cycle.min.all.js" type="text/javascript"></script>
<script src="<?php get_theme_url(); ?>/js/jquery.easing.js" type="text/javascript"></script>
<script src="<?php get_theme_url(); ?>/js/jquery.easing.names.js" type="text/javascript"></script>
<script src="<?php get_theme_url(); ?>/js/cufon-yui.js" type="text/javascript"></script>
<script src="<?php get_theme_url(); ?>/js/custom.js" type="text/javascript"></script>
<script src="<?php get_theme_url(); ?>/js/TitilliumText15L_100-TitilliumText15L_800.font.js" type="text/javascript"></script>
<script type="text/javascript">

$(document).ready(function(){

$('.mini-slides').cycle({
fx: 'fade',
timeout: 7000,
speed: 1000
});

//add classes for the numbered backgrounds in the three columns
$('.col1:eq(0)').addClass('one');
$('.col1:eq(1)').addClass('two');
$('.col1:eq(2)').addClass('three').addClass('no-right-margin');

})

</script>

</head>

<body>
<div id="main">

<div id="top">

<a href="/" id="logo"><img src="<?php if(gst_get_themesettings('logo')) {echo gst_get_themesettings('logo');} else {echo "Simple<span>Business</span>";}?>" alt="<?php get_site_name(); ?>" /></a>

<?php get_component('simplebusiness_sociallinks');?>

</div><!-- /#top -->

<ul id="navigation">
<li id="hover"></li>
<?php get_navigation(return_page_slug()); ?>
</ul><!-- /#navigation -->

<div id="featured">

<div id="arrowLeft"></div>

<?php gst_superslideshow('slideshow'); ?>

<div id="arrowRight"></div>

<div id="slogan">
<h1><?php echo gst_get_themesettings('slogan_h1');?></h1>
<h2><?php echo gst_get_themesettings('slogan_h2');?></h2>
</div>

<div id="slideNav"></div>

</div><!-- /#featured -->

<div id="contentHome">

<?php $items = gst_childpages(return_page_slug(), 'title');?>

<?php foreach($items as $item):?>
<div class="col1">

<?php echo $item['content'];?>

</div><!-- /col1 -->
<?php endforeach;?>

<div class="clear"></div>

<div class="get-started">

<h1><?php echo gst_get_themesettings('getstarted_text');?></h1>

<a href="http://posi.intranet.dom/contact/"><?php echo gst_get_themesettings('getstarted_button');?></a>

</div><!-- /.get-started -->

</div><!-- /#content -->

</div><!-- /#main -->

<div id="footer-wrapper">

<?php get_component('simplebusiness_copyright');?>

</div><!-- /#footer-wrapper -->

<script type="text/javascript"> Cufon.now(); </script>
</body>
</html>
Problem is solved by changing the index.php and by using get_i18n_navigation(return_page_slug());

Thx for your help, you are a KING :-)