GetSimple Support Forum

Full Version: Feature Tests / QA
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I am testing our new uploader for uploadify replacement.

It has modern browser support so some users will lose their uploader and fallback to form uploading.

But must move forward.

That being said some testing would be great before i merge it into master branch ( next release, NOT CURRENT BETA! )


Feedback on browser tests would be great, if we have to we can write fallbacks or plug uploadify back in as a module.

See issue # for browser support.
Also mobile support is a plus
do you want us to post here or create issues on GH ?
here is fine, of course if you are familiar with github that is fine too
Windows, XAMPP
Notice: Undefined variable: isUnixHost in C:\[...]\admin\upload.php on line 308
One notice per file uploaded.

Also, I suggest you hide "Drop files here" box if js disabled.
It was hidden, I must have changed something and did not retest it.
Should be fixed now
I think gsnouploadify should still work also, if one want to turn it off.
Windows Xampp/Chrome..

Uncaught ReferenceError: diff_match_patch is not defined in codemirror on all pages.

when uploading on windows hosts
Notice: Undefined variable: isUnixHost in C:\xampp\htdocs\gs\admin\upload.php on line 308

when uploading a file that already exists, it pop up do you want to overwrite. If you say yes it uploads and renames to filename_x.jpg

After an upload, clicking on delete files just deletes them, no confirm box.. tied into the ajax/JS live events

On front end
Notice: Undefined variable: description in C:\xampp\htdocs\gs\admin\inc\theme_functions.php on line 119
oops fixed, bad merge

the unrelated stuff is known issues
How exactly works the install? Is this the full GS install, or should I copy it over the developer-GS version (3.4.0b)?
Ok I got it working:

Using UwAmp:

Uploading images goes fine, although:
("Upload files and/or images..." -> images are not files?.

1. If I try to upload same filenames I uploaded earlier, I get question to overwrite existing. After another, I get question to ignore these questions (don't remember the exact text, not possible to reproduce). If I say yes, it's impossible to upload these files again by overwriting existing. Tried removing browser cache, cookies etc.

2. After removing one image it's not possible to remove another. Until I disable JavaScript, then I can delete files again. When Javascript is disabled I can still do multiple file upload in one move (tested this in 3.2.3, got fatal error).
That is what it has always said, I didn't change that, I just changed the uploader.

What Browser / OS ?
That is a browser thing, not gs. "Prevent additional dialogs" you have to reset that somewhere.
(2013-12-05, 08:22:24)shawn_a Wrote: [ rel="nofollow" -> ]That is what it has always said, I didn't change that, I just changed the uploader.

What Browser / OS ?
That is a browser thing, not gs. "Prevent additional dialogs" you have to reset that somewhere.

Chrome, Windows 7

Ok issue is gone after restart... ignore my earlier post.
Testing 3.4 features snippets and page drafts in one branch before they touch master.

Please test it out
(2014-11-23, 11:20:20)shawn_a Wrote: [ rel="nofollow" -> ]Please test it out

Initial observations. Clean install to an empty web root; Linux, Apache 2.2, PHP 5.5.18.

Errors showing:
Warning: file_put_contents(<webroot>/data/other/plugins.xml): failed to open stream: No such file or directory in <webroot>/admin/inc/basic.php on line 676

Warning: chmod(): No such file or directory in <webroot>/admin/inc/basic.php on line 774
(Possibly an order-of-events problem – pages.xml does exist and chmod() works.)

Cannot change language in install screen. Preferred language can be selected from the drop-down, but reverts to en_US.

Post install, second login (after changing password):
General settings: Website URL, Local Timezone and Email Address fields are empty. Site seems to work okay. Saving the corrected settings again, they are not persistent.

Website healthcheck:
.htaccess checks show errors (have you rationalised the .htaccess files?):
/    Good file    OK
/data/    Good 'Deny' file    OK
/data/uploads/    Good 'Allow' file    OK
/data/users/    Missing file    Warning
/data/cache/    Missing file    Warning
/data/thumbs/    Good 'Allow' file    OK
/data/pages/    Missing file    Warning
/plugins/    Good 'Deny' file    OK
/data/other/    Missing file    Warning
/data/other/logs/    Missing file    Warning
/theme/    No file    OK

Support -> View Logs -> Failed Logins, with Debug enabled, shows 'No such file or directory' warning. Maybe touch /data/other/logs/failedlogins.log during install?

View Logs button should remain active, to reload logfile selection page.


Is there a write-up on how this should work, please? It's probably easy when you know how ... Wink

Create New Page defaults to Published – should I be able to save a draft copy for subsequent finishing & publishing? Couldn't work out much more, but I hope to spend some more time on it later.

Nice that the right-column buttons remain in view while editing a long page. Please duplicate 'Other Actions' as well as 'Save Updates'.


Deleting a Snippet shows 'Component was deleted' notification.

General impressions:

Looks good. I like the tabbed page editing view. The animation of the notification messages is a bit 'bouncy' – it's very easy to click on the wrong thing as the page moves when the notification is removed. Perhaps I'm just not in the target demographic! Big Grin

Thanks for your hard work.

some of these were expected or known, or on purpose.
I just pushed some fixes for some of these right now.

I had no problem with pages.xml though.

drafts are draft versions of published pages, there is always a published page
the only doc is that github issue linked #570 you could read it all, some of its irrelevant however.
But it does summarizes it.

I was wondering if perhaps not show that published on new pages, as it could be confusing, maybe that small fix will ease it. The rest is pretty straight forward, but it could use some annotations, but i didn't want to break existing translations, i need new strings to change buttons to "create draft" the first time so the labels are greyed to instead on an unsaved first draft to indicate this. So your input is useful, in making this simpler.

I have not tested mutiple language install yet, but its possible its fixed by another change
(2014-11-24, 02:00:54)shawn_a Wrote: [ rel="nofollow" -> ]I just pushed some fixes for some of these right now.

Just a quick try with the latest fixes. Not exhaustive.

Same errors on install screen with pages.xml (as before).
Cannot select install language (as before).

Website settings are now saved (fixed).
Fading notifications is better (imo).

Cannot save changes in Page Edit: neither changes to existing page nor create new page. No debug message.
Ajax saving is enabled are you getting an ajax indicator at top even?
Check js console?

I'll check on the rest of these.
Nm same here, sorry must have broke something.
I think I have page saves fixed now
be aware of this bug, still not fixed
(2014-11-24, 08:25:21)shawn_a Wrote: [ rel="nofollow" -> ]I think I have page saves fixed now

When publishing a draft (replacing a live page), the menu order is not respected (reset to #0).

I would really like to be able to have a draft page without a corresponding published version. So many advantages for the target user (essentially, not having to make a complete page in one go, whether for time-constraints, technical reasons, having to find the right graphic, whatever), as well as opening the possibility for pages embargoed by date, a feature oft-mentioned here, even if auto-publishing is left to a plugin.

Apart from that, the presentation of the page edit screen is good. Easy to get an overview of the current situation and easy to use.

Snippets first impressions.

Long-awaited, very nice – html components with editor. I see that you've even prepared the included templates to use them, Wink

I would really like these to have their own top-level tab (Pages, Snippets, Files, ...) for easier access. Logically, there is no reason for them to be associated with the themes tab (same with components, come to that – they're not limited to a single theme) and would allow site editor access while blocking theme access (e.g., Multi User).

Incidentally, there is no notification of changes having been made (red border to the save button) nor warning of unsaved changes in both Snippets and Components when moving away from the page. I think it's always been like this, but can easily lead to losing changes. Any chance of improving this, please?
Yes I agree on most of that and are still thinking about making dirty form indicators across all of core.

Components are also all saved at once, so even deleting them does nothing until save. So I have some problems to solve but it has always been like that.

I agree on the tabs thing but this could be a plugin since people's might not want to waste their precious tab space.
The github issue on page drafts explains a lot of my concerns with using drafts as non public pages.
It is better to think of drafts atm like backups, they are just versions of a page, they are not plumbed into the pages view, so atm there is no way to even get to them if there was not a corresponding page to begin with.
( this also forces them to be compatible with i18n plugins )

Handling whether a page is public or not, might be something else entirely and have nothing to do with drafts. As i mention private and public toggles we already have.

before release this will have to be worked out, also a cache needs to exist first to even consider offering draft creation as default so that we can show them somewhere for example, without having to load all draft files on every page load.

And I do have the plumbing for default mode toggling by user, just that there is no link to get to drafts atm.
explains everything about the state of this feature atm.
"When publishing a draft (replacing a live page), the menu order is not respected (reset to #0)."

Can you elaborate ?
Do you mean menu priority?

I am not finding this to be the case trying to reproduce.
Pages: 1 2