GetSimple Support Forum

Full Version: Loop Pb not fixed
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi !

It's just to inform you that the loop pb during installation is not fixed with the version 1.4...
I'm just waiting for a pacth before trying this CMS very ambitious !
If you want more informations about my config or what ever you want, i'll just be happy to help to solve this pb.
My config :
What do you mean by 'Pb' ?
When I click on log in after the installation, I arrive once again sur the install page...
This will be fixed in ver 1.5, due out in a couple days. Thanks.
i have installed 1.5 in a subdirectory & I can confirm that the loop problem is still there.
after filling the initial settings & getting password, once i click on the login link it brings me back to the install screen
I have PHP Version 5.2.9
Derek Wrote:What do you mean by 'Pb' ?

I guess problem?
Sorry, in french it's an usual abreviation.
Thanks Eliman - There must have been two reasons for the install loop. One was a mistake of mine where i used a reserved word ($pwd) to check if the site was setup or not. I have since fixed that.

The other problem with this is probably because the install procedure doesn't have rights to write to the /data/other/ folder on your server. Since it can't write the config file, it keeps thinking it has never been setup - thus sending you back to the install page.

Please check to see if the second reason is happening to you... if you see website.xml in the /data/other/ folder then we have a different problem on our hands here.

No, I have not the file, but the folder is on CHMOD 0755... Can I have the file to modify it and upload it on the server ?
brian, giving you the file isnt going to help because you would then also need to write new pages, which would be in the /data/pages/ folder.

For test's sake - try chmodding the folder to 0777. this isn't safe, but we can at least see if it works...
I have tried with the 1.5 version and it doesn't work ! However, if I do a 0777 CHMOD, all works perfectly.
hhmm, something with your server isnt allowing the write process with normal permissions. What about 766? It is a little safer than 777...

if this works, and you want to keep it that way, you will need to CHMOD the whole /data/ and /backups/ folders.
No, install is looping with a 766 CHMOD...
well, this has to be a requirement of your host - that's the only thing I can think of. 777 is bad if you are on a shared host, which many of us are.

I don't know why some hosts need 777 for it to work, and others don't. I guess right now it's just something we need to deal with.... but I will keep an eye out for a fix/workaround.

Thanks for helping Brian.
I'm on a shared host... Whatever, I think a simple test at the end of installation for check if the file exist would be nice.

Something likes this:
if (file_exists('data/other/website.xml')) {
    $thisfile = 'data/other/website.xml';
    $data = getXML($thisfile);
    $SITEURL = $data->SITEURL;
if (@$SITEURL == '') {
$err .= '<b>Error:</b> Try to do a <em>CHMOD 777</em> on the folders data and backups<br />';

May be you can do the CHMOD automaticly, but you need to be sure that's not dangerous...
very good idea brian. I will get this in...

i do a chmod 755 at the beginning of the install.php page, but for those that require 777, that doesnt help a bit.
For those that require a CHMOD 777, it sounds like the files aren't CHOWNed correctly. Is that possible in the PHP script, to detect the root owner and then use that to CHOWN the others?
Derek, I've had an idea about this... let me know what you think if this will work to resolve these types of issues:

<as we are about to write to a file>
1. chmod directory to 777
2. write file
3. chmod directory back to 544
I meant to say:

3. chmod directory back to 755
That should work. Once the XML file is written, it will have the correct owner and group. I just wonder if the folder permissions will prevent it from writing. I have tried to duplicate this error, but I can't replicate it for the life of me.

It really all comes down to if it's folder or file permissions screwing it up.
I am experiencing the same loop. Same request for site name, email, url after submission loop.

No data writing to /data (.xml)

Tried and Failed:
chmod 755 on data
chmod 777 on data
chmod 755 on GetSimple
chmod 777 on GetSimple

Ubuntu 9.04, Apache 2, PHP 5
enabled mod rewrite
.htaccess in dir

What's next?

Please post the contents of your .htaccess file. And I think I am getting this right, but you have this in a sub folder of your main webroot, correct?
chmod 777 on /var/www/GetSimple

Removed lines 42-62 in functions.php to fix blank site issue, but still looping.

<.htaccess @ /var/www/GetSimple/.htaccess>

Options +Indexes
Options +FollowSymlinks
RewriteEngine on

## Uncomment if you are installing GS into a subdirectory
## Replace 'cms' with the folder that GS is installed in
RewriteBase /GetSimple/

## If you uncomment out the above line, comment this one out.
#RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule /?([A-Za-z0-9-]+)/?$ index.php?id=$1 [L]

I got past the loop screen by setting

chmod -R 777 /var/www/GetSimple

But this is too unsecured for me.

It loops when:
chmod -R 755 /var/www/GetSimple/data
chmod -R 777 /var/www/GetSimple/data

It works when:
chmod -R 777 /var/www/GetSimple

I'm happy I've got this running, but what do I have to do to secure it?

Pages: 1 2