GetSimple Support Forum

Full Version: blog posts only work when logged in as admin
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

after several hours spent I hope someone will point me in the right direction. It turns out getting my News Manager blog posts returns 404 errors. However, when I also login into the admin page, they work just fine from the same browser. Posts are not private. Apparently, there's no problem with other pages. Evidently, there's some rights issue, but I'm clueless as to how to go about it. Help would be appreciated.

GS 3.3.5
News Manager 3.1
Health Check ok

Regards.
Have you enabled Fancy URLs in News Manager settings?
Any other plugins installed? I18N?
(2015-03-04, 01:38:42)Carlos Wrote: [ rel="nofollow" -> ]Have you enabled Fancy URLs in News Manager settings?
Any other plugins installed? I18N?

Fancy URLS in News Manager: NO
Active plugins:
FancyBoxPlugin 1.1
I18N Base, I18N 2.3.8
I18N Search 2.11.1
Auto-open Page Options 2.0
Simple Input Tabs 2.6
Small Plugin Toolkit 1.5
Do you have a custom permalink structure in GS Settings? (If yes, which one?)
Have you upgraded News Manager or is it a new installation?
(2015-03-04, 02:23:43)Carlos Wrote: [ rel="nofollow" -> ]Do you have a custom permalink structure in GS Settings? (If yes, which one?)
Have you upgraded News Manager or is it a new installation?

- No custom permalink, I use the default
- News Manager upgraded 3.0 => 3.1 However, the problem existed with 3.0 just the same.
Nice to know it's not an issue with 3.1, thank you for telling.

As you use I18N, please tell me how your URLs look like. Do they have something like ?lang=xx appended? What about the URLs of posts? (even if they return 404 errors) Just some examples, I don't need the full URLs.
(2015-03-04, 02:38:55)Carlos Wrote: [ rel="nofollow" -> ]Nice to know it's not an issue with 3.1, thank you for telling.

As you use I18N, please tell me how your URLs look like. Do they have something like ?lang=xx appended? What about the URLs of posts? (even if they return 404 errors) Just some examples, I don't need the full URLs.

Normal pages use fancy urls:
http://gillesvaneeden.nl/gitaarles/vragen/

Blogs use querystring:
http://gillesvaneeden.nl/blog/?post=sandy-denny

Oh and for now there's only one default language, Dutch. So I have no language specific pages. I did test setting everything back to english (site and News Manager) but with no different result.
You don't have a page with slug blog
News Manager (currently) needs a page (selected in settings) to display the blog/news.
(2015-03-04, 03:04:10)Carlos Wrote: [ rel="nofollow" -> ]You don't have a page with slug blog
News Manager (currently) needs a page (selected in settings) to display the blog/news.

Aaaahhhh

The page was there but it was set to 'private' Confused After some resetting and saving it works now.

Oh well - thanks for your precious time Carlos.