GetSimple Support Forum

Full Version: 504 Gateway Time-out
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
on one of my hosting for some time when switching to the tab Plugins began to appear this page
504 Gateway Time-out

Could be the api requests timing out, causing php to time out, But usually you don't get a 504 fro these, unless nginx does something different, I see these alot on the internet, I think its a problem with nginx in general.

We were even getting it on this site for a while.

I think they were related to fastcgi config
the answer of the support service provider: "When a more detailed analysis of Your question revealed that its decision is necessary to optimize the scripts of Your website, because resource-intensive queries."
but a month ago, all worked well.
Yeah bullshit, it is internal pages not public
I'll add ability to disable plugin Api checks and see if hat helps
Hosting much cheaper ($ 0.6 1gb for a single site), was sold this company in the past year, prices remain the same, maybe just trying to close it.
how many plugins you got?
on other hostings I get 25-30 plugins
I have about that, and it only takes like 3 seconds to load on cache refresh.
a month ago, this did not happen, it was the best my hosting
I am assuming you checked error log?
Turned on debugging ?
Most likely the script is trying to connect through a proxy server, which is currently unavailable and cannot process the request.
[Image: 504-error.jpg]
But it is odd that only the plugins page is having a problem.
But they might have their setup to drop all connections open for more than 500ms - 1s

You can try to do a backup and see if that fails ( since it takes while )

I am suspecting its the 19 curl requests going out all at once.

Test this, install 3.3.7 ( alpha )

to disable plugin checking

i also enabled api debugging, so your console will be full of api details with or without this setting.
sometimes an error occurs and you try to access the control panel.
I tried 3.3.7 - did not help.
but after loading the control panel Plugins tab boot faster - it pleases Smile