GetSimple Support Forum
PROBLEM Warning: date() - Printable Version

+- GetSimple Support Forum (
+-- Forum: GetSimple (
+--- Forum: General Questions and Problems (
+--- Thread: PROBLEM Warning: date() (/showthread.php?tid=6026)

Warning: date() - sontom - 2014-03-29

Hi there,

I am completely new to GS, and have just installed it on my hosted webspace with PHP5.4.

The following error message keeps popping up in various places:
Quote:Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/www/web269/html/plugins/getsimple_contact/process/process.php on line 11

It's already appeared in the admin backend, it's appeared in the frontend. This particular error message appears when I hit the refresh button on the contact form which is created with the GS Contact plugin.

Any thoughts? I've entered a time zone in the settings already.

RE: Warning: date() - shawn_a - 2014-03-29

you need to set a timezone in gsconfig

RE: Warning: date() - sontom - 2014-03-30

(2014-03-29, 23:46:40)shawn_a Wrote: you need to set a timezone in gsconfig

I don't think this is the problem. I just checked the gsconfig file, and there already IS a timezone in it (even if it isn't the right one). And when I change it, the error remains.

RE: Warning: date() - shawn_a - 2014-03-30

you can to uncomment it
remove the #

RE: Warning: date() - sontom - 2014-03-30

OK. A fresh start this morning. I checked gsconfig again, made sure everything I need is uncommented. Timezone is set AND uncommented. But the error still pops up when I hit refresh on the contact form. I emptied the cache on my browser, I used a different browser, but to no avail.

RE: Warning: date() - shawn_a - 2014-03-31

That is odd is it the same error?
If this is a production server, you should have errors turned off anyway. Enable supresserrors in gsconfig also.