Thread Rating:
  • 4 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
News Manager (updated)
(2013-05-29, 19:54:22)Ark Wrote:
(2013-05-23, 15:51:11)Carlos Wrote: - better (though not optimal) support for I18N-powered multilanguage sites

Could you give link or exmple how to use NM in multilingual site.
I want the same post display in different languages on my site. Is it possible with current version of NM?
I have already asked Carlos.

The answer is that you can't do multilingual posts. The only way you can do that is
1) Writing a post in both languages
2) Showing both posts in both language versions of the site

Maybe it would be possible somehow with I18N Search and/or Special Pages, but I haven't tried yet.
Tomáš Janeček - Multilingual personal website powered by GetSimple
» The little I did for GetSimple
Reply
(2013-05-29, 19:54:22)Ark Wrote: Could you give link or exmple how to use NM in multilingual site.

You install it and use it just like in a single-language site. If your news page has slug news, you can create another page with e.g. slug news_fr (for French) and a different title.

(2013-05-29, 19:54:22)Ark Wrote: I want the same post display in different languages on my site. Is it possible with current version of NM?

What has been fixed in NM 2.4.x is that the '#', 'view' links in the backend (posts view/post edit) are not broken if you use I18N (it happened with custom permalink structures that use %language% and %nondefaultlanguage% tokens)

NM is single-language and I currently don't have plans to make it multilang (though I have it in mind).

But it works with a I18N multilanguage site. You see the same posts on any language, and links in news pages are correctly generated (they don't take you to a page with a different language). However (currently) texts like "Published on", "Older posts", etc. are always rendered in the language selected for the news page.
Reply
(2013-05-30, 00:37:09)TeeJay Wrote: Maybe it would be possible somehow with I18N Search and/or Special Pages, but I haven't tried yet.

Best solution for multilanguage news is precissely using those plugins (both or just I18N Search), not using NM (or leave it for a simple blog/news site).
Reply
Hi Carlos,
As I've already anticipated, I am having problems with the search bar of NM.
I have a variety of news inserted in a dozen tags and when I type a word in the search bar, it only shows me the news page with all the recent news.
I tried with the NM 2.3.5 and NM 2.4.2 on GS 3.2.0 but the result is the same.
Could You help me?
Reply
I've tried searching in your site (the URL you PM'ed to me) and seems to work fine. (It's the box at the bottom of the page, isn't it?) I search and get:

Quote:Sono stati trovati i seguenti Articoli:
... and the list of posts found.
Reply
Hhmm... Works fine on Firefox and Chrome, but with Internet Explorer (at least IE8) it happens what you say, you get the main news page instead of the search results.
Reply
It seems it's an IE bug, happens when you press Enter (instead of clicking the submit button) on a form that has just one field. I'll fix this in the next NM release.

In the meantime you can patch it. Edit news_manager/inc/sidebar.php, find this:
Code:
<input type="text" class="text" name="keywords" />
Just before (or after) that, insert this:
Code:
<!--[if IE]><input type="text" style="display: none;" disabled="disabled"
    size="20" value="Ignore field. IE bug fix" /><![endif]-->

(Source: http://www.rachaelarnold.com/dev/archive...ission-bug )
Reply
Carlos, thank You again for you great support.
Yes, it happens when you DON'T click on the submit button: in fact I hidden it with a css line (visibility:hidden).
Now it's all cleared, thank you again!!!
Reply
News Manager 2.4.3 now available in Extend

changelog:
- fix IE bug when pressing Enter on search box (@D.O.)
- optimization: template tag nm_post_title no longer does an extra file read
Reply
Congrats bro! You are a thunder!
I am gonna test it!
Reply
How do i change this [...] to Read more
Reply
HI Riianna,
then it's simple: add in your gsconfig.php file this line
Code:
$nm_i18n["ELLIPSIS"]    = "(read more)";
If you need more details, we are here.
Reply
(2013-06-12, 20:02:57)D.O. Wrote: HI Riianna,
then it's simple: add in your gsconfig.php file this line
Code:
$nm_i18n["ELLIPSIS"]    = "(read more)";
If you need more details, we are here.

That was easy, thanx Smile
Reply
Note that there will be no link in that "read more" string.
Reply
I think she just realized it :-D
Reply
Here's News Manager 2.5 beta, for those who may want to test.

The only change since 2.4.3 is that you can set it up to have post thumbnails / featured images with your excerpts.

Instructions here:
http://www.cyberiada.org/cnb/news-manage...er-25-beta

At this time there's no filebrowser to select the image. You must paste the image URL (full, or relative to data/uploads/)

It includes mvlcek's great pic.php script to do the image resizing in the frontend.

I may do some changes in settings and variable names before releasing 2.5. I may have to do some internal changes to prepare it for a new version of the News Manager Addons plugin that will support this new feature.

Thanks to Oleg06 for doing the first tests.

[edit - attachment removed - 8 downloads]
Reply
YAY! FINALLY!!! I am gonna test it!
Reply
I have created another website which has to be on some kinda wicked hosting. GS keeps telling me that I haven't set up CHMOD 777, but I did and it's set correctly, still, I can create and delete articles and pages, so I don't care. The problem looks like it is some htaccess problem because the news posts aren't dealing with a custom permalink structure properly.

Look how the links look like - OK in the left sidebar, wrong (including %nondefaultlanguage% in the address) on the news page. See here http://ubytovanisetek.cz/aktuality/
Also after switching the site to English, the news page is empty!

The same site works ok on my VPS test server, so everything is correct.
The hosting provider told me that my htaccess should work properly, however, I think it doesn't.
Code:
# News Manager nastaveni:

# for Czech (default language - that's important, it's without /cs/ in the url)
RewriteRule ^aktuality/tag/([^/.]+)/?$ index.php?id=aktuality&tag=$1&lang=cs [L]
RewriteRule ^aktuality/post/([^/.]+)/?$ index.php?id=aktuality&post=$1&lang=cs [L]
RewriteRule ^aktuality/page/([^/.]+)/?$ index.php?id=aktuality&page=$1&lang=cs [L]
RewriteRule ^aktuality/archive/([^/.]+)/?$ index.php?id=aktuality&archive=$1&lang=cs [L]


# for English (secondary language)
RewriteRule ^en/aktuality/tag/([^/.]+)/?$ index.php?id=aktuality&tag=$1&lang=en [L]
RewriteRule ^en/aktuality/post/([^/.]+)/?$ index.php?id=aktuality&post=$1&lang=en [L]
RewriteRule ^en/aktuality/page/([^/.]+)/?$ index.php?id=aktuality&page=$1&lang=en [L]
RewriteRule ^en/aktuality/archive/([^/.]+)/?$ index.php?id=aktuality&archive=$1&lang=en [L]

# end News Manager


I see there is no way how to make this okay, so I'm thinking about the solution, which will be...
Either hiding the menu item "News" or turning off switching languages (the problem are the permalinks actually), but...

... I got an idea that I could re-implement the way how links are built in the sidebar to the news page, I wouldn't mind not having "/en/" in the address on this extra page. Did anyone occurred this problem? Do you have an idea how to deal with this? Thanks for any suggestions Smile
Tomáš Janeček - Multilingual personal website powered by GetSimple
» The little I did for GetSimple
Reply
Plugin version?
Reply
(2013-06-17, 08:04:22)Carlos Wrote: Plugin version?
Sorry, forgot to mention, latest stable of course - 2.4.3

But as I said - it's not the plugin's problem. It works well on the other hostings that I tried
Tomáš Janeček - Multilingual personal website powered by GetSimple
» The little I did for GetSimple
Reply
How do I get addThis to link to the actual post and not just the parent page of where the blog posts are? I have the same problem with gs blog plugin. Merely enabling prettyurls didn't seem to help.
Reply
(2013-06-17, 20:03:13)anto Wrote: How do I get addThis to link to the actual post and not just the parent page of where the blog posts are? I have the same problem with gs blog plugin. Merely enabling prettyurls didn't seem to help.

I suppose it's because of the canonical meta tag.
To remove it, edit your template, change this:
Code:
<?php get_header(); ?>
by:
Code:
<?php get_header(false); ?>
Reply
in version news_manager-2.5-beta3 PNG files are shown with a black background
Reply
(2013-06-17, 23:02:02)Oleg06 Wrote: in version news_manager-2.5-beta3 PNG files are shown with a black background

Does it happen the same with I18N Special Pages? (it's the same image viewer, mvlcek's pic.php)
Reply
Is this on github yet?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 3 Guest(s)