Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
'Multi User 1.4' Plugin
I think you uploaded your latest GS Blog zip file instead of Multi-User 1.7...
Reply
Angryboy Wrote:I think you uploaded your latest GS Blog zip file instead of Multi-User 1.7...
I was working on way to many things yesterday. Fixed.
Reply
Thanks for updating that quickly :-) It's about time that the 'users' page of GetSimple got some more fields. Are you thinking of adding any extra ones, or allowing for custom ones to be defined by the main admin?

By the way, when I first saved the user bio, the 'user's name' and 'bio' labels changed to:

{user-managment/USERS_NAME}
{user-managment/USER_BIO}

I don't know if it is a first time thing, but that's just something I noticed. I look forward to seeing this integrated with other plugins, as it is an underappreciated feature but one that helps to personalise one's use of the CMS considerably.
Reply
I would love to see the possibility to block access to other plugins installed, any possibility of adding that?
Reply
I ran into an odd problem with the plug-in.

Yesterday, I started a new site with a fresh install of GS 3.1 and Multi User 1.6. When I created a 2nd user, the user didn't work at login. There was no error message, the login page merely refreshed when the user's password was submitted. Logging in with the original default user, the settings for the 2nd user were there, so they had been saved by the system. I confirmed the password, logged out and got the same strange result when trying to log back in as the 2nd user.

Optimistically, I updated GS & Multi User to the latest versions (3.1.1 and 1.7) but got the same result. After some probing for things like bad server permissions, I gave up for the day.

This morning, it all magically works as if nothing was ever wrong.

I've used GS & the plugin for half-dozen sites and never seen this behaviour before. Do you (or anyone else) have any clues as to what the cause was?

Thanks!

--> e
Reply
Ed at ISI Wrote:I ran into an odd problem with the plug-in.

Yesterday, I started a new site with a fresh install of GS 3.1 and Multi User 1.6. When I created a 2nd user, the user didn't work at login. There was no error message, the login page merely refreshed when the user's password was submitted. Logging in with the original default user, the settings for the 2nd user were there, so they had been saved by the system. I confirmed the password, logged out and got the same strange result when trying to log back in as the 2nd user.

Optimistically, I updated GS & Multi User to the latest versions (3.1.1 and 1.7) but got the same result. After some probing for things like bad server permissions, I gave up for the day.

This morning, it all magically works as if nothing was ever wrong.

I've used GS & the plugin for half-dozen sites and never seen this behaviour before. Do you (or anyone else) have any clues as to what the cause was?

Thanks!

--> e

This issue keeps coming up, there is obviously some issue here, I believe it is cookie related, cause if you clear the cookie, it works.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
shawn_a Wrote:I believe it is cookie related, cause if you clear the cookie, it works.

Ah, that makes sense and would explain why it worked the next day.

Thanks!
Reply
Hi Mike,

i think have found a small bug with the multi user but i'm not completely sure....

i had a user who used a % sign in their username, when the system wrote the XML file, it left that % sign out of the XML filename, but the username field was still with the % sign;

so when i tried to install the multi-user plugin, i kept getting the fail/ Unable to Load XML file because the plugin is referencing the XML filename on line 63 of the user-management.php, instead of the username that is within the field in the file;

So i guess this should either be fixed, or GS shouldn't allow usernames to be created with characters that can't be represented in the title of the XML file..

-marc
Reply
Hello. First of all, sorry for my English.

I want to ask: can I attach user to new page and only him and admin can edit it?
Reply
If it is too much trouble I understand, but could you possibly add a feature that hooks into http://get-simple.info/extend/plugin/news-manager/43/ and adds a signature to the bottom of the post? Additionally maybe make it so you can make it so the person can only access the News Manager, not the Pages tab
Reply
Version 1.7.1 on GitHub. Introduces hooks for custom permissions for other plugins
View On Github
I have added the ability for other plugins to add custom permissions checkboxes into the manage users area. I am looking for some feedback on the implantation as I am not sure my method is best.

What I have done is created a function, which other plugins can use, that will add a permissions checkbox onto the manage users page. Example below:
Code:
<?php add_mu_permission('blogsettings', 'Blog Settings'); ?>
The above code (placed in my GS Blog plugin) will add a checkbox on the manage users page with the label of Blog Settings. It will save it to the users xml file in the node "blogsettings".

Below is a screenshot of the effect of adding that function and a few other permissions:
[Image: custom_permissions.jpg?psid=1]

Now that the data is stored in the users xml file, the plugin author can access that by manually loading the xml file or by using a function the multi user plugin provides. Example Below:
Code:
<?php check_user_permission($username, $permission_node); ?>
The above will return false if the page is blocked or true if the page is not blocked or the node is missing from the users xml file.

In other regards, I am aware this plugin is in need of a rewrite and you can look forward to that in the coming months. Please let me know your thoughts on this functionality.
Reply
This is what was missing from this plugin. I cant wait to try it out.
It would be great to see snippets from other users to see how they are implementing this too.
Reply
alienee2 Wrote:Hi Mike,

i think have found a small bug with the multi user but i'm not completely sure....

i had a user who used a % sign in their username, when the system wrote the XML file, it left that % sign out of the XML filename, but the username field was still with the % sign;

so when i tried to install the multi-user plugin, i kept getting the fail/ Unable to Load XML file because the plugin is referencing the XML filename on line 63 of the user-management.php, instead of the username that is within the field in the file;

So i guess this should either be fixed, or GS shouldn't allow usernames to be created with characters that can't be represented in the title of the XML file..

-marc
I will add some protection against this in the new version. I think this needs to be a feature of the core, as usernames should not have special characters in them imo.
Reply
Version 1.8.2 Added To Extend
  • Added check_user_permissions() function - This function returns all
    permissions in an array for the provided user
  • Fixed issue with custom permissions being reset if admin settings form
    is submitted

I have added the ability for other plugins to add custom permissions checkboxes into the manage users area.

I created a function, which other plugins can use, that will add a permissions checkbox onto the manage users page. Example below:
Code:
<?php add_mu_permission('blogsettings', 'Blog Settings'); ?>
The above code (placed in my GS Blog plugin) will add a checkbox on the manage users page with the label of Blog Settings. It will save it to the users xml file in the node "blogsettings".

Below is a screenshot of the effect of adding that function and a few other permissions:
[Image: custom_permissions.jpg?psid=1]

Now that the data is stored in the users xml file, the plugin author can access that by manually loading the xml file or by using a function the multi user plugin provides. Example Below:
Code:
<?php check_user_permission($username, $permission_node); ?>
<?php check_user_permissions($username); ?>
The above (check_user_permission()) will return false if the page is blocked or true if the page is not blocked or the node is missing from the users xml file.
The above (check_user_permissions()) function will return an array of all permissions in the following format: 'permissionname' => bool
Reply
mikeh Wrote:I will add some protection against this in the new version. I think this needs to be a feature of the core, as usernames should not have special characters in them imo.

Noted
I think this was discussed somewhere but we keep forgetting to create issues on it or discuss it and fix it.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
shawn_a Wrote:
mikeh Wrote:I will add some protection against this in the new version. I think this needs to be a feature of the core, as usernames should not have special characters in them imo.

Noted
I think this was discussed somewhere but we keep forgetting to create issues on it or discuss it and fix it.
I did not keep true to my word. This has not been updated in the just-released version. I will put it in the next version.
Reply
I think your permissions system is a neat addition without trying to completely control all privs and let plugins do it themselves.

I find something about the whole checkboxes thing annoying though. Perhaps you could use table rows instead, just don't like how its scatters horizontally aligned.

Have you used the username from SVN yet to incorporate ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
If I attempt to change the admin language, I end up with a white screen, and can go no further.
If I remove the plugin, everything functions correctly again.
Reply
Thank you for this wonderful plugin, but I'm a bit lost and I would like a tutorial or a practical example if possible how to create custom permissions, for example in the image below I would like to hide the user to create new options page (edit option enabled ) or modify the menu as well as hide the items marked in the screenshot below. How do I create permissions for the plugin? for example for special pages. A practical example with a puglin to know where put the code... Thanks again

[Image: PGCTV.jpg]
Reply
Can you add the feature that allows for one user to be able to edit only certain pages? (I would like to have one admin user and then several users that can only edit one page.) Thanks!
Reply
I've added and changed something. The adjustment of the language is more complete (some terms added), because till now this has been quite rudimentary.
A few minor problems where corrected, so the fieldname for the login name in the edit form. Now after add a new user that name can not be changed, so that the field should also be inactive set, all changings are running into the empty.
Next, the height of the editor box ad the field Users Bio has been reduced, for users are not so much necessary.

Question:
How could it be done, that changings in the field landing-page are ben taken?
In the actual situation the user will be never redirected to the therefore pointed default page.

Second Question:
How can I upload the changed files for the extension and who does check it, that it can uses from other users?

Greetings from the Ore Mountains in Germany.
Reply
(2012-10-11, 00:57:00)michaellindahl Wrote: Can you add the feature that allows for one user to be able to edit only certain pages? (I would like to have one admin user and then several users that can only edit one page.) Thanks!


Yes, option to select what pages user/users can edit would be appreciated...

Does anyone know a way to do this in latest version of multi user plugin? I'm no good in php.
Reply
I have problem. Upon copying the latest version of the plug-in into the proper folder, I call up SETTINGS and instead of buttons and appropriate links, I get tags inserted as labels and the user editor doesn't work:

Take a look:

http://www.mediafire.com/view/?zz739ds49kvkk9i

3.1.2 or 3.1, neither worked properly with the latest version of the plug-in. Is is something I'm doing?

Walt
Reply
Thanks for the great plugin. It works great for me apart from when I check all boxes apart from the 'pages' I get "You Do Not Have Permissions To Access This Page". When I uncheck the 'edit' and 'pages' box it works. I don't really want the user to add new pages.

Custom Landing Page set to 'pages' and using the latest plugin version with gs 3.1.2.

Thanks in advance.
Reply
(2012-11-21, 10:48:06)MarkeH Wrote: Thanks for the great plugin. It works great for me apart from when I check all boxes apart from the 'pages' I get "You Do Not Have Permissions To Access This Page". When I uncheck the 'edit' and 'pages' box it works. I don't really want the user to add new pages.

Custom Landing Page set to 'pages' and using the latest plugin version with gs 3.1.2.

Thanks in advance.

Sorry, I'm being dumb! You need the edit to be on to view the page. I guess my main request would be the ability to turn off the "Create New Page"

Something like:
<PAGES></PAGES>
<NEWPAGE>no</NEWPAGE>
<FILES>no</FILES>
<THEME>no</THEME>
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels