Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HTTP Error (401) when uploading files
#1
Hey, I'm a little lost at the moment and I hope someone can help me. I have 2 Issues.

# 1 (the bigger one) — I get an Error when uploading files via the backend with the following message:

[Image: content]

although the rights are set properly. See:

[Image: content]

And # 2 — I added another User and when he is editing the settings, he keeps getting the following Error:

Quote:Error: Unable to continue: Unable to write config file. CHMOD 777 the folders /data, /backups and their sub-folders and retry

Strangely enough the changes are still made. So this is only a bit of a blemish, as he can still edit the settings, but solving Problem # 1 is really important to me and i hope anyone can help.

Best regards
Lars
Reply
#2
Lars,

I think you should contact your hoster and ask for a solution, I think they know better about your system than we

good luck,

Connie
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#3
Connie,

thank you for your quick response.

But what should I tell them? As you can see everything appears green in the Website Health Check. So what should they do, when all the required modules are installed, and all the rights are set?

The same with problem # 2 — The changes are actually being accepted, the file is (!) writable, but Get-Simple is giving me this error message. So in my view, both are Get-Simple issues. Or am I getting something wrong?

Regards,
Lars
Reply
#4
Can you send us a screenshot of the ownership of the /data/pages and /data/uploads folders? Usually you can see this information from within your FTP client...
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#5
Of course:

[Image: content] [Image: content]
Reply
#6
is owner 4402 you?
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#7
in gsconfig uncomment
define('GSCHMOD', 0777);
Try to delete and create again /data/uploads directory, or chmod it to 777 instead of 755.
I think that the webserver may be working on system privileges, not user


Ahh just read that this problem appears on 2nd user account.

ps. I can't assure it's not a problem with a different thing.
Don't forget that leaving directories with 777 attributes leaves a hole in security.
Addons: getsimple theme, Online Visitors, Notepad
Reply
#8
ccagle8 Wrote:is owner 4402 you?

I got no idea where this comes from. I can't edit it anyway.
Reply
#9
so if you do what yojoe said (delete folders and recreate) then they should be owned by your ID. i would be interested in if this would work...
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#10
I tried, but I still get the same error message.

Owner is 4402 again. So this should be me. Smile

[Image: content]
Reply
#11
I noticed something while digging around for my other problem.

The new user, who can write the Settings, but gets an Error Message is Owner 4402

[Image: content]

The original user, who can write the Settings, without an Error is Owner 30

[Image: bildschirmfoto20110414u.png]

Does that help anything?
Reply
#12
that is odd because no matter who is the user that is logged into the backend - they should all write to the server with the same "owner"... very strange indeed
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#13
Oh no, come on! Just noticed that i can create folders in the backend without troubles.
Reply
#14
Lars Vegas Wrote:
ccagle8 Wrote:is owner 4402 you?

I got no idea where this comes from. I can't edit it anyway.


that is why I suggested to contact your hoster's support. They should know which user-rights are enabled by default, for scripts, for ftp etc.
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#15
Owner one way, but ftpgroup ?
Connect to you webserv ftp using your administrator account.
And try install a test instance of GS in a subdirectory.
Addons: getsimple theme, Online Visitors, Notepad
Reply
#16
Same two Problems unfortunately. Sad

On another webspace and on my local server (MAMP) it worked just fine so I see I really have to contact my hoster. And I really hope that they can help.

I will update this topic as soon as there is something new.

Many thanks for now.
Reply
#17
I am having the same 401 error on uploads. Do we know what services must be enabled for the file upload to work? Should this be something listed in the installation requirements for GetSimple?
Reply
#18
cliff Wrote:I am having the same 401 error on uploads. Do we know what services must be enabled for the file upload to work? Should this be something listed in the installation requirements for GetSimple?

No, it must not ... it is too common

I just can repeat:

if you run into these troubles which are not typical for GetSimple and which are common for nearly every "grown up standard" Web-Application,

Sorry, "file uploading" is nothing special, it is a common functionality

if you can upload via FTP but not from the web-application, then your user-definiotions are not ok, then FTP is done by "your user" but uploading from inside a web-application is done by another user (see here these user with different numbers)

do ask your hoster's support. You pay for that service!!!

They are the people for these topics. I do not understand why many users are so shy to contact them but not shy to ask in the application's forum

hoster's support people are friendly and supportive (mostly)

but they know really better about the conditions of your hosting package
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#19
Lars Vegas Wrote:I get an Error when uploading files via the backend with the following message:

[Image: content]

SOLVED!

The Site is still in production, so I passwordprotected the Site via htaccess. When I remove the passwordprotection, the uploads work properly.

But the other Problem (Errors when the new created user updates the settings) still consists and the Hoster wasn't able to explain. Anyone?
Reply
#20
Lars Vegas Wrote:SOLVED!

The Site is still in production, so I passwordprotected the Site via htaccess. When I remove the passwordprotection, the uploads work properly.

haha ;=)( you trapped yourself ;=)

Lars Vegas Wrote:But the other Problem (Errors when the new created user updates the settings) still consists and the Hoster wasn't able to explain. Anyone?

Yes! There is a new chapter in the WIKI which deals with the problem when FTP-user and logged-in users run with different permissions, read here:

http://get-simple.info/wiki/installation...webhosters

polyfragmented encountered this and got information from his hoster, so maybe it can help you as well to add this directive to your .htaccess

Cheers, Connie
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#21
Connie Wrote:haha ;=)( you trapped yourself ;=)

Yes, indeed. Tongue

Connie Wrote:polyfragmented encountered this and got information from his hoster, so maybe it can help you as well to add this directive to your .htaccess

Unfortunately, this doesn't help. Anyone else? Smile
Reply
#22
I was having this problem on a password protected dev directory. Removing the password allowed uploads to work again for me.

Why is this the case?
Reply
#23
Lars Vegas Wrote:Unfortunately, this doesn't help. Anyone else? Smile


Lars, are you really sure that "php file upload" is activated in your account?
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#24
Hey Connie,

File upload is working after all. I just have that issue with the second user, which can change the settings, but still gets the error message: "Please change permissions to 777" — But they are.
Reply




Users browsing this thread: 1 Guest(s)