Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I18N Gallery
(2014-12-10, 03:26:32)beaksdale Wrote: I'm struggling to get the JQuery gallery displays to work, I have followed the steps at the start of this thread but no luck. I'm using the latest version of JQuery in my template (with the call to it before the get_header(); in the template) but I can't make it load, help please...

Have a link you can share?
Modern UI Admin for GetSimple
Watch the demo. Install this plugin. Use this CSS. Enjoy.
Reply
hello
How it looks in the source code of the page?
jQuery should be always loaded basically.
If the corresponding call in the page code?
Reply
(2014-12-10, 05:09:41)sal Wrote: Have a link you can share?

(2014-12-10, 17:04:16)R.Muetterlein Wrote: hello
How it looks in the source code of the page?
jQuery should be always loaded basically.
If the corresponding call in the page code?

Hi,
Thanks for both offering to help (sorry for the slow reply I'm doing this in my spare time) here is a link
I've tried removing my JQuery call and using the one with the gallery but didn't work either. I've probably made a mistake somewhere but I haven't been able to find it.
Cheers
Reply
(2014-12-12, 01:00:45)beaksdale Wrote:
(2014-12-10, 05:09:41)sal Wrote: Have a link you can share?

Thanks for both offering to help (sorry for the slow reply I'm doing this in my spare time) here is a link
I've tried removing my JQuery call and using the one with the gallery but didn't work either. I've probably made a mistake somewhere but I haven't been able to find it.
Cheers

Looks like that version of prettyPhoto that ships with I18N Gallery (3.1.2) is incompatible with the version of jQuery you're using (2.1.1) because $.browser was removed in 1.9. One option is to use a jQuery version prior to 1.9 or try adding the following to your main.js file instead and see if it works (a general solution I found on Stack Overflow).

Code:
jQuery.browser = {};
(function () {
    jQuery.browser.msie = false;
    jQuery.browser.version = 0;
    if (navigator.userAgent.match(/MSIE ([0-9]+)\./)) {
        jQuery.browser.msie = true;
        jQuery.browser.version = RegExp.$1;
    }
})();
Modern UI Admin for GetSimple
Watch the demo. Install this plugin. Use this CSS. Enjoy.
Reply
Install this script below jquery http://blog.jquery.com/2013/05/08/jquery...-released/
or change the version of jquery
Reply
Hello and thank you for this module!
That's a lot of work.

Excuse me for my english, I'm french.

I'm new to GetSimple this is my first website.
I wish I could integrate the gallery theme "s3Slider" but I do not arrive there since two days. Only the theme "prettyPhoto" works.
I use GetSimple 3.3.4 with the theme Grill.

if I insert the code (% gallery name = my-gallery-name%) it makes me a white border around images. For this to work I had to create another template and insert <?php get_i18n_gallery('my-gallery-name'); ?> in html code.

But I've done a check of the problems encountered on the official page I18N Gallery. I deactivated jquery in the backoffice because it is already present in my theme.

Here's a link to my http://5.135.162.30/~joffta/creations/ page.

I hope you can help me.

thank you

Best regards.

Joffrey
Reply
Team, need assistance with this plugin. I am able to add the cycle but it does not work like the one the demo site. Also, the other types do not work correctly. I can't to figure out what is missing or not configured properly.
Example: http://calvarychapelofagape.org/new/galleries/, ever time I click on the next button, it jumps up to the top of the page. Is it something on my page?
ThanksHuh
Reply
(2014-12-18, 06:56:06)xanos3000 Wrote: Is it something on my page?

At a quick glance, you're loading two jquerys (your site's and the gallery plugin's) on the gallery page.

Try disabling in the gallery plugin configuration.
--
Nick.
Reply
(2014-12-12, 01:00:45)beaksdale Wrote: Hi,
Thanks for both offering to help (sorry for the slow reply I'm doing this in my spare time) here is a link
I've tried removing my JQuery call and using the one with the gallery but didn't work either. I've probably made a mistake somewhere but I haven't been able to find it.
Cheers

The template is missing all Galery functions. No JS, CSS no.
Please check whether you have made all the necessary adjustments and additions code in the template.
Reply
(2014-12-18, 06:56:06)xanos3000 Wrote: Team, need assistance with this plugin. I am able to add the cycle but it does not work like the one the demo site. Also, the other types do not work correctly. I can't to figure out what is missing or not configured properly.
Example: http://calvarychapelofagape.org/new/galleries/, ever time I click on the next button, it jumps up to the top of the page. Is it something on my page?
ThanksHuh

Again, lack the necessary functions of the gallery. In the code, the page no indication of the images to be displayed is available. I would suggest to investigate the template to complete code and then check in the gallery, all the settings (images, ...) are complete.
Reply
(2014-12-14, 14:20:10)sal Wrote: Looks like that version of prettyPhoto that ships with I18N Gallery (3.1.2) is incompatible with the version of jQuery you're using (2.1.1) because $.browser was removed in 1.9. One option is to use a jQuery version prior to 1.9 or try adding the following to your main.js file instead and see if it works (a general solution I found on Stack Overflow).

(2014-12-14, 17:44:10)Oleg06 Wrote: Install this script below jquery http://blog.jquery.com/2013/05/08/jquery...-released/
or change the version of jquery

Thanks that's where I was going wrong all good (though not sure why it didn't work when I removed my JQuery and used the inbuilt one but whatever).
Reply
When i try to use I18N gallery with my get-simple site locally with GSbigbusiness them the slider included with the them brakes

I don't have any development experience just basic knowledge in html only .

How to clear this issue

[Image: redir?resid=14E0FB4B439264F3!108&authkey...hoto%2cpng]


Attached Files Thumbnail(s)
   
Reply
(2014-12-27, 15:57:17)beenex Wrote: When i try to use I18N gallery with my get-simple site locally with GSbigbusiness them the slider included with the them brakes

I don't have any development experience just basic knowledge in html only .

How to clear this issue

[Image: redir?resid=14E0FB4B439264F3!108&authkey...hoto%2cpng]

Try disable jQuery in the default Gallery settings.

Christophe
Reply
I tryed both without jQuery and css .

(2014-12-28, 04:58:57)tuxy Wrote:
(2014-12-27, 15:57:17)beenex Wrote: When i try to use I18N gallery with my get-simple site locally with GSbigbusiness them the slider included with the them brakes

I don't have any development experience just basic knowledge in html only .

How to clear this issue

[Image: redir?resid=14E0FB4B439264F3!108&authkey...hoto%2cpng]

Try disable jQuery in the default Gallery settings.

Christophe
Reply
Thank you all to help and efforts, the issue is solved . solution by adding the code in template after content part. <?php get_i18n_gallery_header('my_gallery_name'); ?>


(2014-12-31, 13:03:55)beenex Wrote: I tryed both without jQuery and css .

(2014-12-28, 04:58:57)tuxy Wrote:
(2014-12-27, 15:57:17)beenex Wrote: When i try to use I18N gallery with my get-simple site locally with GSbigbusiness them the slider included with the them brakes

I don't have any development experience just basic knowledge in html only .

How to clear this issue

[Image: redir?resid=14E0FB4B439264F3!108&authkey...hoto%2cpng]

Try disable jQuery in the default Gallery settings.

Christophe
Reply
(2014-12-31, 23:47:51)beenex Wrote: Thank you all to help and efforts, the issue is solved . solution by adding the code in template after content part. <?php get_i18n_gallery_header('my_gallery_name'); ?>


(2014-12-31, 13:03:55)beenex Wrote: I tryed both without jQuery and css .

(2014-12-28, 04:58:57)tuxy Wrote:
(2014-12-27, 15:57:17)beenex Wrote: When i try to use I18N gallery with my get-simple site locally with GSbigbusiness them the slider included with the them brakes

I don't have any development experience just basic knowledge in html only .

How to clear this issue

[Image: redir?resid=14E0FB4B439264F3!108&authkey...hoto%2cpng]

Try disable jQuery in the default Gallery settings.

Christophe

Ok, nice Wink
Keep up the good work Shy
Reply
Hello, I have a simple question. I've searched but found nothing, so I'll ask.

Using the (% gallerylink %), is there a way to display in a page all the galleries created? (I mean, a thumbnail and the title of every gallery, not all the pictures).

I know I can create a link for every gallery, but I just want to know if there's a faster way (specially if the client creates and album, so he doesn't have to do this).

Thanks!
Reply
Hi mvlcek and team or anybody

Have just downloaded the latest version v221, and I am trying it out and am in the process of reading through the plugin description at http://mvlcek.bplaced.net/get-simple/i18ngallery

Great and solid gallery plugin ! , and I’ll be using the multilingual support and the normal behaviour of having a group all the thumbs for one gallery grouped on one page.

But I would like to be able to do the following … To have 1 or more images on one page which can be at different places on that page. Also to have 1 or more images on each other page in the same way. And then I would like to specify that all these images belong to one gallery, such that upon clicking on one of these thumb images, I get the gallery scrollable as normal through all those images that belong to that gallery. Meanwhile on a particular page there are just a few of all possible thumbs of that gallery

Can I do this ? Is this behaviour / feature supported by the plugin .. ?

I have looked through the i18n gallery plugin forum (well partially) and have seen that I can use the tag (% gallery name=mygallery thumb=n %) (the thumb part not mentioned in the plugin description page ? ) .. and this will just show just the specified thumb and upon clicking on the thumb it opens the gallery to scroll through all associated images as normal.

This is exactly what I want, but if I add a similar tag on the same page pointing to another thumb, then this other thumb shows as expected .. but however upon clicking it, it does not open the gallery , but instead I get the alert message “Image cannot be loaded. Make sure the path is correct and image exist.”

In general .. it seems that if each gallery just shows one thumb or all thumbs, or each gallery is a different gallery or the same as another on a page, then it seems that only the 1st gallery thumb works …

Also I see in the generated HTML that for each tag to show just one thumb the full code for all thumbs is created but with style no-display for all the other thumbs

I have also seen in http://mvlcek.bplaced.net/get-simple/i18ngallery that there is a tag (% gallerylink name=my-gallery-name url=my-gallery-slug thumb=0 %) but I’m not sure how this works / how to use it …

If I have a gallery with Title = “My Gallery 1” and slug = my-gallery-1, as in tag (% gallery name=my-gallery-1 %, then what is the syntax for the above gallerylink tag ?

Have you any suggestions to get my desired feature to work ?

Thanks in advance

Aldebaran
Reply
(2015-01-21, 05:09:54)aldebaran Wrote: But I would like to be able to do the following … To have 1 or more images on one page which can be at different places on that page. Also to have 1 or more images on each other page in the same way. And then I would like to specify that all these images belong to one gallery, such that upon clicking on one of these thumb images, I get the gallery scrollable as normal through all those images that belong to that gallery. Meanwhile on a particular page there are just a few of all possible thumbs of that gallery

As you already found out, you can specify one thumb of the gallery to be shown. If you want more thumbs to be shown, you can add tags to the gallery images (when editing the gallery) and then use one (or more) of the tags as in (% gallery name=mygallery tags=shirts %).

However, all these images matching the tags will be at one position on the page.

(2015-01-21, 05:09:54)aldebaran Wrote: In general .. it seems that if each gallery just shows one thumb or all thumbs, or each gallery is a different gallery or the same as another on a page, then it seems that only the 1st gallery thumb works …

Yes, you can't specify a (% gallery ... %) with the same name twice on a page.

(2015-01-21, 05:09:54)aldebaran Wrote: Also I see in the generated HTML that for each tag to show just one thumb the full code for all thumbs is created but with style no-display for all the other thumbs

Yes, otherwise there may be problems with most of the gallery types

(2015-01-21, 05:09:54)aldebaran Wrote: I have also seen in http://mvlcek.bplaced.net/get-simple/i18ngallery that there is a tag (% gallerylink name=my-gallery-name url=my-gallery-slug thumb=0 %) but I’m not sure how this works / how to use it …

You would need an extra page (e.g. named mygallerypage) with the gallery tag e.g. (% gallery name=mygallery %). You could also specify autostart=true, if using e.g. prettyphoto.

On you other pages you would then add links like (% gallerylink name=mygallery url=mygallerypage thumb=1 %). This will show the 2nd image of the gallery and a click on this link would then open the page mygallerypage and show the gallery.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
Hi mvlcek

Thanks very much for your quick answers !

Quote:As you already found out, you can specify one thumb of the gallery to be shown. If you want more thumbs to be shown, you can add tags to the gallery images (when editing the gallery) and then use one (or more) of the tags as in (% gallery name=mygallery tags=shirts %).

OK great. Apologies, I did not notice in your description about the tags param in the Extenteted Usage section of your docs / description http://mvlcek.bplaced.net/get-simple/i18ngallery I tried the tags param, and it works as you describe

ALSO / BUT : In your gallery docs page you describe the param imagetags … I tried this also with the (% %) syntax but it did not work .. So can you only use this with a full <php … ?> call in a template ? .. If so, would it not be better to standardise on these params so they are the same for both types of syntax (% ... % ) and <php … ?> ?

Quote:However, all these images matching the tags will be at one position on the page.
OK I guess this will be OK. I will see if this is OK for my client

Quote:Yes, you can't specify a (% gallery ... %) with the same name twice on a page.
OK that’s clear. But at least I see I can specify more than one (% gallery ... %) on the same page, as long as they are all different galleries / gallery names.

BUT, on your docs page, what do you mean “id - use it as an identifier, if you include a gallery more than once on a page” ? … Can you clarify ? … To me “a gallery more than once ..” means it can be the same gallery, whereas you probably mean that the galleries must be different … Can you give an example of using id. How would you use id ? If you say you cannot have the same gallery twice on the same page, then what is the purpose of id ? … the unique gallery name could act as the identifier … ?


Quote:You would need an extra page (e.g. named mygallerypage) with the gallery tag e.g. (% gallery name=mygallery %). You could also specify autostart=true, if using e.g. prettyphoto.

On you other pages you would then add links like (% gallerylink name=mygallery url=mygallerypage thumb=1 %). This will show the 2nd image of the gallery and a click on this link would then open the page mygallerypage and show the gallery.
Ah got it . So this just represents a normal link to another normal GS page. So the url param refers to the slug name of any normal GS page .. PS it seems that the name can be any valid gallery name, and the url can be any GS page, whether there is a gallery there or not.

In your docs page you have “Add a link to a gallery by adding the following to your page “ , but I did not understand “to a gallery” … You actually mean “to any GetSimple page with the slug given by the url param” .. yes ?

Aldebaran
Reply
(2015-01-22, 01:51:07)aldebaran Wrote: ALSO / BUT : In your gallery docs page you describe the param imagetags … I tried this also with the (% %) syntax but it did not work .. So can you only use this with a full <php … ?> call in a template ? .. If so, would it not be better to standardise on these params so they are the same for both types of syntax (% ... % ) and <php … ?> ?

You need to use "tags" for both (% gallery ... tags=mytag %) and <?php get_i18n_gallery(..., array('tags'=>'mytag')); ?>. But if you don't specify tags, e.g. just (% gallery name=mygallery %), you can call the page with http:/.../mygallerypage?imagetags=mytag which will then filter the gallery as if you specified the parameter tags. This way you can have one gallery and show different parts of it by just adding the tags to the link URL.

(2015-01-22, 01:51:07)aldebaran Wrote: BUT, on your docs page, what do you mean “id - use it as an identifier, if you include a gallery more than once on a page” ? … Can you clarify ? … To me “a gallery more than once ..” means it can be the same gallery, whereas you probably mean that the galleries must be different … Can you give an example of using id. How would you use id ? If you say you cannot have the same gallery twice on the same page, then what is the purpose of id ? … the unique gallery name could act as the identifier … ?

Great! You found a feature I wasn't even aware of anymore.
You can use the same gallery multiple times on the same page by specifying an id (i.e. any text string), e.g.
Code:
(% gallery name=mygallery id=g1 %) ... (% gallery name=mygallery id=g2 %)
By looking at the code you should be able to omit the id, if you use different tags, e.g.
Code:
(% gallery name=mygallery tags=building %) ... (% gallery name=mygallery tags=animal %)

(2015-01-22, 01:51:07)aldebaran Wrote: So this just represents a normal link to another normal GS page. So the url param refers to the slug name of any normal GS page .. PS it seems that the name can be any valid gallery name, and the url can be any GS page, whether there is a gallery there or not.

Yes, you are right. It should probably be "add a link, consisting of an image of a gallery, to any page". Updated in the description.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
(Re the id param)
(2015-01-22, 04:48:53)mvlcek Wrote: Great! You found a feature I wasn't even aware of anymore.
You can use the same gallery multiple times on the same page by specifying an id (i.e. any text string)

Brilliant ! This is exactly what I want if I use the id param with the thumb param – It works perfectly ! Smile

Reminder : What I want : Have one or more different thumbs (say upto 3) on the same page, and on other pages, but in different positions on the page separated by other content (ie not together in a tabular form), and then all belong to the same gallery, and when you click on any such thumb you can scroll through ALL the images of the gallery

Example :
Code:
(% gallery name=my-gallery-1 thumb=0 id=g1 %)
Some other content. Some other content  ...
(% gallery name=my-gallery-1 thumb=3 id=g2 %)
... where the values of id are just any text, but different for each gallery statement.

So apologies for not understanding this from your docs description of id ( http://mvlcek.bplaced.net/get-simple/i18ngallery ) .. the docs descriptions of the params such as id, tags, pic are a bit short for me !

Request : I think it would be good for others if you could expand these descriptions and have an example for each. … And then I would not ask so many questions !


(2015-01-22, 04:48:53)mvlcek Wrote: By looking at the code you should be able to omit the id, if you use different tags, e.g. …

Yes I see now, in the generated HTML the use of the tags param or the id param differentiates the code for each gallery on the page with the rel attribute (and maybe other places), even if the gallery name is the same … and then this is sufficient for all galleries to function properly

But in my case I cannot use the tags param for what I want to do (see above), eg by defining a tag for just one image, because on clicking and opening the gallery I would only see that single image as the enlarged image

But the id param works perfectly for what I want, if I use it with the thumb param (because with the thumb param you display just the one thumb , but the enlarged gallery window shows all images of the gallery)

So thanks again

Aldebaran
Reply
Hey guys,
I'm trying to figure how to put slider at a banner place. Do you have any idea? You can see both of they here: http://test.format-reklamy.pl/?name=slid...ew-gallery

Thanks
Reply
(2015-02-15, 22:23:20)party Wrote: Hey guys,
I'm trying to figure how to put slider at a banner place. Do you have any idea? You can see both of they here: http://test.format-reklamy.pl/?name=slid...ew-gallery

Thanks

Start with placing
Code:
<?php get_i18n_gallery_header('my-gallery-name'); ?>
to #banner div in your template.php file.
You might need to do some style polishing to display the slider properly...
Reply
Hello
I'm new on this forum (and new with the GetSimple) so welcome Smile
And at the begining I have a big problem with the I18N Gallery.

I have done everything from this tutorial: http://getsimple.jadefusion.net/tutorial...ry-plugin/

And at the end there is big problem because I don't have the working gallery.

I have searched the forum for solution and the only thing is the problem with JQuery.

I have dissabled it in the settings but it still doesn't work as it should be.

Here is a link to my site: http://fjt.org.pl/galeria2/

Maybe You can give me some advice what is the reason of my problem

Thank you
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels