Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't install plugins
I'm trying GetSimple out at the moment and I'm finding it very user friendly, intuitive and quick to learn.

But I can't install any plugins. They get uploaded, I follow the instructions on the plugin page and they refuse to activate. Also the two existing plugins 'Innovation Theme Plugin' & 'Send Anonymous Data' don't deactivate either.

Everything else works fine except the plugins.

I've included a screencap of the support page if it helps.
Are you extracting them from the zip files first and putting right into the plugins folder ?
Do they actually show up on the plugins page ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Thanks for the reply.
Yes, unzipped first, then uploaded to the plugings folder. Both the folder and the PHP file of the same name were uploaded.

The admin/plugins page just says "Version - Author: - update to 1.9.3" next to the gallery plugin.

The "update to 1.9.3" is a link to the same plugin page I downloaded the original plugin.

I've attached a screencap of the admin/plugin page with an inset pic of my FTP showing the plugin folder.
I have never seen this before, perhaps it is failing to write the plugins file because of permissions.

Anyone know how that works ?

Do you know how to turn debug mode on ? Give that a try and see if there are any errors.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
I turned on the debug and sure enough there is a plugin error.

I've put it on another screencap below.

It seems to be a problem with the SimpleXML Module. My host has it installed but it still seems to be the problem.
hmm says you dont have permission, but your health check says you do to data/other/

Try changing your permissions to 755 not 777, it might not let you write to files that are publicly accessible.
777 might be too high ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Hi again,
Thanks for your help, but no luck I'm afraid.

I changed everything in /data to 0755. Health check says '0755 Writable - OK', but when I click activate on the plugins it changes to 'Deactivate' in red, then waits about four or five seconds and reverts back to 'Activate' in black.

It seems like my host probably has things set up a bit differently to other hosts.

Thanks anyway.
It would be nice to know for sure, so we can throw pertinent errors to the user.
Maybe manually check the data/other/plugins.xml and see whats in it. Maybe rename it and try again

Are you having issue saving pages ?
Does the other folder have an htaccess file if apache ?

My host was once in read only filesystem mode, but permissions said everything was fine. But writes actually failed.

My goal is to make health check as robust as possible to catch all these issues.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
I tried creating a page with the 0755 permissions but it wouldn't work - even though the health check said it was OK. I changed everything in /data back to 0777 and saving new pages worked fine.

I had a look at the plugins.xml file at it contained this:

<?xml version="1.0" encoding="UTF-8"?>

I then changed its file name to plugins.xmlOLD and a new one was written. I looked back at the plugins page, and the plugins were all activated.

I've also just uploaded another plugin and it activated perfectly with the freshly re-written plugins.xml file.

This is really strange...

So I deleted everything and did a fresh install, making /data & /backup permissions 0777.
I uploaded 3 plugins to the /plugins folder and...
The same problem. They are not active and the activate link doesn't work.

I changed the permissions of the plugins.xml file to 0666 and refreshed the plugins page. Now all the plugins are activated and the activate/deactivate link works properly.

In conclusion, the file /data/other/pages.xml is being written to, on a fresh install, with the permissions 0644.
The file /data/other/plugins.xml is not being written to with the permissions 0644 but works OK when the permissions are changed to 0666.

Users browsing this thread: 1 Guest(s)