Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Simple Input Tabs
(2012-11-17, 01:45:05)uitdecom Wrote: magic_quotes_gpc is on, runtime and sybase are off, json (1.2.1) is enabled.

Hmm looks alright then. Thanks for being a good sport with this by the way. I appreciate the help figuring this out. Shy

Does this file have any issues?
Reply
No, thank you sir Smile It's working!
<º)))><
Reply
(2012-11-17, 02:08:14)uitdecom Wrote: No, thank you sir Smile It's working!

Awesome!

Suppose I need to upload another version. Angel

1.9g, there we go.

Also I have a question to anyone using this plugin. Do you use it as a singular file or just drag the whole zip contents across? I ask because I'm contemplating the merits of splitting the functionality of this plugin into two files. I love the simplicity of a single file when it comes to distribution, but it might be a lot easier to maintain and extend should it be split into two.
Reply
Alright, well no reply so I've added a dependancy. Tongue

So remember to ensure both simple_input_tabs.php and small_plugin_toolkit.php are in the plugins folder. I hope you guys are ok with having a second file. It does add a lot of flexibility and will make maintenance much easier imo. It's all good too, as functionality hasn't changed at all. Just now there are two files required instead of one.

Speaking of twos...

VERSION 2!

Woooo!

Added a configuration menu so all config options can be changed in the CMS itself. There should be no need to go into the code now, unless you want to specify default options for distribution (which can be done).

Also plenty of translations needed. Angel
Reply
(2012-11-21, 02:36:11)jason.dixon.email Wrote: VERSION 2!
Woooo!

Hmm, sorry to burst your bubble, but on a clean install with only the new version in the plugs dir., when I click on edit page or try to add a new one, I get a blank screen. Confused
Reply
(2012-11-21, 03:54:48)islander Wrote:
(2012-11-21, 02:36:11)jason.dixon.email Wrote: VERSION 2!
Woooo!

Hmm, sorry to burst your bubble, but on a clean install with only the new version in the plugs dir., when I click on edit page or try to add a new one, I get a blank screen. Confused

-pop-

Righto I've managed to reproduce the problem so far with the Innovation template. Are you using that in your test?

Alright, I should have fixed the problem. Forgot to take into account that Get Simple looks not only for templates, but also for a "functions.php" file in the theme folder.

Version 2.0a.

Inflating bubble.
Reply
New update works fine.
Yes, it was with the Innovation template that is loaded by default with a new install.

I like your slick little config. panel, although I might move it to Plugins instead of Settings.

Will start playing around with in during the next few days. Will let you know if I find anything.

In the meantime, bubble on!
Reply
I use GS 3.12, with the following plugins:
I18N
I18N Gallery
I18N Search
I18N Special Pages
Imagizer

site: http://www.printuri.eu

Friendly URL activated,

When I install Simple Input Tabs, when I try to save a page , ( any page ) I get this error:

"Server error
The website encountered an error while retrieving http://printuri.eu/admin/changedata.php. It may be down for maintenance or configured incorrectly.
Here are some suggestions:
Reload this webpage later.
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.
"

I think your plugin is an excelent concept and may take GS3 to the next step.
Reply
(2012-12-09, 06:18:26)tazmandev Wrote: I use GS 3.12, with the following plugins:
I18N
I18N Gallery
I18N Search
I18N Special Pages
Imagizer

site: http://www.printuri.eu

Friendly URL activated,

When I install Simple Input Tabs, when I try to save a page , ( any page ) I get this error:

"Server error
The website encountered an error while retrieving http://printuri.eu/admin/changedata.php. It may be down for maintenance or configured incorrectly.
Here are some suggestions:
Reload this webpage later.
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.
"

I think your plugin is an excelent concept and may take GS3 to the next step.

Thanks for your kind words! Hmm... Would you be able to disable each plugin one by one on the plugin page just to see which one is causing problems?

One thing you could try if you're keen is to change a couple lines of code and see if it helps:

At around line 199 UNDER this code:

PHP Code:
    $template_len count($split_template); 

Add in this code here:

PHP Code:
$template_lang false

Then changing this code, at around line 205 from:

PHP Code:
if(in_array($template_lang$language_list)){//  make sure the file is a language file. 

to:

PHP Code:
if($template_lang && in_array($template_lang$language_list)){//  make sure the file is a language file. 

If you try this let me know if anything changes? Smile
Reply
This plugin needs a guide with some pictures,lol I still have no idea what it does.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
(2012-12-11, 10:53:04)shawn_a Wrote: This plugin needs a guide with some pictures,lol I still have no idea what it does.
Jason made one here:
http://simpleinputtabs.internetimagery.com/index.html#
Looks useful to me. I haven't been doing any web work recently but when I get back to it...
Reply
(2012-12-11, 10:53:04)shawn_a Wrote: This plugin needs a guide with some pictures,lol I still have no idea what it does.

I suppose it's a bit like special pages with custom fields. Only greatly simplified with a pinch of magic.
Reply
Hello. Just for the info:

Following this wiki page:

http://get-simple.info/wiki/plugins:crea...r_creation

Every plugin has one file in the root plugin folder and multiple files and/or folders in one subfolder.

This is so it doesn't get a mess in the plugin folder

Your plugin has 4 files and one subfolder in the plugin-root.
Reply
Yeah that's not good
Plugins shouldn't have more than 1 plugin file , it makes plugin detection mess up and updates and other stuff
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
The Small Plugin Toolkit added with the Simple Input Tabs plugin adds this file:

/data/other/Shared_Data.xml

At my site it generates the following error in the Data File Integrity Check:

/data/other/Shared_Data.xml XML Invalid - Error!
Reply
Ah right. My bad, haha.

There is nothing technically wrong with the file, it just uses a simpler non-xml format. It's the file that saves the configuration data (of all plugins using small plugin toolkit).

In light of this oversight I'll make it use a normal xml format to remove that error. Or a different extension.
Reply
(2012-12-13, 04:43:19)datiswous Wrote: Hello. Just for the info:

Following this wiki page:

http://get-simple.info/wiki/plugins:crea...r_creation

Every plugin has one file in the root plugin folder and multiple files and/or folders in one subfolder.

This is so it doesn't get a mess in the plugin folder

Your plugin has 4 files and one subfolder in the plugin-root.

Ah yes... well. Blush

Two of those files are actual plugins and the subfolder is for one of them so that should be alright. Another file is a readme text file which hopefully is ok. The last one functions.php deletes itself upon activation. All it does is move the plugin files to the correct folder if they were accidentally put in the theme directory (or intentionally if distributed directly with a theme). I suppose that file pushes the boundaries a tad when it comes to convention. Tongue
Reply
Plugins should contain 1 plugin only, and only 1 file in root,
if you require dependencies put them in a subfolder or distribute them separately and load on demand.

No other files should be present in the plugins root but the plugin file that registered the plugin.

The extend and plugin system assumes this, and cannot properly function as you have it.

Unless your distributing this file on your own as an archive, then fine, it will be an archive of 3 plugins.

But in extend this confuses the api and versioning, and might be prevented at anytime in the future and your plugin will suddenly stop working.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
Hmm righto, separate distributions it is!

So the extend system looks at more than just the php file with the same name as the zip?
Reply
Since extend and the plugin system grabs a php file and uses it as the id, having more than 1 makes it unpredictable. And you wind up with plugins that do not link to extend or disable properly.

Hopefully in the future we can add dependancies so plugins wont enable if the required dependancies are not installed.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
That would be a good idea. It would be nice to have a robust dependency system so that we can have various plugin frameworks.

Updated to 2.1

Moved some files around to make Extend happy. Taken out small plugin toolkit, which must now be downloaded separately. Added a helpful message and link to the plugin should simple input tabs not locate it while running.

Tazmandev if you're still reading this thread, and are still having problems can you try out this version of the plugin? I haven't been able to reproduce your error but I did make one small change which may help your situation.
Reply
(2012-12-14, 23:09:39)jason.dixon.email Wrote: Updated to 2.1

Moved some files around to make Extend happy. Taken out small plugin toolkit, which must now be downloaded separately. Added a helpful message and link to the plugin should simple input tabs not locate it while running.

This error I get in the new GetSimple 3.2.0b beta version:

When activating both the plugins Simple input Tabs and Small Plugin toolkit, I get a white screen with this error:

Quote:Fatal error: Cannot use string offset as an array in ../plugins/small_plugin_toolkit.php on line 192

When I only activate one, I don't get the error
This is not the case in the stable version.

(2012-12-14, 23:09:39)jason.dixon.email Wrote: Added a helpful message and link to the plugin should simple input tabs not locate it while running.

When I have only the Simple Input Tabs uploaded and activated, I get a white screen with this message on every page of the website and admin part:

Quote:Simple Input Tabs cannot find the plugin Small Plugin Toolkit. It is required to operate. Click here to get it.

This is both in the stable and the beta.


btw. This might sound all too negative from me (my last couple of posts). I only want to be helpful by giving this info. I think I don't have a good working theme yet to use your plugin with.
Reply
Hmm ok I'll have to check that future error out. I haven't really been looking too hard at the new release.

That message is very heavy handed and I'll make it more subtle. Tongue

But it is working properly as both files are required.

Oh and don't worry. I'm not taking it as being extremely negative. I want to get any issues with this fixed as well. Smile
Reply
Hi Jason,

I have really enjoyed trying out your plugin. I have an unwanted site design which I was going to upload as a Theme. It has one, two and three column templates and some extra text blocks. Did you say this plugin could be distributed _with_ a theme so that the layout would all work as soon as you activated the theme? That the plugin will install itself? Are there any special instructions for that?
Reply
Yeah. Give it a test run first though to make sure it works for you. Works for me, but I suppose I have to label it as experimental as I haven't had any feedback yet.

The key is in the functions.php file found in the simple_input_tabs folder (which incidentally can be modified easily to install any plugin).

Place all your theme files into the theme folder as you would normally do then throw the plugin into the same folder (so simple_input_tabs.php would be in the same directory as template.php).

If you use a file named functions.php in your theme, then rename it to temp.functions.php. If you don't then ignore this step.

Move the functions.php file located in the simple_input_tabs folder into the same location as your template.php file.

And that should do it. When the theme is viewed, GetSimple will look at the functions.php file, which will in turn move the required plugins to the proper place.

Just be sure to make a copy of the file when testing things as it deletes itself once it has run. Let me know how it goes. Smile
Reply




Users browsing this thread: 2 Guest(s)