Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CKEditor 4.0.2 Update
#26
I fail to see the problem that needs to be fixed.

FYI the Kama skin doesn't exist in that branch and the cke is custom not full.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#27
(2013-04-08, 03:43:21)karamo Wrote: Ich verstehe nicht, wo das Problem liegt, dass meine Anregungen nicht akzeptiert werden. Diese minimalen Änderungen würden das Problem lösen.
I don't understand the problem accepting my recommentations. The minimal changes would solve the Problem.

Shawn,

I support Wolfgang, there is no need to cripple the functionalitly, better to continue like we did all the time: default is a slim equipment and all options to enhance and add more functions are kept

why not?
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#28
Hello,
(2013-04-08, 09:35:33)shawn_a Wrote: I fail to see the problem that needs to be fixed.
FYI the Kama skin doesn't exist in that branch and the cke is custom not full.
1) Please check it:
!!! - Changes from Toolbar-Buttons will not recognised !!!
A mouse-click is not a "keyup"-event !!!

2) Skin "kama" does exist !!! see:
http://ckeditor.com/addon/kama

DE: Bitte teste das nochmals! Änderungen von einem Toolbar-Button, zB. "B" (Bold,fett), werden nicht wahrgenommen !!! Denn eine Maus-Betätigung ist eben kein "keyup"-Event und wird daher auch nicht ausgelöst.
Vielleicht können das andere auch noch testen, damit ich nicht ganz alleine dastehe mit dieser Behauptung, denn ich kann mich auch irren, aber ich habe das mehrmals getestet und so festgestellt.

LG Wolfgang
Reply
#29
kama does not exist in THAT BRANCH. I didn't add it, you have to add it yourself.
Was kama included in 3.1 ?

What does changes from toolbar buttons not recognised mean ?
Can you explain in more detail ?

Ill find out why basic is missing justify buttons etc.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#30
I will start a new thread on this branch, since it appears this is offtopic for this thread, and some people might be confused.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#31
Hello,
(2013-04-08, 22:53:32)shawn_a Wrote: 1) kama does not exist in THAT BRANCH. I didn't add it, you have to add it yourself.

2) What does changes from toolbar buttons not recognised mean ?
Can you explain in more detail ?

ad 1) ok, exactly what I did. And therefore I need the flexibility and the freedom to do that: Adding Skin-kama

ad 2) If you enter editing a page and the first step is eq. marking a word and then click [B] = Button for bold, onthe right side, out of the Editor, under the big Button {PAGE_UNSAVED} does NOT appear. If you press a key for editing the text, then it will appear.

(2013-04-08, 22:54:32)shawn_a Wrote: I will start a new thread on this branch, since it appears this is offtopic for this thread, and some people might be confused.
Ok, link to that new thread, please.

DE: Auf Grund meiner sehr langen Programmiererfahrung (und "Beta-Tester") habe ich festgestellt, dass ein schlanker, klarer Code, ohne Schnörksel, Haken oder Ösen, vorzuziehen ist.
Wenn ein Programm, wie in meinem vorangegangenem Posting beschrieben, definitiv falschen Code generiert, oder unnötige Beschränkungen auferlegt, dann ist das ein Grund für mich, darauf hinzuweisen. Wenn mein Vorschlag nicht akzeptiert wird, obwohl die Sachlage klar ist und ich bereits eine saubere Lösung angegeben habe, dann tut es mir sehr leid, und ich bin nicht mehr gewillt, meine Energie dahingehend zu verschwenden.

"Wer lesen kann, ist entscheident im Vorteil !"

Kurz und klar: Wenn CKE 4 per default die Toolbar-Buttons bereitstellt, und auch andere Skins, dann ist es nicht nötig, durch eine Behinderung seitens GS das zu verhindern.

@Connie: Wäre es möglich, einen Bereich einzurichten, in dem Modifikationen von GS u.a. (zB. PlugIns) ohne "Diskussions-Müll" bereitgestellt werden können, die von der "offiziellen" Seite (noch) nicht akzeptiert und eingearbeitet werden?
EDIT: Ist bereits verfügbar, siehe: http://www.get-simple.de/editor/editor-update/
LG Wolfgang
Reply
#32
Fixed, to 'cke full', sorry about that, i was trying to avoid having 69 plugins, but the size is still pretty small.

http://get-simple.info/forums/showthread.php?tid=4614
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#33
I will fix the change listener in a bit to the new one as you mentioned.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#34
Wolfgang,

ich danke dir für deine Arbeit. Shawn hat es ja nun gesehen und er hat es in die neue Betaversion aufgenommen, wenn ich es richtig verstehe.
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#35
Hello,
(2013-04-09, 00:01:18)shawn_a Wrote: I will fix the change listener in a bit to the new one as you mentioned.
ok, very fine. It is a big step into "perfection" Smile

(2013-04-09, 17:20:19)Connie Wrote: Shawn hat es ja nun gesehen und er hat es in die neue Betaversion aufgenommen, wenn ich es richtig verstehe.
Ja, das hat er. Die anderen Kleinigkeiten werden wir auch noch irgendwie unterbringen können, um den generierten Code sauber zu bekommen und um kleine Einschränkungen aufzuheben.
LG Wolfgang
Reply
#36
It has been fixed already
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#37
(2013-04-11, 07:57:57)shawn_a Wrote: It has been fixed already
No, is not quite right. Not all fixed.

My remarks in Posting #22 still remains!
Preventing the default Toolbar-Buttons of CKE 4.1 full

Your recommentation (in gsconfig.php) produces wrong code:
Code:
define('GSEDITOROPTIONS',"toolbar: null");

EDIT: Meine Vorschläge zur Code-Verbesserung wurden abgelehnt und als unbedeutend und verwirrend für die Leser angesehen. Da dies aber nicht mein Bestreben ist, habe ich die Vorschläge hier auch gelöscht und werde sie in geeigneter Form anderweitig publizieren.

LG Wolfgang
Reply
#38
The change trigger has been fixed.

It is helpful if you do not combine issues . This has nothing to do with ckeditor 4.1.
I this is an issue then it always was an issue nothing has changed. It is therefore a new issue , you are causing confusion. Also this configuration has always worked.

If you want some feature the create a new issue about it and say what you want or what doesn't work, nothing you are posting makes sense to anyone but you.

It is very hard to track and issue when you are posting a bunch of code blocks, and your own solutions.
Post the problem, what is expected, and how to reproduce. That is all a developer needs to know about an issue.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#39
Create a new post about this and i will look at it, as i am still unclear about what your are trying to do, you have not explained it very well.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#40
I explain what I did:

1. I download Stable patched to ck editor 4.1 from https://github.com/GetSimpleCMS/GetSimpl...ki/testing
2. I extracted from the zip "CKfolder" and replaced with the one onto my website.
3. I extracted from the zip "edit.php" and replaced in http://www.mywebsite.it/admin/
4. I tried to edit pages, but the editor is disappear.

How can I integrate CKeditor full into my website? Could you write the step I have to follow? Thank in advanced
Reply
#41
(2013-04-30, 19:53:58)zintonio Wrote: 1. I download Stable patched to ck editor 4.1
2. I extracted from the zip "CKfolder" and replaced
3. I extracted from the zip "edit.php" and replaced
4. I tried to edit pages, but the editor is disappear.

What Version of GetSimple?
Look at:
http://www.get-simple.de/editor-update/e...ersion-41/
for updating GS 3.2.0 to use CKE4.1

If you need help for translation, call me.

LG Wolfgang
Reply
#42
(2013-04-30, 20:18:10)karamo Wrote:
(2013-04-30, 19:53:58)zintonio Wrote: 1. I download Stable patched to ck editor 4.1
2. I extracted from the zip "CKfolder" and replaced
3. I extracted from the zip "edit.php" and replaced
4. I tried to edit pages, but the editor is disappear.

What Version of GetSimple?
Look at:
http://www.get-simple.de/editor-update/e...ersion-41/
for updating GS 3.2.0 to use CKE4.1

If you need help for translation, call me.

LG Wolfgang

Thanks for reply, I use GetSimple 3.2.1. Can I use the same step written in
Die erforderlichen Schritte: section?

I have a lot of plugin installed in web site I do not want replace with Stable patched to ckeditor to 4.1. I just want change the editor.

I appreciate if you can help me with translation, otherwise I have to do by myself.

Thanks
Reply
#43
Stable patched is 3.2.1
Shrug
It's the same thing, or just look the the diffs between branches, and apply them.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#44
(2013-04-30, 22:17:35)shawn_a Wrote: Stable patched is 3.2.1
Shrug
It's the same thing, or just look the the diffs between branches, and apply them.

It works!!! The only problem is that in the other plugin for example news manager and Newsletter the editor disappear.
In this case I have to modify the plugin but in some cases it is very difficult.
Do you know any idea how to avoid rewrite plugin?

Thanks
Reply
#45
I will take a look at those plugins and see what is conflicting, and if there is a way around it. Unless you already know ? Its probably the skin.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#46
Hallo,
Sorry, "GS 3.2.1 stable" (2013/04/30) seems to be not "GS3.2.1 patched with CKE4.1".
All Problems of GS 3.2.0 are existing. Don't use it !
Use Stable patched to ckeditor to 4.1 Download
This Version is working with CKE4.1 and skin "moono" or "kama".
Modifications are possible !!
If you want, apply my patches following:
... a moment please ...

LG Wolfgang
Reply
#47
(2013-05-01, 02:17:36)karamo Wrote: Hallo,
Sorry, "GS 3.2.1 stable" (2013/04/30) seems to be not "GS3.2.1 patched with CKE4.1".
All Problems of GS 3.2.0 are existing. Don't use it !
Use Stable patched to ckeditor to 4.1 Download
This Version is working with CKE4.1 and skin "moono" or "kama".
Modifications are possible !!
If you want, apply my patches following:
... a moment please ...

LG Wolfgang

I just followed the istructions posted in http://www.get-simple.de/editor-update/e...ersion-41/, and it works very good with GS 3.2.1

(2013-04-30, 23:06:08)shawn_a Wrote: I will take a look at those plugins and see what is conflicting, and if there is a way around it. Unless you already know ? Its probably the skin.

I examinated news manager plugin, and I rewrite ckeditor.php following the Karamo's instructions. It works very good!
About MLD newsletter plugin is little bit more complicated to examinate.
Reply
#48
(2013-05-01, 17:26:58)zintonio Wrote: I just followed the istructions posted in http://www.get-simple.de/editor-update/e...ersion-41/ and it works very good with GS 3.2.1
Smile very fine, I'm happy to hear that. I had no time for 100%-test, but will come soon.
LG Wolfgang
Reply
#49
(2013-05-01, 17:44:37)karamo Wrote:
(2013-05-01, 17:26:58)zintonio Wrote: I just followed the istructions posted in http://www.get-simple.de/editor-update/e...ersion-41/ and it works very good with GS 3.2.1
Smile very fine, I'm happy to hear that. I had no time for 100%-test, but will come soon.
LG Wolfgang

Obviously, for my purposes, works fine. So I cannot say 100%-tested but I am satisfied! The greater job is to update the plugins which use this ckeditor. But step by step I will try to do it.
Thanks for support
Reply
#50
I am going to test news manager with the patch_cke branch, I am going to assume the big issue is the skin is non existent now. I might go ahead and retain both versions, and move the core cke to a new folder so that plugins al continue to load the old version, not really sure what the best option is, some plugins include their own some use core files, it would be very hard to predict what plugins might do when they are assuming an old version. Priority would be to not break them to start with.

Oh and i have no idea what karamo is talking about.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels