Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
host doesn't allow .htaccess, site transfer
I just finished building a website for a client who uses "enom" for hosting. When I transfered the site, I saw the "non-apache server environment" warning and uncommented the line in gsconfig and it went away.

After that, I attempted to log into the admin pannel with no success at all, and the recover function password doesn't send a new one.

Php IS running though. As a matter of fact, the website, except for the website root being incorrect because I couldn't log in to update it, is basically running.

Enom doesn't allow you to use .htaccess files, it uses a system where you select which file you want the server to automatically load. When I tried to add a file named .htaccess to that list, it doesn't allow it.

I also need to guarantee that the website is secure, since their previous website was maliciously attacked (probably because of enom right?)

What are my options at this point? I just knew Enom was going to give me problems *facepalm*. I have a feeling that my best and easiest option is just convince the client to transfer the domain name registration to me, and ditch enom for hosting all together?
From Enom:

Quote:Do not use virtual includes, and do not use relative or parent paths. Always try and use full paths when ever possible.
Safe mode and Register Globals are enabled by default, however we allow to put your own custom php.ini file in your website root. Sessions will automatically start - you would need to turn off the session start in your code, or lower your error reporting in a php.ini file.
This is a IIS server - so that means that you can not use .htaccess files to over write global settings. You can however use a php.ini file in your root directory to set some of the settings. Some of them are disabled globally.
To see all the server settings, module settings and compiled extensions, please create a file called phpinfo.php. In that file, place only this one line:
<?php phpinfo(); ?>
Now upload and browse to the file in your web browser.

Am I doomed?
well if it doesnt support htaccess and you got the apache warning ( which is there for a reason ) Then your site is probably wide open for attacks, and your user files might even be viewable from the web.

People are running on IIS but you have to handle security yourself.

Try turning debug mode on and see if you can find out why logins are failing, also check
data/other/logs/error log
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
(2013-06-12, 22:39:15)djrodan Wrote: Am I doomed?

Not necessarily. Enom appears to offer Linux hosting at the same price, so unless you really want to gain experience with IIS, get your client to change the hosting.

Their Features list specifically mentions .htaccess files are allowed with Linux (as you'd expect).

Users browsing this thread: 1 Guest(s)