Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BETA RELEASE v3.3.0 release candidate
#26
(2014-01-09, 03:50:07)shawn_a Wrote: Translation strings diffs not yet compiled.

Hi

As a translator, i'd like to subscribe to any notification system you might have.
Couldn't find. Any pointer/help welcome.

Thanks
Emmanuel
Reply
#27
You can track lang on github
https://github.com/GetSimpleCMS/GS_LANGS
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#28
(2014-01-15, 04:07:02)shawn_a Wrote: You can track lang on github
https://github.com/GetSimpleCMS/GS_LANGS

New strings found:

PHP Code:
"SITE_UPDATED"            =>    "Your site has been Updated",
"SERVICE_UNAVAILABLE"    =>    "This page is temporarily unavailable"

Easy update Wink
Reply
#29
Anyone figure out these header already sent issues ?

Check you gs error logs for the errors or your host logs.

It is possible that the error is before php error levels are set in common.php and not in the gs error log.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#30
(2014-01-17, 06:18:34)shawn_a Wrote: Anyone figure out these header already sent issues ?

Terrible issues in the admin regarding headers...Sad

Mostly the plugins list, upon activating/deactivating,
it looks like nothing has been done, so you click again...
oh, and for pages too: you delete a page, but still here,
are re-appearing later... aso. Why? Ajax issue?

Had to install a No-Cache extension to be able to work decently.
But this is not a requirement we can ask to customers, right?

P.S.
The only place where i've found some HTTP header setting is in /template/style.php. For the css, and nothing for the pages themselves or am i missing something?
Reply
#31
Cannot reproduce, PHP 5.3.5, I don't get those errors.
No idea, I can only suggest that someone getting them, tries commenting out ob_ function calls in admin/index.php:
Code:
//ob_start();
include('inc/common.php');
//ob_end_flush();
Reply
#32
Yeah I have tested on every install I have, no errors, i also tried on php 5.2-5.4 in fact this fix lets me login even if debug mode is one and I have php warnings. But it appears that forcing the buffer flush causes some people issues, or maybe they have a plugin that has another level of output buffering already.

Or maybe it is related to this, and not that commit at all.
https://github.com/GetSimpleCMS/GetSimpleCMS/issues/653
Maybe you can try reverting these 2 and see which one fixes it ( not at the same time of course )

emanwebdev
No clue what you are reporting, thats a new one to me, perhaps it is related to this
https://github.com/GetSimpleCMS/GetSimpl...4?source=c
Or server sending some whackado cache headers or proxy, or a weird browser following non standard cache policies. What browser are you using , you are the first person to ever report this specific issue.
Are you using any special cache rules in htaccess?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#33
3.3.0 is now a month late and now even 3 days late on the revised schedule.
Not good
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#34
(2014-01-17, 07:51:58)shawn_a Wrote: related to this https://github.com/GetSimpleCMS/GetSimpl...4?source=c

right. think so too.

(2014-01-17, 07:51:58)shawn_a Wrote: Or server sending some whackado cache headers or proxy

no. servers are ok. both local & remote dev /(Apache 2.4. thus, is that the reason!?)

(2014-01-17, 07:51:58)shawn_a Wrote: or a weird browser following non standard cache policies. What browser are you using

Tested on
Chrome, Firefox, Maxthon, IE11, Opera, Safari

GS admin Ajaxed' save ONLY works on... Opera !!!

(2014-01-17, 07:51:58)shawn_a Wrote: Are you using any special cache rules in htaccess?

!!!!! You good !!!! GOTCHA !!!

Following the YSlow and others recommendations
added header expirations directives :
Code:
# Enable expirations
ExpiresActive On

so i guess GS admin is puzzled

Better to add another .htaccess in /admin/ to override site rules.

Or put the admin in a separate subdomain, like gs-admin.mysite.com ???
Reply
#35
UPDATE:

(2014-01-17, 18:51:44)emanwebdev Wrote: added header expirations directives :
Code:
# Enable expirations
ExpiresActive On

After a couple of tests, confirmation: As soon as you activate
expirations directives (ETAG are ok), both GS and the admin get puzzled Cool

Solution without penalizing the front-end site:

Code:
ExpiresActive On
# Default directive
ExpiresDefault "access plus 0 seconds"

to put in a .htaccess in /admin/
Reply
#36
Well I would use a header hook and throw out some cache headers on backend for probably most pages or just ajax. And we can address this in a patch probably.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#37
Release Candidate 2 is out, should fix any remaining issues with this release ( that I know of )

Not the cache issue on ajax, but by default the issue does not exist.

Also if you guys can see if the header issue goes away ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#38
GreaT Job Shawn! My errorlog is clear now!

PHP Version > 5.3.28-1~dotdeb

Thank You
Reply
#39
LANG has changed!!!!!
https://github.com/GetSimpleCMS/GS_LANGS...6ba2067ed1
https://github.com/GetSimpleCMS/GS_LANGS...ter#diff-0
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#40
I think its time to pull the pin off this mother.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#41
RELEASED
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels