Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GetSimple Blog
#51
Using gsblog 3.1.3 @ GS version 3.3.2 ...

Found a bug that occure when using "GSEDITOROPTIONS" at the gsconfig.php
it makes a JS error that hides the ckEDITOR in the new/edit post screen.

BUG FIX:

open gs-blog/inc/manage_custom_fields.php at line 240

turn
Code:
    if (defined('GSEDITOROPTIONS') && trim(GSEDITOROPTIONS)!="") { $EDOPTIONS = ", ".GSEDITOROPTIONS; } else {    $EDOPTIONS = ''; }

into:
Code:
    if (defined('GSEDITOROPTIONS') && trim(GSEDITOROPTIONS)!="") { $EDOPTIONS = GSEDITOROPTIONS." ,"; } else {    $EDOPTIONS = ''; }

============== EDIT ==================
Same fix for version 3.2
Reply
#52
I thought I fixed this, hmm i do not see this issue.
Can you give me exact examples, gsoptions and which page your on ?

nevermind, this must be different

yup this is a bug in gsblog it output 2 commas, ok so its not a core issue.
( although I did notice it does wrap custom toolbars in another js array, like we used to do, so you might wind up with an empty toolbar )
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#53
(2014-05-22, 23:51:40)shawn_a Wrote: I thought I fixed this, hmm i do not see this issue.
Can you give me exact examples, gsoptions and which page your on ?
My exact examples is not important since when I looked for the cause I saw it's also with an "innocent"
PHP Code:
define('GSEDITOROPTIONS',"toolbarCanCollapse : 'true'"); 

(2014-05-22, 23:51:40)shawn_a Wrote: yup this is a bug in gsblog it output 2 commas, ok so its not a core issue.
( although I did notice it does wrap custom toolbars in another js array, like we used to do, so you might wind up with an empty toolbar )

not exactly it's a wrong position, not double ... if you'll follow my fix you'll see that it simply puts the comma before instead of after :-)

It's not in core (I saw you fixed that already), and probably occurs whenever "ckeditor.php" or "Custom fields" are used in plugins.
Reply
#54
Exclamation 
Version 3.2.1 is now available on Extend!

Security Fixes:
  • Added check if defined 'IN_GS' to all php files. This prevents files being loaded directly, rather they need to be called from within GS.
  • Updated MagpieRSS from 0.7a to 0.72
Code Changes:
  • MagpieRSS will now use the GS cache instead of trying to create its own. This would fail because of permissions in the plugin dir.
  • Added Italian (it_IT) language file, thanks to Nicola Laviola (nikynik)
  • Fixed typos and a missing string in en_US and it_IT language files.
  • Fixed issue with RSS Auto-Importer creating blank posts when using content.
  • Fixed author not showing in post.
  • Changed strings in en_US language file for descriptions on settings pages.
  • CKeditor Bug? Mentioned in the forums, but I couldn't reproduce it. Used given fix anyway.
  • Removed outdated language files. As translators come on board, languages will be (re)added.
Check out my website: JohnStray.id.au
Reply
#55
I found a small HTML validation issue within frontEndFunctions.php... The output beginning on line 111 really should be a <div> instead of a <p> since the contents of the blog posts will contain <p> elements:

Code:
<div class="blog_post_content">...

You have my thanks for continuing work on this plugin -- it was really easy to get up and running.
Reply
#56
There may also be a glitch with the multi-user plugin -- everything seems to install just fine, but this is what I get after entering a new user's info and clicking "Add New User".
Reply
#57
Try disabling GS blog under plugins and see if the same problem occurs.
Check out my website: JohnStray.id.au
Reply
#58
(2014-05-26, 00:28:27)johnstray2001 Wrote: Try disabling GS blog under plugins and see if the same problem occurs.

If I deactivate GetSimple Blog, the multi-user plugin works just fine. When I reactivate GS Blog, it's back to the empty page when adding another user.

Thanks,
Addison
Reply
#59
GS BLOG MODIFICATIONS

Hi!

I've wornking on old GS Blog version (1.5). I just discover this new and exciting fork.

The thing is I think it will be a great idea to merge my changes on the new plugin.
I have no very much experiencie and knowledge on programing, so, I just have did some little changes, so I think someone could easily incorporate and improve the changes to main GS Blog 3.

The changes are these:
  • Change the administration page to allow add a image to post (the old thumbnail system does not work fine)
  • When a image is added, then, some images are automatically generated:
    • The original image is reduced to a 800x800 max file (this avoid users to upload extrmely high files. Useful for customers with no much knowledge about internet, blogs and image files)
    • A small thumbnail for the GS media explorer and the GS Blog administrator zone (the thumbnail is showed when editing a post)
    • A 100x100 cropped thumbnail -> this is used on public article list and the public GS Blog main page. If you clic on the image, you go to article view.
    • A 600x400 cropped thumnail -> this is used on public article view. If you clic on the image, full image is showed.
    • Obiously, a procedure to generate the thumbnails is crated on GSBlog source code.
  • Change the administration page to allow edit or delete previows article image.
  • Modified the article view, article list, etc. for using new thumbnails sizes.
  • Created a new funcion to generate a Blog Breadcrumb.
  • Modified the GSBlog funcions to show Title in Archive list, Search form, Lates articles and categories list.
  • Added a "go back" link at the end of every GS Blog page to go back to the previous page (whitout JavaScrtip, just a real link).
  • Show category link on article view. Useful on public GS Blog page to easily identify the article category and access it.

You can download the modified files here:
GS Blog 1.5 modified by jEsuSdA 8)

You can see a running version of my modified GS Blog here:
GS Blog fork demo

Note: the articles are nonsense, they are only for testing purposes.


----


The fork advantage is focused on customer use:
They can create new article, easily add one image to article (no matters whatever size and megabyte) and clic publish button.

The modified GSBlog generates the image thumbnails and woks as any user expect to work. Big Grin


Please, consider merge my modifications into the new GS Blog branch. I'd do it, but I recognize that I have no the level or experience enough to do that: :_ (
Reply
#60
jesusda,

Thank-you for your request. I will look into adding some of these feature in the next version.

~john
Check out my website: JohnStray.id.au
Reply
#61
(2014-06-01, 14:07:20)johnstray2001 Wrote: jesusda,

Thank-you for your request. I will look into adding some of these feature in the next version.

~john

Thank you!
If I can help you whith any question or someting, let me know.

I'm near to 60% of Spanish translation. I will send the es_ES.php file as soon I finish the translation task. Wink

Thank you!!!
Reply
#62
I seem to have come across a couple of problems with the latest version
  • I'm running 3.2.1 but the update system says I am running 3.2.0 (updated twice to be sure).

  • I can't seem to turn off 'User pretty URLs' once I've enabled it (Just keeps the checkbox ticked once saved).

  • The ' View what your site's .htaccess should be!' popup no longer shows when clicking.
Hope this helps improve a great plugin.

Ade
Reply
#63
I'll add weight to number 2 and 3 as enumerated by apt above. This breaks a key feature since the link to the expanded, complete excerpt is formed with the the slug address; clicking the title/link results in "We are sorry, but the page you are looking for does not exist."
Reply
#64
  • how to change a name of existing category ? i don't see any button..
  • how can i change a position of category ? it should be sorted by ASC, DSC, or custom like menu change position of page.. ( i want create a sub menu for other categories and i want to sort it)
    now only i can create or delete a category...
  • i'm was download a plugin from
    http://get-simple.info/extend/plugin/get...-blog/810/
    the newest version is 3.2.1
    but in plugins version i see: 3.2.0
    it's a bug in version number? or someone don't upload a newest version ?
  • blog should have a option to: always visible a Page Options.
    I'm using it in get simple from plugin:
    http://get-simple.info/extend/plugin/aut...tions/187/
    but in blog plugin it's not working
  • the blog posts should be sorted by ASC, DSC, or custom... - sometimes it's a very useful
  • all fields in Manage Custom Fields without a slug, tags, title, content, should be possible to remove
  • different categories should be able to choose various custom fields ..
    should be possible to assign post to several categories at once (in a situation where different categories have different custom fields - then I do not know what Smile but somehow it should be solved
  • until they "get simple" does not have a universal uploader used in the content pages, news, or other modules .. should be available choices of uploaded files by "file manager"
  • Link images to posts - this option should be added (it's added in a news manager)... images (option) should be linked to the name of post of blog

plugin is great and it only proposals develop. In my opinion, you are doing a great job in a great way! keep it up!!
user plugin: scroll to top
Reply
#65
Any update from the developer on the issues identified with the latest version?
Reply
#66
My apologies to everyone for that late response. Other commitments have kept me from keeping up with this for the last couple of weeks.

apt, snooze, xxdex: All your feature / bug requests have been noted. I will look into adding what I can.
addison: I'm not entirely sure what the issue might be. This calls for further investigation.

The version problem in 3.2.1 is actually a bug. I forgot to update the version number in the main gs-blog.php file before I uploaded it to extend. To fix, simply edit gs-blog.php and change the version number found near the start of the file.

I plan to spend a fair bit of time on the plugin this weekend, so the next version should be out Sunday night (Australian Central Time).

Thanks everyone for all your feedback thus-far!
Check out my website: JohnStray.id.au
Reply
#67
Thanks for the update John, I'll look forward to the release.
Reply
#68
In the meantime, John is the .htaccess somewhere available to copy or download?
Reply
#69
Hi,

I would like show all tags from blog post in the sidebar.

i try to write <?php show_blog_tag(); ?> but not work.
this line <?php show_blog_tag(); ?> show me a post but not "cloud tag"

Can we do that ?


Thanks a lot
Reply
#70
(2014-06-13, 00:18:09)snooze Wrote: In the meantime, John is the .htaccess somewhere available to copy or download?

Never mind, I found it in adminFunctions.php.
Reply
#71
snooze,
The other way to get it, when your on the page in admin, use your browser to view the source of the page, and its sitting between to < pre > tags in there.

t3vall,
That might be a bug. That function is supposed to output the tag cloud. I'll have a look into that.
Check out my website: JohnStray.id.au
Reply
#72
Hello everyone.

It's a second day I am trying this plugin - following the instruction for installation, changing the custom settings and writing a post in the blog, but when I create a post, I find it safe and sound in the "data" folder, and its short version is shown on the page allocated for the blog, but neither a click on the post name, nor a click on "read more" is bringing me to its full version - instead I see 404 page.

Could anyonle please tell me, what I didn't write/adjust somewhere?
Reply
#73
(2014-06-14, 01:23:17)Sharmila Wrote: Hello everyone.

It's a second day I am trying this plugin - following the instruction for installation, changing the custom settings and writing a post in the blog, but when I create a post, I find it safe and sound in the "data" folder, and its short version is shown on the page allocated for the blog, but neither a click on the post name, nor a click on "read more" is bringing me to its full version - instead I see 404 page.

Could anyonle plase tell me, what I didn't write/adjust somewhere?

You will need to modify your root .htaccess file. There is a known bug in the current version that stops this info from showing in the admin area.

You will need to add the following lines to .htaccess (where 'blog' is the slug to the page you choose in settings (change all if required)):
Code:
RewriteRule ^blog/post/([^/.]+)/?$ index.php?id=blog&post=$1 [L]
RewriteRule ^blog/tag/([^/.]+)/?$ index.php?id=blog&tag=$1 [L]
RewriteRule ^blog/page/([^/.]+)/?$ index.php?id=blog&page=$1 [L]
RewriteRule ^blog/archive/([^/.]+)/?$ index.php?id=blog&archive=$1 [L]
RewriteRule ^blog/category/([^/.]+)/?$ index.php?id=blog&category=$1 [L]

Your final .htaccess file should look something like this:
Code:
AddDefaultCharset UTF-8
Options -Indexes

# blocks direct access to the XML files - they hold all the data!
&lt;Files ~ "\.xml$"&gt;
    Order allow,deny
    Deny from all
    Satisfy All
&lt;/Files&gt;
&lt;Files sitemap.xml&gt;
    Order allow,deny
    Allow from all
    Satisfy All
&lt;/Files&gt;

RewriteEngine on

# Usually RewriteBase is just '/', but
# replace it with your subdirectory path -- IMPORTANT -> if your site is located in subfolder you need to change this to reflect (eg: /subfolder/)
RewriteBase /

RewriteRule ^blog/post/([^/.]+)/?$ index.php?id=blog&post=$1 [L]
RewriteRule ^blog/tag/([^/.]+)/?$ index.php?id=blog&tag=$1 [L]
RewriteRule ^blog/page/([^/.]+)/?$ index.php?id=blog&page=$1 [L]
RewriteRule ^blog/archive/([^/.]+)/?$ index.php?id=blog&archive=$1 [L]
RewriteRule ^blog/category/([^/.]+)/?$ index.php?id=blog&category=$1 [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule /?([A-Za-z0-9_-]+)/?$ index.php?id=$1 [QSA,L]



If you are hosting on a Microsoft IIS based server, you will need to modify your web.config file to add the following rule (Needs to be first in the list):
Code:
$<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <clear />
                <rule name="Blog" stopProcessing="true">
                    <match url="(^feed)/([|^post|^tag|^page|^archive|^category]+)/([^/.]+)/?$" ignoreCase="true" />
                    <conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
                    <action type="Rewrite" url="index.php?id={R:1}&amp;{R:2}={R:3}" appendQueryString="true" />
                </rule>
            </rules>
        </rewrite>
    </system.webServer>
</configuration>
Check out my website: JohnStray.id.au
Reply
#74
Bug 
The following is a list of bugs and features that have been requested. Some will be implemented, but some won't. This list contains the answers with reasons. Bugfixes will be done first, then features next.

I'd also like to let everyone know that an entire code rewrite is underway that will become version 4.0. This is still a number of months away though. This version will include many new features, much better compatibility with other plugins, plus much better debugging when in debug mode.

List Key:
{Y} Yes. Will be added.
{N} No. Won't be added.
{A} Already Implemented.
{?} Not Sure. Confusing Request.

jesusda:

- Change the administration page to allow add a image to post (the old thumbnail system does not work fine)
- {Y} New thumbnail system will be developed.

- When a image is added, then, some images are automatically generated
- {N} Multiple thumbnails will not be added. You can do this effect with CSS.

- Change the administration page to allow edit or delete previows article image.
- {Y} New thumbnail system will be developed.

- Modified the article view, article list, etc. for using new thumbnails sizes.
- {N} Multiple thumbnails will not be added. You can do this effect with CSS.

- Created a new funcion to generate a Blog Breadcrumb.
- {Y} I have released a breadcrumb plugin that will be updated to support GS Blog posts.

- Modified the GSBlog functions to show Title in Archive list, Search form, Latest articles and categories list.
- {?} Not sure what is being requested here...

- Added a "go back" link at the end of every GS Blog page to go back to the previous page (whitout JavaScrtip, just a real link).
- {Y} Links will be updated accordingly.

- Show category link on article view. Useful on public GS Blog page to easily identify the article category and access it.
- {A} Already implemented. A setting exists for this, author and date in main settings page.

apt:

- I'm running 3.2.1 but the update system says I am running 3.2.0 (updated twice to be sure).
- {Y} Bugfix. I forgot to update the version number before uploading.

- I can't seem to turn off 'User pretty URLs' once I've enabled it (Just keeps the checkbox ticked once saved).
- {Y} Bugfix. I will investigate and fix in the next version.

- The 'View what your site's .htaccess should be!' popup no longer shows when clicking.
- {Y} Bugfix. JavaScript error. Will fix in the next version.

xxdex:

- how to change a name of existing category ? i don't see any button..
- {Y} Will add the ability to edit categories.

- how can i change a position of category ? it should be sorted by ASC, DSC, or custom like menu change position of page.
- {Y} Category sorting option will be added to settings.

- blog should have a option to: always visible a Page Options. I'm using it in get simple from plugin: Auto-open Page Options
- {Y} Compatibility with this plugin will be added.

- the blog posts should be sorted by ASC, DSC, or custom... - sometimes it's a very useful
- {N} Not in the scope of a classic blog which is sorted by date.
- Maybe you could create custom function to do this by getting the array of posts and sorting the array before output.

- all fields in Manage Custom Fields without a slug, tags, title, content, should be possible to remove
- {A} Already implemented. All non-required fields can be removed.

- different categories should be able to choose various custom fields.
- {N} Too difficult to implement. Would require an entirely different post structure.

- should be possible to assign post to several categories at once
- {Y} Might be difficult to do, but I will look into this.

- Link images to posts - this option should be added (it's added in a news manager)...
- {Y} Bugfix. Thumbnail images should already have been links to their respective posts.

t3vall:

- I try to write <?php show_blog_tag(); ?> but not work. This line <?php show_blog_tag(); ?> show me a post but not "cloud tag"
- {Y} Bugfix. This function is supposed to show a tag cloud.

Other features to be added:

- RSS Auto-Importer thumbnail support will be added so that when posts are imported, a thumbnail will be downloaded (based on the first <img> tag of the content) then attached to the post.
Check out my website: JohnStray.id.au
Reply
#75
(2014-06-15, 00:18:30)johnstray2001 Wrote: You will need to modify your root .htaccess file. There is a known bug in the current version that stops this info from showing in the admin area.

You will need to add the following lines to .htaccess (where 'blog' is the slug to the page you choose in settings (change all if required)):
...

Your final .htaccess file should look something like this:
...



If you are hosting on a Microsoft IIS based server, you will need to modify your web.config file to add the following rule (Needs to be first in the list):
...
Thank you for your rerply, but my root .htaccess looks right now like this:
Code:
#
# GetSimple CMS htaccess ROOT file
# apache 2.4
#

# The following require certain allow overrides, if getting 500 error comment them out one by one
# can be resolved in apache httpd.conf to ensure security alternatives

# override charset
AddDefaultCharset UTF-8

# prevent directory listings
Options -Indexes

# Follow symbolink links, This is required for rewrites on some hosts
Options +FollowSymLinks

# Set the default handler.
DirectoryIndex index.php

# blocks direct access to the XML files - they hold all the data!
<Files ~ "\.xml$">
    <IfModule !mod_authz_core.c>
        Deny from all
    </IfModule>
    <IfModule mod_access_compat.c>
        Deny from all
    </IfModule>
    <IfModule mod_authz_core.c>
        <IfModule !mod_access_compat.c>
            Require all denied
        </IfModule>
    </IfModule>    
</Files>

<Files sitemap.xml>
    <IfModule !mod_authz_core.c>
        Allow from all
    </IfModule>
    <IfModule mod_access_compat.c>
        Allow from all
    </IfModule>
    <IfModule mod_authz_core.c>
        <IfModule !mod_access_compat.c>
            Require all granted
        </IfModule>
    </IfModule>    
</Files>

# handle rewrites for fancy urls
<IfModule mod_rewrite.c>
    RewriteEngine on

    # Usually RewriteBase is just '/', but
    # replace it with your subdirectory path
    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule /?([A-Za-z0-9_-]+)/?$ index.php?id=$1 [QSA,L]
</IfModule>

RewriteRule ^works/post/([^/.]+)/?$ index.php?id=blog&post=$1 [L]
RewriteRule ^works/tag/([^/.]+)/?$ index.php?id=blog&tag=$1 [L]
RewriteRule ^works/page/([^/.]+)/?$ index.php?id=blog&page=$1 [L]
RewriteRule ^works/archive/([^/.]+)/?$ index.php?id=blog&archive=$1 [L]
RewriteRule ^works/category/([^/.]+)/?$ index.php?id=blog&category=$1 [L]
Where 'works' is a page allocated for blog plugin, and nothing has changed after adding these lines. What do I do wrong?

*And I do not know if provider has offered me a Microsoft IIS based server or something else.*

Beforehand thank you for your help.
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels