Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GetSimple Blog
I updated to 3.4.3 with a fresh download and now I get this too: "Blog Settings File successfully written!"
And I still don't have the thumbnail upload option.

Could you please advise?

============

I tried reinstalling the plugin, but still no result.
Reply
Ok, maybe try getting a copy of the master from the GitHub project page.

https://GitHub.com/johnstray/gs-blog/
Check out my website: JohnStray.id.au
Reply
(2016-12-20, 20:58:55)johnstray2001 Wrote: Ok, maybe try getting a copy of the master from the GitHub project page.

https://GitHub.com/johnstray/gs-blog/

I got it right now from github and have the same

Quote:Blog Settings File successfully written!
Blog Settings File successfully written!
Blog Settings File successfully written!

on the frontpage. and the menu in blog admin is there, but doesn't do anything.

btw:
Which themes are reported to be working with your blog plugin?
Reply
I think I see the problem.

In gs-blog/class/Blog.php on line 75, change:
Code:
$update_settings = true;
to
Code:
$update_settings = false;
Check out my website: JohnStray.id.au
Reply
thx, this removed the "Blog Settings File successfully written!" issue, but still any link in the blog menu has no effect at all.
Even the help-link is inactive.
Any content in the "home" page is replaced by "There are no posts to display!"
There's no possibility to use the blog functionality.
May I ask, with which theme you test your plugin?
Are there any dependencies?

I have I18n base, search, navigation, gallery, custom fields, GS shortcodes, less and multi-user plugins installed.

my webserver uses litespeed instead of apache. might that be a problem?
I downgraded to version 3.4.2 and it's the same. Nothing happens, when clicking on any menulink in the blog menu.
Reply
I'm sure I'm doing something really stupid here but I'm new to GetSimple CMS. I downloaded your plugin and put it in my plugins directory and extracted it. This is on Debian 8 with Apache 2. Set permissions for everything to www-data:www-data. Go into admin page. See the plugin. Click on Activate. Go to the Blog tab and I just get a white box. Go back to the plugins tab and the plugin is disabled. It also tells me to upgrade to 3.4.3 which I think I've downloaded but in the gs-blog.php file it still says 3.4.2. I also tried the master file from git but it does exactly the same thing.

Any suggestions?
Reply
(2016-12-22, 03:34:50)pinguin Wrote: thx, this removed the "Blog Settings File successfully written!" issue, but still any link in the blog menu has no effect at all.
Even the help-link is inactive.
Any content in the "home" page is replaced by "There are no posts to display!"
There's no possibility to use the blog functionality.
May I ask, with which theme you test your plugin?
Are there any dependencies?

I have I18n base, search, navigation, gallery, custom fields, GS shortcodes, less and multi-user plugins installed.

my webserver uses litespeed instead of apache. might that be a problem?
I downgraded to version 3.4.2 and it's the same. Nothing happens, when clicking on any menulink in the blog menu.

The multi-user plugin seems to be clashing with this. Deactivating it fixed this exact problem for me. I still needed to change the $update_settings to false in order to get rid of the message constantly popping up though. I don't atm have time to look into it so atm you kinda have to pick either one or the other Tongue Hopefully somebody can fix it.

-Petri
Reply
(2017-01-11, 01:05:16)The multi-user plugin seems to be clashing with this. Deactivating it fixed this exact problem for me. I still needed to change the $update_settings to false in order to get rid of the message constantly popping up though. I don\t atm have time to look into it so atm you kinda have to pick either one or the other Hopefully somebody can fix it. Wrote: -Petri

Hi John, do you have any plans or suggestions for making your blog plugin play nice with Multi-User? Having multiple user accounts is a must-have for every website I create. I'm sure this is a common issue for lots of GS developers.

BTW, your Blog plugin is the first one for GS that actually works and has all of the features you would expect in a blog - nice work!!
Reply
i am really happy with gs blog. it has made big steps ahead comparing it to the version i installed 1 year ago!

but there is one thing that does not work:
while all pages of my gs website display correctly, the parts where the blog is supposed to display the post format shows wrong characters instead of umlauts and not the german date format despite the website being set to german language.
1. why are the characters wrongly displayed?
2. where can i set a different time format from 'F d, Y' resp. why does it not show according to the language selected in gs settings?

thanks in advance!
Reply
Hi johnstray2001,

Thanks for the useful plugin, it makes life easier. Now I can blog easily and quickly post my articles. I have question: There is a section of Categories.. I want to create some "sub-categories" of 4 main categories. Though I didn't find any such a functionality, while creating categories, that's why I have asked you this question.

hope you reply and solve the problem.
Thanks
Reply
Hi John. Have you implemented a tag cloud function yet? Cheers.
Reply
I have the same problem too Big Grin. Cant assign page to Blog it allways go to index page. Also theres no option to select language etc. I have news manager addon, i18n base and gallery plugins installet. If i try Github master version and try to activate the plugin it says error and whole site goes blank.
Reply
I had a couple of issues with this plugin initially (I downloaded the version from the GetSimple Plugin site: http://get-simple.info/extend/plugin/get...-blog/810/) but I was eventually able to track them down and sort them out.

The first was that I was constantly seeing Blog Settings File successfully written! repeatedly at the top of my home page. The second was that the setting for Page to display blog posts setting was not being saved, so the blog would only display on the index slug. It took a little digging to sort out, (and if I was paying attention, the fix for the first was mentioned by johnstray2001) but both fixes are quick and easy.

For the first: Edit plugins/gs-blog/class/Blog.php and on line 75 change $update_settings from true to false:
PHP Code:
$update_settings false

Don't worry, it will still save your settings when you update them, but now only when they are updated.

For the second: Edit plugins/gs-blog/inc/html/settings-main.php and on line 21 change blog_url to blogurl:
PHP Code:
<select class="text" name="blogurl"

Those two tweaks sorted out my issues and at a glance the plugin is working properly now.
Reply
(2017-06-20, 10:53:52)QBFreak Wrote: I had a couple of issues with this plugin initially (I downloaded the version from the GetSimple Plugin site: http://get-simple.info/extend/plugin/get...-blog/810/) but I was eventually able to track them down and sort them out.

The first was that I was constantly seeing Blog Settings File successfully written! repeatedly at the top of my home page. The second was that the setting for Page to display blog posts setting was not being saved, so the blog would only display on the index slug. It took a little digging to sort out, (and if I was paying attention, the fix for the first was mentioned by johnstray2001) but both fixes are quick and easy.

For the first: Edit plugins/gs-blog/class/Blog.php and on line 75 change $update_settings from true to false:
PHP Code:
$update_settings false

Don't worry, it will still save your settings when you update them, but now only when they are updated.

For the second: Edit plugins/gs-blog/inc/html/settings-main.php and on line 21 change blog_url to blogurl:
PHP Code:
<select class="text" name="blogurl"

Those two tweaks sorted out my issues and at a glance the plugin is working properly now.

Thanx, it works now Big Grin.
Reply
Hi, I have recently installed this plugin and am adjusting it to my needs now. I have a problem with length of excerpts. I inserted 350 in the field Length of excerpt (characters): in the front-end interface and initially, I imagined that posts shorter than 350 characters would be displayed full and longer posts will display just the first 350 characters. But shorter posts are displayed without the last word every time (even posts containing only two short words display only the first one and the second one is omitted, posts with three words display only first two words and so on) and longer posts (over 350 characters) are terminated somewhere before the 350th character (a different number in every post, in a range from 204 to 345 characters in my few tests (345 seems to be maximum)). Is there any way to fix this?

Thank you for your advices.
Reply
I tried some attempts and partially have succeeded.
There is this code in the file frontEndFunctions.php:

PHP Code:
# Determine if we should be showing an excerpt or full post.
 
 if(($excerpt == false) || (($excerpt == true) && ($blogSettings['postformat'] == 'Y')))
{
$p['content'] = html_entity_decode($post->content); // Get the full contents of the post
}
elseif((
$excerpt == true) && ($blogSettings['postformat'] == 'N'))
// It's an excerpt...
 
   $el = (empty($blogSettings['excerptlength']) ? 250 $blogSettings['excerptlength']);
// Length?
 
   $p['content'] = $Blog->create_excerpt(html_entity_decode($post->content),0,$el);
// Create excerpt


and I supplemented it this way:

PHP Code:
# Determine if we should be showing an excerpt or full post.
 
if(($excerpt == false) || (($excerpt == true) && (($blogSettings['postformat'] == 'Y')
|| (
strlen($post->content) <= $blogSettings['excerptlength']))))
{
 
   $p['content'] = html_entity_decode($post->content); // Get the full contents of the post
 
 }
elseif((
$excerpt == true) && ($blogSettings['postformat'] == 'N'))
// It's an excerpt...
 
   $el = (empty($blogSettings['excerptlength']) ? 250 $blogSettings['excerptlength']);
// Length?
 
   $p['content'] = $Blog->create_excerpt(html_entity_decode($post->content),0,$el);
 // Create excerpt


It was only a blind attempt but it succeeded (short posts are displayed full, not mutilated now, longer excerpted). What however persist is that length of excerpts set in the front-end administration corresponds not with what is really displayed in a page (really displayed excerpt is much shorter). But it is not so annoying bug and can be bypassed by suitable (overstated) setting in the administration.

I only wonder if I am the only one having troubles with described excerpts' length.
Reply
I ran into a fun issue with posts not showing up today. I wrote it up in my blog: https://s.qbfreak.net/gsbptz

TL;DR Make sure your GetSimple configuration Timezone matches your server's timezone, not necessarily YOUR timezone.
Reply
(2017-06-27, 20:41:01)lotova Wrote: Hi, I have recently installed this plugin and am adjusting it to my needs now. I have a problem with length of excerpts. I inserted 350 in the field Length of excerpt (characters): in the front-end interface and initially, I imagined that posts shorter than 350 characters would be displayed full and longer posts will display just the first 350 characters. But shorter posts are displayed without the last word every time (even posts containing only two short words display only the first one and the second one is omitted, posts with three words display only first two words and so on) and longer posts (over 350 characters) are terminated somewhere before the 350th character (a different number in every post, in a range from 204 to 345 characters in my few tests (345 seems to be maximum)). Is there any way to fix this?

Thank you for your advices.

I started to dig into this (shortly after your last post), but I haven't had the time to hack at it and come up with something better. I did discover the reason the excerpts always seem shorter than the maximum. It is because when it counts characters to determine the excerpt length, it counts the HTML formatting as well as the plain text of the content. IMO this should be changed to ignore all markup. It's something I want to look into if I get some free time. Or maybe the dev will stop by and roll up our changes and a fix for excerpts into a new version. One can only hope Smile
Reply
Hi everyone, sorry I haven't been around in a while. I don't seem to be getting email notifications about new replies from this thread any more. Ill have to fix that.
Answering the list of questions in the order they appear:

@pinquin: I'm not sure why you had the issue of no posts to display. The theme I test with is just the default Innovation theme that comes with GS. There are no dependancies for this plugin. It should work fine all on it's own. I have never used and therefor never tested GS Blog with the lightspeed server, so I have no idea if or how this could affect the operation of the plugin, but in theory, as long as it runs php, it should be fine. Maybe you could setup Apache and test if you still have the same problems.

@mr_clark: The white box issue is usually caused by a PHP error. Please enable debugging or search your server's logs to see what the error is, then report back here.

@petrijah & bensayers: I am aware that there are issues with most of the User Management plugins, but as their developers have not been seen in a while, there is not much I can do about it. I have, however, decided to build a new User Management plugin that's much more powerful that any that currently exist on extend, plus it will be quite easy for plugin developers to hook in to enable permissions in their own plugins. You can follow the development here: https://github.com/johnstray/gs-users

@pigsound: I might have to look into ways to support posts in other languages. I suspect this has something to do with the way the actual content of the post is stored/retrieved from the XML file. The date formats can be changed simply by modifying the language file of choice inside the /plugins/gs-blog/lang/ folder.

@rogi: Unfortunately, I don't think implementing sub-categories will be possible.

@FairlyIncognito: I have not yet implemented a tag cloud, but it is on the todo list for the next major version release (3.5.0).

@lotova: Thanks for the feedback and the fix you provided. I will take a look at it and implement it in the next version.

@QBFreek: Thanks for the feedback. I will look into the issue and possibly rewrite the excerpt function so that it doesn't count any html formatting.


I will try to get a bug fix release out in the near future that covers all the bugs you guys have mentioned so far. I can't be too sure of an ETA just yet though. I'll keep you posted here.

Thanks everyone for all of your positive feedback and bug reports. I greatly appreciate the support!
Check out my website: JohnStray.id.au
Reply
(2017-09-15, 00:23:50)johnstray2001 Wrote: @pigsound: I might have to look into ways to support posts in other languages. I suspect this has something to do with the way the actual content of the post is stored/retrieved from the XML file. The date formats can be changed simply by modifying the language file of choice inside the /plugins/gs-blog/lang/ folder.

hi john,
thank you for your reply. of course i thought about changing the language file in the gs-blog/lang/ folder. since the date format  in this file is already the way i want it to be, i did not change it. conclusion: although the language file is set correctly, the date is displayed incorrectly. i also noticed wrongly displayed umlauts in the blog dates and i wonder where to get this right. i already searched for false encoding settings in the plugin's files, but to no avail.

maybe you can help me with this strange behaviour?
best wishes, pigsound
Reply
(2016-12-31, 10:26:48)mr_clark Wrote: I'm sure I'm doing something really stupid here but I'm new to GetSimple CMS. I downloaded your plugin and put it in my plugins directory and extracted it. This is on Debian 8 with Apache 2. Set permissions for everything to www-data:www-data. Go into admin page. See the plugin. Click on Activate. Go to the Blog tab and I just get a white box. Go back to the plugins tab and the plugin is disabled. It also tells me to upgrade to 3.4.3 which I think I've downloaded but in the gs-blog.php file it still says 3.4.2. I also tried the master file from git but it does exactly the same thing.

Any suggestions?

I have the same problem. The "GS Blog" is the first in the list of plugins, and when I activate it - it is automatically deactivated. However, I changed the name of this plugin to "News" and in this case it works normally, because then it is not the first on the list of plugins, but somewhere in the middle... But, now that I activate "News" then "i18n base" is deactivated because it is now the first plugin on the list.

So, there is some kind of error in the code of the GS blog Exclamation

I did not find any error in debug mode, nor in server logs.

But I only have this problem when my web site is on a localhost. When I transfer it to the server http://www.website.com, everything works normally. In that case there is no problem...

Does anyone have a solution? Confused Huh

Thanks in advance...
Reply




Users browsing this thread: 2 Guest(s)
Free HDTV Channels Residential Solar Panels