Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with implementation at WEDOS
I've been implementing latest GetSimple on my WEDOS pages and I ran into some problems. Which I solved, but the solution may come handy for others, therefore I'm writing this post.

1. .htaccess problem.
WEDOS forbids several commands in .htaccess files Options +FollowSymLinks is one of them. All pages (admin and index) were giving me 500 error. Options +FollowSymLinks is in .htaccess file in default installation of GetSimple. Commenting the line solved this first problem.

2. aliases and bad URLs
I have several domains at WEDOS. Files for these domains are in this folder structure: for is the folder /www/domains/ for is in /www/domains/ etc. The translation of URLs is done by .htaccess in /www/ folder. But GetSimple uses $_SERVER['PHP_SELF'] for getting URLs and I was therefore getting bad URLs like this for index page it was I had to change $_SERVER['PHP_SELF'] to $_SERVER['REQUEST_URI']. And I hope it solved my problem. I don't know this exactly, because I was getting bad URLs during installation and I replaced the variables after installation. But since then I didn't encounter such a problem.

3. Bad CSS within Page Editation.
At the end of the Editation page, there should be a dropdown menu with 'Clone' and 'Save and close' options. I had these signs in pure unordered list and not clickable. I did not need to use these options, but it bothered me and I thought it may be some problem with caching or badly done installation. But I had the problem in two different browsers and trying to avoid cache use was not helpful. I dig through the page structure and css and found that in /admin/template/css.php are CSS rules for #edit #dropdown. But it wasn't working. I didn't find the #edit element in the page, but the body tag had id 'edit.php?index.php' or something like that. I suppose this should be the #edit element, but since it wasn't working and I didn't find usage of the #dropdown element elsewhere, I simply removed the #edit in all lines with #dropdown in /admin/template/css.php and the dropdown started to work as it should.

That's all for now. I'll be setting up the template and site content next so I'll see if I didn't cause any damage with my problem solving.
Sounds like these are all suggestsiteurl function failures.
Are you using symbolic link?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
No. In knowledge base of WEDOS, they say the URL translation is done only by .htaccess in /www/ directory.
Do you have 2 rewrite rules occurring along your web path?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
I'm not sure. I've just landed at WEDOS hosting. Their default .htaccess is this:

RewriteEngine On

# cele domeny (aliasy)
RewriteCond %{REQUEST_URI} !^domains/
RewriteCond %{REQUEST_URI} !^/domains/
RewriteCond %{HTTP_HOST} ^(www\.)?(.*)$
RewriteCond %{DOCUMENT_ROOT}/domains/%2 -d
RewriteRule (.*) domains/%2/$1 [DPI]

# subdomeny (s nebo bez www na zacatku)
RewriteCond %{REQUEST_URI} !^subdom/
RewriteCond %{REQUEST_URI} !^/subdom/
RewriteCond %{HTTP_HOST} ^(www\.)?(.*)\.([^\.]*)\.([^\.]*)$
RewriteCond %{DOCUMENT_ROOT}/subdom/%2 -d
RewriteRule (.*) subdom/%2/$1 [DPI]

# aliasy - spravne presmerovani pri chybejicim /
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^domains/[^/]+/(.+[^/])$ /$1/ [R]

# subdomeny - spravne presmerovani pri chybejicim /
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^subdom/[^/]+/(.+[^/])$ /$1/ [R]
Yeah your url is clearly being adjusted, making it calculate it wrong.

You can clearly see the difference.

GS does not know about this when it tried to guess the siteurl, it probably works fine after you can go in settings and change your siteurl.

honestly i think its odd for a webhost to be using a rewrite for subdomain folder management, ideally this is handled with virtual hosts configs, not sure the benefit here.

I already changed all the PHP_SELF code to
$_SERVER['SCRIPT_NAME'] in 3.4, i wonder if that would help.

Maybe someone will look at this and know right off the bat, ill have to think about it and see how to handle this kind of setup. It might be easiest to just use request_url on setup code.

But that doesn't explain where the heck
edit.php?index.php is coming from , don't see that in that rewrite.

There is also this known issue,
not sure if it factors in also or not.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Yes, I forgott to mention, that I've also set the siteurl in setting to only

I also don't know the benefit of such setting of domains, but I decide to get somehow pass it. Set it once and forget it…
Concerning <body id="edit.php?id=index":
I think that $_SERVER['REQUEST_URI'] used in function myself() could return the url also with the query string used to access the edit.php.
I don't know where else is the function myself() used. It might get the right directory url, but in this case it causes trouble, because originally used $_SERVER['PHP_SELF'] returns the name of the script without query string?
Oh yeah you can't use that you can try using the scriptname thing I posted above.
I didn't realize this was due to your modification.

Try that instead of php self, not request url.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Well, $_SERVER['SCRIPT_NAME'] returns the right id in body tag, but again, it's the same problem like with $_SERVER['PHP_SELF']. In settings GetSimple is again suggesting the wrong website URL As I said, I don't know where else is function myself() used, but it would be great if GetSimple was using only the address from website URL in settings.

Users browsing this thread: 1 Guest(s)