Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Admin Theme
#26
(2015-04-29, 03:32:18)phireware Wrote: Looks like quite a few changes, thanks for all the input! Would everyone be willing to work together with their changes on this in the GitHub repo? I'd like to make this theme as best as possible and perhaps it could be the default theme in a future version!

GitHub: https://github.com/PhireWare/flat-blue

will do, and perhaps yes! What I also like about this theme is that it looks fit to be 'flat-anything'; eg. flat-red, flat-maroon, flat-green, flat-brown etc. If in a future update if the style is partly dynamic, this could be done easily with one setting..

At a certain point it will probably be necessary to check whether this integrates well with I18n pages view too, because a large percent of GS userbase uses the plugin imo.
Reply
#27
The style can already be by using admin.xml colors.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#28
I noticed a weird behaviour of this plugin on a multilingual website (I18N plugin). When activated, if you go to the tab pages -> all pages, the <ul class="nav pages"> onto the header disappear. Actually I can still see it through Firebug but in practice it is somehow hidden and inactivated by the plugin.
Reply
#29
Very Good Job!
Reply
#30
When activated DEBUG MODE - i can`t see debug window
may be need add " id="gsdebug" " in main plugin class?

<div id="gsdebug"><pre></pre></div>
Reply
#31
(2015-05-07, 23:52:57)GPB61 Wrote: I noticed a weird behaviour of this plugin on a multilingual website (I18N plugin). When activated, if you go to the tab pages -> all pages, the <ul class="nav pages"> onto the header disappear. Actually I can still see it through Firebug but in practice it is somehow hidden and inactivated by the plugin.

I added this issue to the Github tracker 2 days ago. Fix by replacing line 79 in the plugin's CSS with:

#header { position: fixed; height: 61px; }
.header { margin:0; border-top:0; filter:none; background-image:none; top: 0; left: 0; right: 0; z-index: 1000;}
Reply
#32
(2015-05-28, 21:05:35)Tyblitz Wrote:
(2015-05-07, 23:52:57)GPB61 Wrote: I noticed a weird behaviour of this plugin on a multilingual website (I18N plugin). When activated, if you go to the tab pages -> all pages, the <ul class="nav pages"> onto the header disappear. Actually I can still see it through Firebug but in practice it is somehow hidden and inactivated by the plugin.

I added this issue to the Github tracker 2 days ago. Fix by replacing line 79 in the plugin's CSS with:

#header { position: fixed; height: 61px; }
.header { margin:0; border-top:0; filter:none; background-image:none; top: 0; left: 0; right: 0; z-index: 1000;}

Thanks! This has been fixed in GitHub.
Reply
#33
If you guys need any help for implementing a new admin theme for newer gs releases, just message me. 
I'd love to contribute! 
Reply
#34
How can I fix the window of "Theme editor"? I mean the grey one. It goes far far away to the right, and I would like to have it proper with settled resolution or auto-fitting to resolution of my screen.
Glowczynski.pl - webmaster, graphic designer, translator.
For any job offers contact me via artur@glowczynski.pl.
Reply
#35
(2015-12-30, 05:51:01)Artur Wrote: How can I fix the window of "Theme editor"? I mean the grey one. It goes far far away to the right, and I would like to have it proper with settled resolution or auto-fitting to resolution of my screen.

Unfortunately I don't have a lot of control over this as the theme editor is the same class as everything else, meaning I need to keep it there for the menubar when it shows up. This could easily be fixed if this wasn't a plugin and was baked right in. If the theme editor had it's own class, I could create something specific for it.
Reply
#36
Just tested it. Looks great, page layout is just what I have been looking for. Mechanically the plugin works fine.

Why will I not use it? Visually the font is unclear. Screen from an older machine without clear type:
   
The font starts from font-weight:300 for headings. I would like not to exclude editing from older OSs. Also the font is downloaded from Google just in Latin subset, which causes national chars displayed in Arial, as you can see.
Reply
#37
(2015-05-28, 22:41:07)phireware Wrote:
(2015-05-28, 21:05:35)Tyblitz Wrote:
(2015-05-07, 23:52:57)GPB61 Wrote: I noticed a weird behaviour of this plugin on a multilingual website (I18N plugin). When activated, if you go to the tab pages -> all pages, the <ul class="nav pages"> onto the header disappear. Actually I can still see it through Firebug but in practice it is somehow hidden and inactivated by the plugin.

I added this issue to the Github tracker 2 days ago. Fix by replacing line 79 in the plugin's CSS with:

#header { position: fixed; height: 61px; }
.header { margin:0; border-top:0; filter:none; background-image:none; top: 0; left: 0; right: 0; z-index: 1000;}

Thanks! This has been fixed in GitHub.
Thanks, the plugin now works (GS version 3.3.13)! Big Grin Maybe someone may change that CSS in the repositories?
Reply
#38
This is a known issue, someone needs to go through the css and convert it all to use normal font weights
https://github.com/GetSimpleCMS/GetSimpl...ssues/1179
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels