Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AdminXML Plus [0.3]
#1
AdminXML Plus is a plugin for easily & quickly customizing the admin.xml file from the GS interface, with instant preview, thereby making it easy to see which color scheme fits your install best. You can also choose from all existing community themes, as well as export your theme for later use, or to be shared with the community. Note: requires GS Custom Settings(0.4 or 0.5 for AdminXML v0.2, 0.6 for AdminXML 0.3). Both the Metro Goldwyn Mayer and the Sunset theme have been created with this UI. =)

Features
  • Instant admin theme preview
  • Create & export your admin theme in no-time.
  • Choose from all existing themes with one click.
  • Reset to GS default colors
  • Sync's with existing admin.xml config.
Installation
  1. If you haven't already, download & install GS Custom Settings 0.4+.
  2. Download the plugin, extract to plugins folder, activate in plugins tab and navigate to the GS Custom Settings 'Site' tab. In the sidebar you will see an item 'AdminXML Plus'.
  3. Ready!

Preview

[Image: hs5b3JV.png]
Reply
#2
So it only allow us to change colours of original admin theme, am I right?
Glowczynski.pl - webmaster, graphic designer, translator.
For any job offers contact me via artur@glowczynski.pl.
Reply
#3
(2015-06-02, 06:21:12)Artur Wrote: So it only allow us to change colours of original admin theme, am I right?

That means the 9 colors you can customize in admin.xml. I believe the GetSimple design is balanced and there's a reason only those are customizable by default. The aim of this plugin is not to provide more  customization options, but to facilitate existing ones & to lower the barrier for creating community admin themes. 
I might be adding a couple non-themeable ones (like text color, pagenav link inactive & hover, which are set resp. to black, lightgray & white), and eventually the possibility to replace the text logo on the left with an image, but that depends on demand for it.
Reply
#4
the translation is not the whole works
https://yadi.sk/i/tQPS06wth2KfW
Reply
#5
(2015-06-02, 07:03:36)Oleg06 Wrote: the translation is not the whole works
https://yadi.sk/i/tQPS06wth2KfW

Huh, that's really weird! Only those 2? This time I tested with French translation and it works... Maybe... can you try something? Cut & paste the 2 first translation strings (PLUGIN_TITLE & PLUGIN_DESCR) to the very bottom of the translation file; does it work?
Reply
#6
I replaced the line in the file of English, no change
http://prntscr.com/7c1ko6
Reply
#7
Totally awesome! (as usual)

You should add a color picker.

Btw. Where can I find the documentation for GS Custom Settings? Your site seems to be taken over by some hosting company..
Reply
#8
@Oleg, sorry I haven't the slightest. Did you put the file online already? If not, could you place it in attachment here so I can test?

(2015-06-02, 08:05:23)datiswous Wrote: Totally awesome! (as usual)

You should add a color picker.

Btw. Where can I find the documentation for GS Custom Settings? Your site seems to be taken over by some hosting company..

Yes the color picker will be in GS Custom Settings 0.6 (so it won't be on this plugin, but it will be able to make use of it).
As for the docs, no it's online, you must've typed it with www (it only works without atm). So http://webketje.com. Alternatively, you can also go to http://webketje.github.io, because it's hosted on Github.
Reply
#9
you mean this file?
http://get-simple.info/extend/plugin-lan...-plus/947/
Reply
#10
(2015-06-02, 12:00:25)Tyblitz Wrote: As for the docs, no it's online, you must've typed it with www (it only works without atm). So http://webketje.com. Alternatively, you can also go to http://webketje.github.io, because it's hosted on Github.

http://webketje.github.io just redirects to http://webketje.com/ . If I go there I get a page from J Crea Websolutions. When I reload I get your website (or not), sometimes it's also your website with some/all styling removed.

Sometimes I get a 404 Not Found error on a subpage.


I also saw this in the end of webpage source:
Code:
</body>
</html>
    </body>
</html>
Reply
#11
Works for me must be your DNS
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#12
Yes, must be over at your end, because there's no way I've got such malformed HTML (it's all templated with Jekyll) Big Grin.


The only problem with the DNS I could see, is that it somehow rewrites webketje.com to http://www.webketje.com
Alas, I haven't had the time or patience to configure both domains to my blog yet (it's somewhat complicated with Github).

If it's your cache, one of the following options should work:
 - If you use Google Chrome, in the right menu, click on 'Open incognito tab', and navigate to the site. 
 - OR Go to http://translate.google.com, type http://webketje.com in the left box, & click the link in the right box.
 - OR Navigate to the site, hit F12, press Reload button next to the URL until you see an option dropdown, & click 'Empty cache & Hard reload'.
Reply
#13
I tested this at my work (maybe because of proxyserver?), at home it doesn't seem to be the case. Still has some incorrect html in the source though, but it doesn't seem to affect the output.
Reply
#14
@Oleg, I found it, stupid typo xD. See below, should have been secondary instead of primary.
Code:
"section_secondary_label":"Вторичные цвета",
"primary_0_label":"Цвет тени активной вкладки в сайдбаре",
"primary_1_label":"Цвет фона активной вкладки в сайдбаре, цвет текста заголовков",

To that occasion, and because I forgot to tweak some names because I changed the plugin name last minute before publishing, v0.2 out. You will need to reactivate it in the plugin page.

- Fixed ru_Ru & en_US language files
- Renamed all functions & tab name to adminxml_plus (used to be admin_theme_customizer, but I found that too broad given the scope of the plugin)

If you had installed 0.1, you might want to delete the old data file in data/other/custom_settings/plugin_data_adminxml.json
You can also leave it there to rot :p. 
Reply
#15
Thank you very much translation work, but I can not change the color scheme admin.
Reply
#16
(2015-06-03, 07:16:20)Oleg06 Wrote: Thank you very much translation work, but I can not change the color scheme admin.

With GSDEBUG on, getting any errors? After manually flushing cache in Settings tab? I retested on GS 3.3.4, 3.3.5, with both GS Custom Settings 0.4 & 0.5, with & without admin.xml, no errors, no problems..
Reply
#17
AdminXML Plus 0.3 released

- Made compatible with GS Custom Settings 0.6. You can now make use of colorpickers if your browser natively supports it.

If you have an earlier version of GS Custom Settings, first deactivate AdminXML Plus, install GS Custom Settings 0.6, then update AdminXML Plus to 0.3.
Reply
#18
The link on the extend site (http://get-simple.info/extend/plugin/adminxml-plus/946/) downloads version 0.2 (maybe still...).
I would appreciate it, if you could update the file, too. Thanks for the work!
Reply
#19
(2015-11-14, 19:09:38)Texta Wrote: The link on the extend site (http://get-simple.info/extend/plugin/adminxml-plus/946/) downloads version 0.2 (maybe still...).
I would appreciate it, if you could update the file, too. Thanks for the work!

Hey Texta, don't worry, it is version 0.3 but I forgot to update the version number in the PHP file. If it were 0.2 it wouldn't work with GS Custom Settings 0.6+. I'll update the file soon.
Reply




Users browsing this thread: 1 Guest(s)