Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BETA 3.3.9 beta 3
#1
3.3.9 Beta 3 released

Only change is ckeditor update, NOTE this has possibility of breaking old stuff that integrate with ckeditor, but there have been no reports yet.

This version is needed to be compatible with modern browsers.

Note this significantly increases the size of our archive.

http://get-simple.info/download
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#2
This is fast tracked to release and will remain the only issue in this version to make tracking and reverting easier.
3.3.10 is already also ready
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#3
Can we just go up from 3.3.8 to 3.3.10?
Reply
#4
They still need beta testing
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#5
(2016-03-22, 07:33:22)shawn_a Wrote: 3.3.9 Beta 1 released

Only change is ckeditor update, NOTE this has possibility of breaking old stuff that integrate with ckeditor, but there have been no reports yet.

This version is needed to be compatible with modern browsers.

Note this significantly increases the size of our archive.

http://get-simple.info/download

The link on that page isn't working.
But looking forward to testing it out.
Reply
#6
fixed
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#7
Is their any change between this and the "GetSimpleCMS-patch_cke" branch? If not, I tested it without any problem for a few weeks.
__
Contact me if you need a french translation file for your plugin.
Reply
#8
Yes
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#9
After upgrading from 3.3.8 I have the same issue as with cke_patch (http://get-simple.info/forums/showthread...5#pid54825), that is, old Ckeditor is still loaded, until I do Ctrl-F5.

I've tried changing, in admin/edit.php,
<script ... src=".../ckeditor.js">
by:
<script ... src=".../ckeditor.js?gsver=3.3.9">
Then after upgrading, the correct ckeditor is loaded but unfortunately the icons are mangled (until I Ctrl-F5).
Reply
#10
I got a solution for this, will test then cut a new beta
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#11
Beta 2 with caching fix attempt
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#12
After upgrading from 3.3.8, ckeditor box is not displayed (blank space), and in the Firefox console I get:

Code:
Error: TypeError: r is undefined
Source file: http://localhost/gs312multilang/admin/template/js/ckeditor/ckeditor.js
Line: 24

Error: TypeError: CKEDITOR.skin is undefined
Source file: http://localhost/gs312multilang/admin/template/js/ckeditor/skins/getsimple/skin.js
Line: 5

Again, I don't get the new ckeditor until I do Ctrl-F5.
Reply
#13
When did you download it ?
Sounds like you are still caching something, and then its mismatching.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#14
Some hours ago, but didn't have the time to report. Will try again.
Reply
#15
Ill have to clean this up, github jacked up my tags and when i fixed it i missed some commits.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#16
:-) Just tried again upgrading from 3.3.8 with this last version.
Correct ckeditor version loaded, but mangled icons. Both in Firefox and Chrome. No js errors this time.
In Firefox I do Ctrl-F5 and get the correct icons. In Chrome I have to clear the cache.

(These tests have been done in my local testing machine, XAMPP, Win10 - will try on another server)

--

Just tested with a live site (cpanel based shared hosting) and I have the same issue with the icons until I clear the browser cache.


Attached Files Thumbnail(s)
   
Reply
#17
beta 3 released

Seems to work fine for me with nocache, It does seem like icons.png might have a problem I am not sure though.

Can you try it ?

I doubt it will fix your problem, the icons does not respect the timestamps, but I am not having an issue regardless.
Ill keep checking, could be a host config for image caching or htaccess maybe.

Do you have an aggressive image cache policy?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#18
Just tested beta 3, same issue, new cke but mangled icons.
I think it's browser cache related. It only happens to me in browsers where I had previously accessed the GS 3.3.8 (or GS 3.3.x) admin panel - Just tried with a different browser which I hadn't used before, and the icons (and cke version) are ok.
At the same time, in Chrome (until I clear the cache), I'm still getting the wrong icons. BTW it's a standard install of Chrome, no changes in config and no extensions (just an adblocker)

My tests are:
- downgrade to GS 3.3.8 (or older) by overwriting index.php and admin folder. Access /admin, clear cache (ctrl-F5) and create a page to check cke and icons. Log out.
- Upgrade to GS 3.3.9 beta, again overwriting index.php and admin. Access /admin and create a page, check cke and icons. (wrong ones, so I clear cache, and then they're ok)
(This is a standard GS install, no changes in .htaccess, no image policies)

Note: for me this issue is not a problem at all. I'm just reporting just in case it's going to be an issue for others.
Reply
#19
I have standard chrome, works for me, Would be interesting to see what your headers say for icons.png.
It probably depends on your hosts cache config.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#20
https://dev.ckeditor.com/ticket/10685
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#21
Just after upgrading, with mangled icons

Request URL:http://localhost/gs338/admin/template/js/ckeditor/skins/getsimple/icons.png
Request Method:GET
Status Code:200 OK (from cache)
Remote Address:127.0.0.1:80
Response Headers
Accept-Ranges:bytes
Content-Length:21235
Content-Type:image/png
Date:Tue, 29 Mar 2016 13:49:18 GMT
ETag:"3f000000036be8-52f3-52a8002a221e8"
Last-Modified:Fri, 29 Jan 2016 21:49:31 GMT
Server:Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1
Request Headers
Provisional headers are shown
Accept:image/webp,image/*,*/*;q=0.8
Referer:http://localhost/gs338/admin/template/js/ckeditor/skins/getsimple/editor.css?t=3.3.9b3
User-Agent:Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36
Reply
#22
We could maybe add a special redirect in htaccess, or a cache rule.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#23
I guess if this is a client cache, there is no fixing it via host. But perhaps in the background on update I can force fetch it using a new url before ckeditor does
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#24
carlos you think this would work ?
added to header.php #93

PHP Code:
<body <?php filename_id(); echo ' '.$bodyclass?> >    
    <?php 
    
// ckeditor skin caching force update
    
if(isset($_GET['updated'])) { 
        echo 
'<img style="display:none;" src="template/js/ckeditor/skins/getsimple/icons.png?t='.get_gs_version().'">';
    }
    
?>

I pushed it to branch 3.3.9b
try it if you want
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#25
Clever, but I'm afraid it doesn't work for me (still wrong icons until I clear cache, several browsers)

Anyway, I think it would only work for the first user accessing the admin panel just after the upgrade.

And another thing I had not thought about: plugins that also include GS's ckeditor (NM, GSB, I18N CF/SP, ...) might still have the wrong ckeditor or icons (unless all of them are updated to use the parameters).

I think I read in the ckeditor link you posted that the only fail-safe solution would be changing ckeditor's path. But this would be a trouble for plugins.

So I suppose it may be better to leave it as it was in beta 1 (better having the old ckeditor with correct icons), and warn in the changelog about the possible ckeditor cache issues.
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels