Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error: edit message when trying to save
Yeah, I was really just agreeing with your previous statement that you would add an owner check to 3.4. - It would be a good idea since it wasn't obvious to me why I was getting the error. I had changed permission to 777 and still had the error. The health check said everything was OK.

@Cobber seems to have had the same issue and resolution. I also went though the "proper" install process of unzipping a clean install of GetSimple, but as soon as I replaced the data folder by uploading via SFTP I started getting the error. (Now I know why Wink )

I've read elsewhere that setting the owner to www-data:www-data globally is not a good idea, so I'm happy with my site the way it is now.

Thanks Shawn, GetSimple is a great CMS, I hope you are keeping well!
Owner check how ?

This is not really possible using php, it is problematic and pretty much useless, since php has no idea how your linux permissions are setup or what your groups are, so checking owner is pointless.
Even doing writable checks are problematic.

Both rely on running shell commands which are a huge security hole, and varies from platform to platform, therefor it is the webadmins job to setup permissions.

If you think there was some warning missing then maybe we can fix that, install usually does writable checks of a sorts, so does health check, but its possible it is missing something or its already fixed in 3.4
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Hi Shawn,

Your health check does something which determines that the data and backup folders aren't writable, and suggests changing the permissions to 777 which gets rid of the warning (but in my case didn't solve the problem).

The error message when saving changes to a page come about because of an error when issuing a chmod()..., maybe your health check could also try a chmod() and if that fails, then you could show a message along the lines of "Unable to change permissions on the backup folder, check that the owner of the backup and data folders have chmod() rights, e.g. www-data, or whatever is appropriate for your server."

I have no idea if that is doable, or practical? But I suspect it is better to change the owner of the folders, rather than changing permissions to 777, and changing the owner fixes the error on saving pages, changing permissions doesn't.
I do not know but usually you need to change your gschmod to use a different kind if its faiiing, then it will not attempt to chmod, and in 3.4 you can disable it entirely.

But if you get chmod errors most likely you need to set your actual permissions in gsconfig, and not let it use the defaults.

Sometimes your saves succeed but you get failure warnings because chmod fails after the save. That is what i mean, it is because you have not set your gschmod properly. ( sometimes chmod is disabled also )
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix

Users browsing this thread: 1 Guest(s)