Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Undefined variable errors during installation
I attempted to install GetSimple 2.01 on a virtual server with this configuration:
Apache 2.2.3
PHP 5.3.2 running in FastCGI mode
mod_write enabled
temp.htaccess was renamed to .htaccess and chmoded to 777. Setting RewriteBase manually or leaving the defuault did not help.

The site is located located at:
/usr/www/capoeira/dev/public_html and aliased to /home/capoeira/dev/public_html

I turned on error reporting in the gsconfig.php file, the error messages I received are listed below (note that the directory is not correct even though I set it correctly in .htaccess):
Notice: Undefined variable: SITEURL in /usr/www/capoeira/public_html/admin/inc/common.php on line 87

Notice: Undefined variable: SITENAME in /usr/www/capoeira/public_html/admin/inc/common.php on line 90

Notice: Undefined variable: LANG in /usr/www/capoeira/public_html/admin/inc/common.php on line 108

Warning: Cannot modify header information - headers already sent by (output started at /usr/www/capoeira/public_html/admin/inc/common.php:87) in /usr/www/capoeira/public_html/admin/inc/common.php on line 129

It tuns out my host was running PHP 5.1.6 not 5.3.2 as listed, meaning this installation problem was related to the json_decode() and pathinfo() problems described previously. It was solved by installing RC 2.02. Nice work on the new release Get Simple developers.
I'm trying out GS on Xampp (PHP 5.2.6) and get the same errors. Tried upgrading to the latest development version but still get this when I navigate to the GS directory:

Notice: Undefined variable: SITEURL in C:\xampp\htdocs\gs2\admin\inc\common.php on line 87

Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\gs2\admin\inc\common.php:87) in C:\xampp\htdocs\gs2\admin\inc\common.php on line 129

Tried rewriting base in .htaccess because I've got GS in a subdirectory, but that made no difference. Any ideas what might be wrong?

EDIT: Okay, I've updated Xampp to 1.7.3 (PHP 5.3.1) and 2.01 works fine now.

Users browsing this thread: 1 Guest(s)