Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
setlang= not working on live site
#1
Just uploaded and migrated a site developed on localhost to a new hosting provider but am experiencing problems with setlang. Have installed I18NBase and I18N but keep getting the following message from provider.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@iomart.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Reply
#2
(2017-02-09, 22:11:42)cobber Wrote: Just uploaded and migrated a site developed on localhost to a new hosting provider but am experiencing problems with setlang. Have installed I18NBase and I18N but keep getting the following message from provider.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@iomart.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Hey cobber, what server are you on? If it's Apache 2.3 or 2.4 and mod_access_compat is not enabled, this might be a problem with incompatible plugin .htaccess files. If you can access the httpd.conf file, you can check it there.
If you have access to Apache error logs (from your host panel), check them (search for "500"), and report error message here.
If you're on a shared host, create a file phpinfo.php with just this code: <?php phpinfo(); ?> and upload it to your GS root path, then load it in the browser, and Ctrl + F search "apache2handler". Check the version, and whether you can see mod_access, or mod_access_compat in the 'Loaded Modules' row.
Reply
#3
(2017-02-10, 09:32:03)Tyblitz Wrote:
(2017-02-09, 22:11:42)cobber Wrote: Just uploaded and migrated a site developed on localhost to a new hosting provider but am experiencing problems with setlang. Have installed I18NBase and I18N but keep getting the following message from provider.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@iomart.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Hey cobber, what server are you on? If it's Apache 2.3 or 2.4 and mod_access_compat is not enabled, this might be a problem with incompatible plugin .htaccess files. If you can access the httpd.conf file, you can check it there.
If you have access to Apache error logs (from your host panel), check them (search for "500"), and report error message here.
If you're on a shared host, create a file phpinfo.php with just this code: <?php phpinfo(); ?> and upload it to your GS root path, then load it in the browser, and Ctrl + F search "apache2handler". Check the version, and whether you can see mod_access, or mod_access_compat in the 'Loaded Modules' row.

Superb thanks, much appreciated :-)
Ok so I have the the following loaded in apache v2.4.6

core mod_so http_core mod_access_compat mod_actions mod_alias mod_allowmethods mod_auth_basic mod_auth_digest mod_authn_anon mod_authn_core mod_authn_dbd mod_authn_dbm mod_authn_file mod_authn_socache mod_authz_core mod_authz_dbd mod_authz_dbm mod_authz_groupfile mod_authz_host mod_authz_owner mod_authz_user mod_autoindex mod_cache mod_cache_disk mod_data mod_dbd mod_deflate mod_dir mod_dumpio mod_echo mod_env mod_expires mod_ext_filter mod_filter mod_headers mod_include mod_info mod_log_config mod_logio mod_mime_magic mod_mime mod_negotiation mod_remoteip mod_reqtimeout mod_rewrite mod_setenvif mod_slotmem_plain mod_slotmem_shm mod_socache_dbm mod_socache_memcache mod_socache_shmcb mod_status mod_substitute mod_suexec mod_unique_id mod_unixd mod_userdir mod_version mod_vhost_alias mod_dav mod_dav_fs mod_dav_lock mod_lua prefork mod_proxy mod_lbmethod_bybusyness mod_lbmethod_byrequests mod_lbmethod_bytraffic mod_lbmethod_heartbeat mod_proxy_ajp mod_proxy_balancer mod_proxy_connect mod_proxy_express mod_proxy_fcgi mod_proxy_fdpass mod_proxy_ftp mod_proxy_http mod_proxy_scgi mod_proxy_wstunnel mod_systemd mod_cgi mod_fcgid mod_ruid2 mod_php5 mod_usertrack mod_speling mod_instaweb
Reply
#4
Found the anwer. It was the .htaccess file.
When I migrated it over from localhost the path was set to /testingFolder.

Once I changed the path back to root / then all worked fine.

Was getting a little worried there for sec.

Hope it helps some one Blush
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels