Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Theme not coming up with https
#1
I enabled https in apache and the pages load but the theme is not coming up.
(try http://www.ko4bb.com versus https://www.ko4bb.com)

I also installed the https plugin  http://get-simple.info/extend/plugin/force-https/1028/
and that seems to work to the extent that the web server returns the https page even if not requested (good) but the theme is still not loading. (I have disabled the plugin for now until that problem is resolved.)

I use the FrixelOne theme.

I am still at GetSimple 3.3.4 (scared to upgrade, the last time it did not go smoothly and I was down for several days, it was most likely my fault but I am not sure how I should go about now if I wanted to upgrade again because I never found out what I did wrong)

Thanks in advance for any suggestion
Reply
#2
Set the 'Website URL' (in admin 'Settings') to https://...

You can't easily have the website available to both http and https requests at the same time, so use https only (is my advice).

I don't know how the force-https plugin works, so you may need to change other links (e.g., in pages, template.php, css files, etc.) to https. I prefer to use this in the root .htaccess file:
Code:
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.domain.tld/$1 [R=301,L]

Add these lines immediately after the existing RewriteBase directive. Use your website address, of course.
--
Nick.
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels