User Tools

Site Tools


installation:requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
installation:requirements [2013/05/16 11:52]
Timbow [Server Requirements]
installation:requirements [2018/08/25 00:10] (current)
plahpoy [Server Requirements]
Line 10: Line 10:
   * Windows hosting has been tested successfully,​ with minor limitations.   * Windows hosting has been tested successfully,​ with minor limitations.
   * Nginx working (tested on Debian Lenny and Squeeze) with minor tweaks.   * Nginx working (tested on Debian Lenny and Squeeze) with minor tweaks.
 +**Would be nice to know where the minor tweaks are for NGINX as nothing working past the first level of pages eg:​www.mydomain.com/​blah/​ works and www.mydomain.com/​blah/​page2/​ does not (404)**
  
 ===== Apache & PHP: Required Modules ===== ===== Apache & PHP: Required Modules =====
 +==== Required Modules ====
  
-This is information on the required PHP/Apache ​modules ​that GetSimple uses:+**[[http://​www.php.net/​manual/​en/​book.simplexml.php|SimpleXML]]** ​is used by GetSimpleCMS for efficient XML document manipulation.\\ 
 +The extension is enabled by default in most distros. To be sure //for local development//,​ open a terminal and list all PHP modules ​by typing:
  
-==== Required Modules (Error) ====+  php -m 
 +   
 +//For remote servers//, upload a file phpinfo.php with the following contents:
  
-  ​[[http://​www.php.net/​manual/​en/​simplexml.installation.php|SimpleXML]] - This module is necessary as GetSimple currently relies on XML to store it's data.  +  ​<?php phpinfo(INFO_MODULES);​ ?> 
-    * If you do not have this installed, you will not be able to use GetSimple.+   
 +..navigate to it in the browser, and search for SimpleXML. 
 +If SimpleXML is not in the list, you need to [[http://​www.php.net/​manual/​en/​simplexml.installation.php|install it]]. 
 +\\ 
 +==== Important but not Absolutely Required Modules====
  
-==== Important but not Required Modules (Warning) ==== +  ​* [[http://​www.php.net/​manual/​en/​zip.installation.php|ZipArchive]] - For making zip [[how_to:​backup_website|backups]] of your website. ​If you do not have this installed, ​GS will try to use the [[http://​php.net/​manual/​en/​book.zlib.php|zlib library]] ​to create .tar.gz files instead of .zip . 
- +  * [[http://​httpd.apache.org/​docs/​current/​mod/​mod_rewrite.html|Apache mod_rewrite]] - This is only needed if you want to use [[:​pretty_urls|FancyURLs]] (set within the control panel'​s '​settings'​ page). aka **rewrite_module**.
-  ​* [[http://​www.php.net/​manual/​en/​zip.installation.php|ZipArchive]] - This is only needed if you want to take [[how_to:​backup_website|backups]] of your website. ​ +
-    * As of GS v3.1, if you do not have this installed, ​your backups ​will try to use the [[http://​php.net/​manual/​en/​book.zlib.php|zlib library]] ​(it will create .tar.gz files instead of .zip) +
-  * [[http://​httpd.apache.org/​docs/​current/​mod/​mod_rewrite.html|Apache mod_rewrite]] - This is only needed if you want to use [[:​pretty_urls|FancyURLs]] (set within the control panel'​s '​settings'​ page.)+
   * [[http://​www.php.net/​manual/​en/​curl.setup.php|Curl]] - Curl is needed to connect to our API to check for GetSimple updates. ​   * [[http://​www.php.net/​manual/​en/​curl.setup.php|Curl]] - Curl is needed to connect to our API to check for GetSimple updates. ​
-    * This means: you don't really need it, but if you want to install it, see [[http://​www.php.net/​manual/​en/​curl.setup.php|here]]. (Debian install via apt-get install php5-curl) 
   * [[http://​www.php.net/​manual/​en/​image.installation.php|GD Library]] - This module is needed in order to create thumbnails on uploaded images.   * [[http://​www.php.net/​manual/​en/​image.installation.php|GD Library]] - This module is needed in order to create thumbnails on uploaded images.
- 
 ======Links====== ======Links======
 Back to the GetSimple Wiki [[:​start|Contents Page]] Back to the GetSimple Wiki [[:​start|Contents Page]]
Line 37: Line 41:
   *[[installation:​requirements|Server requirements and Apache Modules]]   *[[installation:​requirements|Server requirements and Apache Modules]]
   *[[installation:​upgrade|Upgrading to the Latest Version of GetSimple]]   *[[installation:​upgrade|Upgrading to the Latest Version of GetSimple]]
-  *[[how_to:​svn_pull|Automatic installation via the SVN ]] 
   *[[installation:​specific-webhosters|Guidance for Specific Hosting Companies]]   *[[installation:​specific-webhosters|Guidance for Specific Hosting Companies]]
  
  
installation/requirements.1368705138.txt.gz · Last modified: 2013/05/16 11:52 by Timbow