GetSimple Support Forum

Full Version: error: edit message when trying to save
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
just tried saving some random text to the home page and I receive an error message

error: edit

Also in console log I'm getting this but don't think it's relevant

'sbfixed not enabled or scrolltofixed not loaded'
(2016-03-24, 09:02:50)cobber Wrote: [ rel="nofollow" -> ]just tried saving some random text to the home page and I receive an error message

error: edit

Also in console log I'm getting this but don't think it's relevant

'sbfixed not enabled or scrolltofixed not loaded'

There are many possibilities but one problem I and others had is discussed here...

http://get-simple.info/forums/showthread.php?tid=8060
Hi again

Tried uncommenting GSNOCSRF but still getting errror.

Okay so I installed a new fresh version of GS, then added a theme - no problems there.

Next I added the multi user plugin, added a user and made some editing changed while logged in as them - No problem

Next I edited a page as admin and all worked fine (So far)

The only conclusion I can come to is that the problem arises when I try to migrate a site.

The saga continues - still loving this cms, it has huge potential and I back it 100%
thats not your problem, check your error logs and enable debugging
check health check, do all the things we recommend in the sticky
HI Shawn

error log states the follwing.

[26-Mar-2016 23:52:10 Europe/London] PHP Warning: chmod(): Operation not permitted in /var/www/html/getSimpleCms/GS_v8/admin/inc/basic.php on line 320

Bit perplexed as chmod is set to 777 on localhost

Health check also states all files are ok (green) all the way don the list
Chmod might be blocked, warnings wont be fatal though, just warnings.

Hmm, can you save anything? Theme editor? Components? Settings page?

Create new page?
(2016-03-27, 11:26:11)shawn_a Wrote: [ rel="nofollow" -> ]Chmod might be blocked, warnings wont be fatal though, just warnings.

Hmm, can you save anything? Theme editor? Components? Settings page?

Create new page?

Hi Shawn

once site has been migrated I can:

Edit theme and components with no error messages

Create a new page and edit without any error messages

Cannot edit settings and receive error message
Warning: chmod(): Operation not permitted in /var/www/html/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/inc/basic.php on line 322


Thanks again
Did you migrate via the method suggested? clean install ?
(2016-03-28, 00:47:03)shawn_a Wrote: [ rel="nofollow" -> ]Did you migrate via the method suggested? clean install ?

Hi Shawn, thanks for the reply,

I did yeah. I downloaded a fresh copy from GS and installed it clean.

Then I replaced the plugins folder, theme folder and data folder (as explained in the wikki http://get-simple.info/wiki/installation:migrating)

After that I went straight to settings and changed the url accordingly and when I tried to save I got the chmod error.  

When I closed and reopened the browser the url had been changed. So it is updating.
I also then tried opening the admin in another browser (to check if Chrome was playing up), again I edited the admin/settings page - changing the website name field and clicked save. The error message appeared but the save went ahead.

Thanks
So gs just says error edit?
Did you check the actual error log and your host error log
(2016-03-28, 04:21:48)shawn_a Wrote: [ rel="nofollow" -> ]So gs just says error edit?
Did you check the actual error log and your host error log



Yeah the actual error log says: 

[27-Mar-2016 16:44:48 Europe/London] PHP Warning:  chmod(): Operation not permitted in /var/www/html/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/inc/basic.php on line 322

The apache error log has several entries that basically repeat it's self every time I attempted to make a change. Here is a sample.

[:error] [pid 5750] [client 127.0.0.1:37136] PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/www/html/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/template/style.php on line 18, referer: http://localhost/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/pages.php


[Sun Mar 27 15:04:00.812122 2016] [:error] [pid 5752] [client 127.0.0.1:37138] PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/www/html/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/template/style.php on line 18, referer: http://localhost/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/edit.php?id=p2

[Sun Mar 27 15:04:12.565500 2016] [:error] [pid 5755] [client 127.0.0.1:37142] PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/www/html/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/template/style.php on line 18, referer: http://localhost/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/edit.php?id=p2&upd=edit-success&type=edit


[Sun Mar 27 15:15:04.864188 2016] [:error] [pid 10958] [client 127.0.0.1:37168] PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/www/html/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/template/style.php on line 18, referer: http://localhost/testingFolder/flatFileCmsTest/getSimpleCms/GS_v8/admin/edit.php?id=about-me
Ok I've been at this all night, I have installed multiple fresh instances of gs

I've found that once installed I can add a theme to the theme folder as mentioned in the wiki and all works fine.

However when I add the data folder, that's when the problems occur with the chmod issue
When you add your data? Does it work as a fresh install?

Those are warnings in log there could be an actual error hidden in there so make sure you dont miss it.
(2016-03-28, 10:53:04)shawn_a Wrote: [ rel="nofollow" -> ]When you add your data? Does it work as a fresh install?

Those are warnings in log there could be an actual error hidden in there so make sure you dont miss it.

I installed a fresh version of GS and all works fine, then I add the theme folder and all still seems okay.

Even when I add the data folder, my pages are imported correctly and appear in the admin section under pages.

It's when I try to edit a page that I get the error message (even though the edit is accepted). In previous attempts even the settings section in admin gave me the chmod error, now that seems okay. It's just the editing page error message that I receive.

In a red message bar at the top of the page it says:  Error:edit. 
If you get no errors editing pages on a fresh install before you migrate your data then it's a owner permissions problem.
Which means you will have to chmod and chown the files after moving them, there might be a script or guide somewhere in the forums.

Are you ftping them ?

What version of GS are you installing ?
What is GSCHMOD set to in gsconfig ? Have you tried commenting it out or using 755 ?

If your stuff is saving, i might be able to modify to ignore this error.
I have added ability to disable chmods in 3.3.10 beta 2
(2016-03-29, 01:36:52)shawn_a Wrote: [ rel="nofollow" -> ]I have added ability to disable chmods in 3.3.10 beta 2

Hi Shawn

Am using the stable version of GS 3.3.8

Tried uncommenting the GSCHMOD to 755 in config but no joy there.

Not too eperienced using chmod but have checked the permissions and I am the owner for the folders in question and also the group too corresponds to my user name. 

I'm sure I'll get it eventually, Your help is very much appreciated

Thanks
Just as an after thought. I would be curious to see how many others have experienced this problem when migrating a site and also what OS they are using.
not many, only sites with safe_mode which no one uses much these days, or sites that have added chmod to disabled_functiions in php.
(2016-03-29, 07:37:13)shawn_a Wrote: [ rel="nofollow" -> ]not many, only sites with safe_mode which no one uses much these days, or sites that have added chmod to disabled_functiions in php.

Just tried migrating a test site on windows and all went well, so I definitely think its a linux issue with permissions and ownership.
Found I had to change ownership on a couple of files.

sudo chown -R apache:apache data/pages
sudo chown cobber:cobber data/pages
sudo chown -R apache:apache data/other
sudo chown -R apache:apache data/users


Thanks for your help Shawn Smile
I think i have 3.4 set to show owners on health check so it should help figure this out
I had this error today with a new site I had uploaded from a local XAMPP server.

Pages and News Manager were throwing errors on changes.

The Data and Backup folders and files had the owner and group of the SFTP user I had used to upload the site.

I finally noticed that a new page had the owner www-data:www-data and permissions set to 0755 so I recursively changed these to folders ownership to www-data:www-data and permissions to 0755 and the error went away.

So spelling that out during the install check would be a great help to new users Shawn!

Now, my follow up question is how do I upload an existing site to the live server so that the owner is set to www-data:www-data?
thats not really a gs thing, thats a administrator task, every system is different, did you check health check it tells you about permissions errors.

you can try uploading via control panel.

ftp sometimes lets you change owners, sometimes you can just set the proper permissions in the same group.

Sometimes you need to ssh in and chown
Pages: 1 2