Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
500 Error when updating content AND website no longer renders properly
I'm stumped on this one. I migrated my WORKING GS sites to a new host and they worked at first but now they don't.

I've checked permissions, I've upgraded to 3.3.16, I even wiped the site and did a fresh install of 3.3.16 (which is where I am at now), and when I go to update any content on the page, I get a 500 error. I currently have the site rendering because I replaced the template and deleted the top navigation in the template, but that's just a temporary fix.
The biggest issue I think is the fact that I can't edit pages or templates in admin without getting a 500 error,

The error message I get is:

Fatal error: Uncaught TypeError: count(): Argument #1 ($value) must be of type Countable|array, bool given in /home/host/public_html/ Stack trace: #0 {main} thrown in /home/host/public_html/ on line 52

before that, I was getting this error in DEBUG MODE when I tried to access the page and all I could see what the header image but no menu or content.

Fatal error: Uncaught Error: Call to undefined function get_i18n_navigation() in /home/host/public_html/ Stack trace: #0 /home/host/public_html/ include() #1 /home/host/public_html/ include('/home/ionmodco/...') #2 {main} thrown in /home/host/public_html/ on line 21

I also read somewhere that GS has an exploit that maybe I just need to move over to a whole new platform (?) but honestly I love GetSimple and usually have no issues with it. If anyone has some suggestions for me on how to fix either or both issues, it would be much appreciated!

Messages In This Thread
500 Error when updating content AND website no longer renders properly - by grassfrog - 2022-11-10, 02:53:37

Users browsing this thread: 1 Guest(s)