Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ImForms
#1
ImForms support thread
http://get-simple.info/extend/plugin/imforms/1121/
ImForms - is in beta phase any suggestions are welcome!
Reply
#2
Hi,

I really like the form builder you have created. I have had a few issues with it though. I couldn't get smtp to work at all despite numerous attempts with my servers smtp settings, variations of that and also i tried googles smtp settings. couldn't get that to work at all which was a bit frustrating.

I can use it with smtp disabled but the emails that are sent from the form to my gmail end up in the spam folder with the message "This message may not have been sent by: xxxxxx@gmail.com Learn more Report phishing".

The form is responsive which i like, except the google captcha. What i did to fix that was I added data-size="compact" to this line in lib/elements.php:
return '<div '.(($this->class) ? ' class="'.$this->class.'" ' : '').'data-sitekey="'.$this->site_key.'" data-size="compact"></div>';

That reduces it to a smaller size which fits mobile screens but still is OK on larger screens.

I'm not going to bother with smtp this time as I've finished that project and moved on but if those kind of issues could be fixed it would be absolutely ideal for future use!
Reply
#3
Hello Rob1n,

thank you for your feedback.
Well, firstly, ImForms have nothing to do with your SMTP settings, it allows you to use the same settings as PHPMailer, no more no less. On my demo page it also works with a standard Gmail account: http://demos.ehret-studio.com/imforms/

My SMTP settings are as follows:
Code:
$config->mailerDebug = 0;
$config->emailFrom = '******@gmail.com';
$config->emailFromName = '**** *****';
$config->useSmtp = true;
    $config->smtpHostname = 'smtp.gmail.com';
    $config->smtpUser = '******@gmail.com';
    $config->smptPassword = '**************';
    $config->smtpEncryption = 'START_TLS';
    $config->smtpPort = 25;

On PHPMailer's Github page below, you will find a simple example script, that you can use in your environment to find out your correct SMTP settings, If this doesn't work then there is something wrong with your server:
https://github.com/PHPMailer/PHPMailer

You can also try changing the mailerDebug variable to 2 or 3 and take a look at the ItemManager's log file under: /data/other/logs/imlog_2017**.txt

(2017-11-03, 18:30:24)Rob1n Wrote: The form is responsive which i like, except the google captcha. What i did to fix that was I added data-size="compact" to this line in lib/elements.php:
return '<div '.(($this->class) ? ' class="'.$this->class.'" ' : '').'data-sitekey="'.$this->site_key.'" data-size="compact"></div>';

That reduces it to a smaller size which fits mobile screens but still is OK on larger screens.

That's a good thing it will be implemented in the next versions, or I can add an additional variable for this purpose.

Best regards
Reply
#4
Thanks for that, I'll try your suggestions next time. The form really is excellent, good work!
Reply
#5
hello, i tried to set my email by using a custom.config file. But when I try this I get a blank screen and my website is totally shutdown. When I delete the custom.config file my website is back again. Plugin works great but to set my own emailadress it's failing.

Do you know how to solve this?

Kind regards
Reply
#6
Sure, enable debugmode in gsconfig file, then post the error message here
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels