Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgrading 3.3.13 to 3.3.14
#26
have you tried switching to built in themes?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#27
See attached file for screenshot


Attached Files Thumbnail(s)
   
Reply
#28
Yes, I activated Cardinal template, but it had the same effect, all elements are shown, only content which should be loaded with

<h1><?php get_page_title(); ?></h1>
<?php get_page_content(); ?>

is missing.
Reply
#29
very strange and pages show up on backend just fine ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#30
Yes, backend shows no problems.
Reply
#31
did you try using ?id=index and not fancyurl ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#32
Quote:have you tried switching to built in themes?

In my case it is standard Innovation theme with some css adjustments.

Yes, as SoHo22 said: the page layout and elements are as they should be, but instead of the page content: "Page does not exist".

Backend is fine, but in english.

I tried http://www.domain.de/?id=index and I tried switching off fancyurl in settings, no difference.
Reply
#33
I tried it as well, no change.
But my backend is in German.
Reply
#34
Smile 
Sorry, my mistake. I lost a de_DE.php in fire... Angel
Reply
#35
If you want to give me some kind of access i would be willing to take a look, if you have ftp even better, or if you can setup a test site, or new install ina sub directory etc.

I would also be willing to grab an archive of your site and run it myself to see if I can reproduce.

Just IM me to cooirdinate
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#36
@shawn_a

You should have a private message.
Reply
#37
This fix breaks some versions or instances of php 7, not sure exaclty which

https://github.com/GetSimpleCMS/GetSimpl...ssues/1238

https://github.com/GetSimpleCMS/GetSimpl...ad5dcf8a56
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#38
But where do I find that plugin.php? I'm just curious what you did... Rolleyes
Reply
#39
second link above shows the change I reversed, Will release a hotfix soon
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#40
plugin_functions.php
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#41
OK... thank you very much for your work!
Reply
#42
https://github.com/GetSimpleCMS/GetSimpl...tag/3.3.15
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#43
IS ANYONE USING PHP 7.0 + and not having issues with 3.3.14?
Can you test 3.3.15 and see if it has a problem ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#44
(2018-09-08, 04:11:32)shawn_a Wrote: IS ANYONE USING PHP 7.0 + and not having issues with 3.3.14?
Can you test 3.3.15 and see if it has a problem ?

I can try. PHP 7.1.16.

Can you tell which issues I sould be testing?
Reply
#45
I installed gs 3.3.15 (not upgrade) and it seems to work fine on apache 2.4.33 and php 7.1.16. I'm using built in themes and created a few extra pages.

When switching fancy URLs on, links won't work for some reason. Cannot find any problem with .htaccess file.
Reply
#46
Quote:IS ANYONE USING PHP 7.0 + and not having issues with 3.3.14


@acenda

But you are having issues with 3.3.14 - you were the thread opener...
Reply
#47
[quote pid='63027' dateline='1536825248']
IS ANYONE USING PHP 7.0 + and not having issues with 3.3.14
[/quote]

Just a +1, php7.0, same error (404) with 3.3.14, reverted to 3.3.13. I hesitate trying 3.3.15, or 14 with php 7.1, lost too much time already.
Any confirmation on which combination works for sure? OP?
Reply
#48
3.3.15 should be fine
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#49
(2018-09-25, 23:00:17)shawn_a Wrote: 3.3.15 should be fine

Thanks Shawn, Quick Work!
Reply
#50
I uploaded 3.3.15
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 1 Guest(s)