Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
QUESTION How to set Fancy URLs and RewriteBase ?

I failed with setting the Fancy URLs

I have tried GS 3.3.15 and 3.3.13 with the same issue

The situation is :

Health Report is green ! :)) 

Quote:Server Config
PHP - Version actuelle 7.2.9-1 - OK
cURL Module Installé - OK
GD Library Installé - OK
ZipArchive Installé - OK
SimpleXML Module Installé - OK
chmod chmod - OK
Apache Web Server Apache/2.4.25 (Debian) - OK
Apache Mod Rewrite Installé - OK

Quote:PHP disable_functions pcntl_alarm,pcntl_fork,pcntl_waitpid,pcntl_wait,pcntl_wifexited,pcntl_wifstopped,pcntl_wifsignaled,pcntl_wifcontinued,pcntl_wexitstatus,pcntl_wtermsig,pcntl_wstopsig,pcntl_signal,pcntl_signal_get_handler,pcntl_signal_dispatch,pcntl_get_last_error,pcntl_strerror,pcntl_sigprocmask,pcntl_sigwaitinfo,pcntl_sigtimedwait,pcntl_exec,pcntl_getpriority,pcntl_setpriority,pcntl_async_signals,

GS is installed in : /var/www/mysite/


with this content :

<VirtualHost *:80>
       ServerName mysite.local
       DocumentRoot /var/www/mysite
       ErrorLog ${APACHE_LOG_DIR}/error.log
       CustomLog ${APACHE_LOG_DIR}/access.log combined

In /var/www/mysite/.htaccess

there is : RewriteBase /   as suggested 

I've tried (in vain) every options described in wiki :[]=url

At first, the server was running PHP 7.0,
as I read there could have troubles with 7.0,
I upgrade PHP to 7.2 but it doesn't work better !

As everything else look working fine,
including url rewrite itself (http://mysite.local/page1/page-1-1/),
but GS doesn't find the page matching with the rewritten URL
and I get a server answer like :

Quote:Not Found
The requested URL /page1/page-1-1/ was not found on this server.
Apache/2.4.25 (Debian) Server at mysite.local Port 80

So, now I come to think that the problem may come from :
  1. my RewriteBase is wrong 
  2. Fancy URL is bugged

Thanks for help and explanations. 
So nobody knows about fixing the fancy URL ?

Users browsing this thread: 1 Guest(s)