Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Support for multilanguage sites, Internationalization (I18N)
You may have a patched version of GS in your old server.
That's the normal way GS generates URLs for subpages of 'index'.

Ages ago I posted this fix. I suppose it may still work (but now it would be in line 429 or so)
http://get-simple.info/forums/showthread...6#pid14286
Reply
Since changing to PHP-version 7.2 I get a warning:
Quote:Warning: count(): Parameter must be an array or an object that implements Countable in /getsimple/plugins/i18n_navigation/frontend.class.php on line 219

219: 'haschildren' => $showChildren ? count($children) > 0 : self::hasChildren($childurl, $show)

Installation is up-to-date. GetSimple 3.3.15, I18N Navigation 3.3.1

I can suppress the warning by adding
Code:
if (version_compare(PHP_VERSION, '7.2.0', '>=')) {
  error_reporting(E_ALL ^ E_WARNING);
}

Maybe you have a better idea for that.
Reply




Users browsing this thread: 1 Guest(s)