Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
'Multi User 1.4' Plugin
#51
Connie Wrote:Version 1.2

This plugin just doesn't like me ...

Users which I created were not allowed to log in in Firefox, I had to clear the cache many times, delete the user, re-create the user until FF lets me in

in IE 8 no problem ...

so there must be a problem with the cache, or some delayed writing...

For example, I created login for Thorsten, he couldn't log in (totally other computer with other browser cache)
he logged in as "Standard User" and changed password etc. and now he can log in

not so nice, as I say, it does not like me ;=)

Did you run into the problems many others ran into? Blocking access to 'pages' and not setting an alternate landing page?
Reply
#52
mikeh Wrote:Did you run into the problems many others ran into? Blocking access to 'pages' and not setting an alternate landing page?

No, I did not check anything and did not enter a landing page, so the standard should work ... albeit this plugin confuses me as I use other systems where you have to check which options are allowed, here it is a negative selection ...

but: no option checked and no landing page defined, so everything should work and it should let me in ;=(
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#53
Connie Wrote:
mikeh Wrote:Did you run into the problems many others ran into? Blocking access to 'pages' and not setting an alternate landing page?

No, I did not check anything and did not enter a landing page, so the standard should work ... albeit this plugin confuses me as I use other systems where you have to check which options are allowed, here it is a negative selection ...

but: no option checked and no landing page defined, so everything should work and it should let me in ;=(

This is probably a dumb question, but I want to get this figured out for you so it does not happen to anyone else.

Are you using v3.0?
Reply
#54
mikeh Wrote:Are you using v3.0?
Yes, we're using 3.0. Smile
Reply
#55
polyfragmented Wrote:
mikeh Wrote:Are you using v3.0?
Yes, we're using 3.0. Smile
You are having this issue as well?
Reply
#56
mikeh Wrote:You are having this issue as well?

haha, we are working on the same site;=)

get-simple.de will soon be out ... and as we are a team we use the multi-user-plugin ;=)

Cheerio, Connie
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#57
I will try to replicate this problem and test it extensively in a few hours after work.

If you want, please post or pm any specs or info that will assist in my replicating/fixing the issue (installed plugins, custom settings, etc)..

i'll get it figured out Smile
Reply
#58
Mikeh,

now I tried again with a different szenario:

1) I created a user using IE 9
2) I logged in with that user using FF

everything ok

1) I created a new user in FF
2) I logged in in FF

everything ok

the only difference to the situation before:

the problems arouse when getsimple was installed in a subdirectory, e.g. www.pixelblut.de/getsimple
now getsimple is installed in a domain's root, www.get-simple.de, and it works

another difference is that it is 7:36 in the morning and I had my first coffee, the problems happened in the afternoon when I (or my Pc or Firefox) was tired maybe ;=(

let's go like this: before you investigate more, we will test again
I will ask Thorsten to create new users as well and test, if problems persist we will come back here, ok?
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#59
Mikeh,

now I tried again with a different szenario:

1) I created a user using IE 9
2) I logged in with that user using FF

everything ok

1) I created a new user in FF
2) I logged in in FF

everything ok

But:

user "Connie" cannot log in
user "connie" can log in

are the usernames case-sensitive? are there any specifications for upper- or lower-case?
I do not think so, as Txxx_Bxxx is accepted, but Connie not

Getsimple sits in the root and not in a subdirectory

I notice, that the button still shows "edit user" and not "save changes"
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#60
Connie Wrote:Mikeh,

now I tried again with a different szenario:

1) I created a user using IE 9
2) I logged in with that user using FF

everything ok

1) I created a new user in FF
2) I logged in in FF

everything ok

But:

user "Connie" cannot log in
user "connie" can log in

are the usernames case-sensitive? are there any specifications for upper- or lower-case?
I do not think so, as Txxx_Bxxx is accepted, but Connie not

Getsimple sits in the root and not in a subdirectory

I notice, that the button still shows "edit user" and not "save changes"

The user names are case sensitive. That is something I overlooked and will fix now.
Its not so much that username is case sensitive but it is looking for a file called Connie.xml instead of one called connie.xml.
Reply
#61
Mikeh,

I noticed another thing :

I had the account "connie" and edited that account. OK
Then I noticed that I want "Connie" and not "connie", but editing the name created another xml-userfile, did not modify the existing one

maybe that was one of the reasons of my confusion?

And: the button is still not "Save Changes"
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#62
Me again ... sorry for that...

A) everything in Firefox 3.6.16
1) absolute fresh install of GS 3.0 in a subdirectory: www.domainname.tld/testgetsimple

2) User is "admin" with a changed password, not the original one from installation
3) "admin" logged out and logged in again with new passwort
4) "admin" created new user:

Connie with email, use html-editor, language de_DE, no restrictions, no landing page defined

5) "admin" logs out and checks via ftp, that data/users/Connie.xml is created = yes
6) "Connie" tries to log in, no chance
7) Clear the cache etc., no chance

B) Now in IE9:

8) "Connie" wants to log in, no chance
9) logs in as "admin", ok, creates a new user "Peter" with the same data like "Connie"
10) logs out
11) Peter.xml is created
12) "Peter" cannot log in in FF 3.6.16 and in IE9 either

OWNER/GROUP is 704 and the files are 644, when I set them to '755' no chance as well

tested, whether there is a difference if GS is installed in the root or not - no difference

what to do? I sent you information via email
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#63
Awesome, thanks for the detailed list.

I already began working on fixing these issues and will have 1.3 uploaded tonight.

Give me about 3 hours, I am putting my son to sleep now.
Reply
#64
mikeh Wrote:Give me about 3 hours, I am putting my son to sleep now.

I give you more, it's sunday!
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#65
Connie Wrote:
mikeh Wrote:Give me about 3 hours, I am putting my son to sleep now.

I give you more, it's sunday!

Try this out, if it works let me know and I will upload it to extend.

Delete your existing users (except the admin) before trying it out.
Reply
#66
mikeh Wrote:Try this out, if it works let me know and I will upload it to extend.

Tricky Micky ;=)

I deleted the users
I deleted the 2 plugin-files
I uploaded the new plugin version

Albeit it still shows "version 1.2" (no problem with that) I noticed:

1) now the button says "save changes" not "edit user" => +
2) I created user "Connie" with "C", after saving, the username was "connie"
3) after log-out, the file connie.xml was created
4) logging in with "Connie" works
5) logging in with "connie" works as well

to verify that this problem was nothing personal, I added the users "Mickey" and "mouse"
everything works as it should!

Thumbs up!

Please describe in the extend section, that the login-name will be case-insensitive, but stored in lowercase, that will help disorientated users like me a lot ;=)

Cheers, Connie
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#67
Connie Wrote:
mikeh Wrote:Try this out, if it works let me know and I will upload it to extend.

Tricky Micky ;=)

I deleted the users
I deleted the 2 plugin-files
I uploaded the new plugin version

Albeit it still shows "version 1.2" (no problem with that) I noticed:

1) now the button says "save changes" not "edit user" => +
2) I created user "Connie" with "C", after saving, the username was "connie"
3) after log-out, the file connie.xml was created
4) logging in with "Connie" works
5) logging in with "connie" works as well

to verify that this problem was nothing personal, I added the users "Mickey" and "mouse"
everything works as it should!

Thumbs up!

Please describe in the extend section, that the login-name will be case-insensitive, but stored in lowercase, that will help disorientated users like me a lot ;=)

Cheers, Connie

Great, I am glad everything is working.

I have changed the version and I am uploading to extend right now.

Please let me know if you run into any more bugs/problems, or have any requests or needs for your project.
Reply
#68
Was the 1.2.1 or 1.3 (the one in the forum download, not posted "officially") update supposed to solve the IE 9 problem? I've downloaded and installed/tried both, and my problem from before still exists...
Reply
#69
patriotmedia Wrote:Was the 1.2.1 or 1.3 (the one in the forum download, not posted "officially") update supposed to solve the IE 9 problem? I've downloaded and installed/tried both, and my problem from before still exists...

I have not fixed the IE 9 problem. I could not replicate it.
Reply
#70
mikeh Wrote:
patriotmedia Wrote:Was the 1.2.1 or 1.3 (the one in the forum download, not posted "officially") update supposed to solve the IE 9 problem? I've downloaded and installed/tried both, and my problem from before still exists...

I have not fixed the IE 9 problem. I could not replicate it.

OK, I'll see if I can record my screen as soon as I get a free minute to show you. I guess if no one else has this problem (I'm running Vista and IE9) - it's me? I've got 8 on my other computer, going to put 9 on and see if it still happens there.
Reply
#71
hi, really nice plugin!

found a problem, both on local and live installation..
I try to change permissions for a user (block Pages, etc..), click on "save changes" but nothing happens.

my workaround is to create a user and set permissions in that form. this works.
but of course I cannot change permissions when the user is created.
Reply
#72
testing with latest build (got for svn) i sometimes get this error:
Warning: simplexml_load_file(): I/O warning : failed to load external entity "./../data/users/.xml" in /var/www/mysite.it/plugins/user-managment.php on line 680 Unable to load XML file!

maybe that's causes by me, doing a few tests in creating / editing new users, and trying to log in with the new user account using chrome incognito window. I get the same error even when doing a logout.

right now just typing mysite.com/admin/ return that error. TO regain access to my site i have to manually delete the 2 user management plugins
Reply
#73
Mikeh,

am I correct in assuming that "Multiuser Add" is no longer needed in order to create new users? I was going through our installed plugins at get-simple.de and sought for the Extend entry (which I couldn't find).

I'm hesitant to delete Multiuser Add in order to test things.
Reply
#74
I installed GS 3.1B today with the actual multi-user-plugin from the extend , 1.2.1

I can install users, but when I log out, I get this message:

Quote:Warning: simplexml_load_file() [function.simplexml-load-file]: I/O warning : failed to load external entity "./../data/users/.xml" in /var/www/web10/html/getsimplebeta/plugins/user-managment.php on line 680
Unable to load XML file!

but the data file for the new user is there

I deactivated the plugin and deleted it

Am I wrong that multi-user-plugin will come with a language file? In the moment it is only english
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#75
Sorry I Have not been around for a while, been out of the country for over a month!

I'll try and get these issues listed here resolved asap..

polyfragmented Wrote:Mikeh,

am I correct in assuming that "Multiuser Add" is no longer needed in order to create new users? I was going through our installed plugins at get-simple.de and sought for the Extend entry (which I couldn't find).

I'm hesitant to delete Multiuser Add in order to test things.

Multi-user Add is still required. The next version I release will not require it. It is specifically used for adding new users only, while the main plugin file is for editing/viewing users.
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels