Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Get Simple CMS Community Edition
#1
Rainbow 
Hi all,

since there is no hint on the Download page, I thought opening this thread could be helpful to better find the new Community Edition.

The download page of the Get Simple CMS Community Edition is: https://getsimplecms-ce.github.io/

The GitHub repository of the Community Edition is: https://github.com/GetSimpleCMS-CE/

The GitHub repository of additional languages is: https://github.com/GetSimpleCMS-CE/GS-CE-Langs

The GitHub repository of PHP8 plugins for GetSimple CMS Community Edition is: https://getsimplecms-ce-plugins.github.io/

And the topic page with the PHP8 fixes that are the reason for this edition is: http://get-simple.info/forums/showthread.php?tid=16548

And finally from me: thank you for your work! GS IS STILL ALIVE!

Hypertexter
Reply
#2
Thanks for starting this thread.

A few more php8.x compatible links of interest:

Updated plugins

Additional Languages

Single file installer/ updater


GS Community Edition with php8.x compatibility, new features and much more!  Support Me


Reply
#3
Great to see this.

GS remains a great way to launch a website. Could do with a redesign.
Reply
#4
(2023-01-11, 22:01:25)islander Wrote: Thanks for starting this thread.

A few more php8.x compatible links of interest:

Updated plugins

Additional Languages

Single file installer/ updater

Thank you for the links, I updated the first post with some of them.
Reply
#5
Hi!

I did all these updates, either a fresh install or the patch
nothing works
PHP is 8.1.29
See here: https://www.lyriktext.de/wasistdas.php

My server responds with Internal Server Error 500

What can I do? I am moving GS to a new hoster and I am in hurry, because the site is unoperable now
I need a working installation...
|--

Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#6
(6 hours ago)Connie Wrote: Hi!

I did all these updates, either a fresh install or the patch
nothing works
PHP is 8.1.29
See here: https://www.lyriktext.de/wasistdas.php

My server responds with Internal Server Error 500

What can I do? I am moving GS to a new hoster and I am in hurry, because the site is unoperable now
I need a working installation...

Fresh install without any old plugins?
Reply
#7
(5 hours ago)multicolor Wrote: Fresh install without any old plugins?

well, a fresh install without any old pages, plugins etc. produced the 500 message

what I did: 
  • I deleted the uploaded files
  • I set all PHP versions back  step by step , from 8.x to 7.4.33
  • uploaded and tried to install all versions back to 3.3.15
  • I ended up with GS 3-3-16
then I was desperate, always Apache Message 500
  • I then found hints in the .htaccess:
    # The following require certain allow overrides, if getting 500 error comment them out one by one
    # can be resolved in apache httpd.conf to ensure security alternatives

  • I then deactivated "# Options +FollowSymLinks"
  • I could finish the setup, login etc. => so I dared to upload the saved content / files etc. from the former place

  • The website worked, all pages there, menue works etc.
BUT:
  • I cannot edit pages, whenever I try to edit an existing  page,  => 500
  • I have to delete a page, create it new, modify it and publish it, after saving the page = 500!
  • I can go back to ... / admin and open the pages tab: the new page is there, but a new page without a name is created as well!
    I have to delete the new nameless page
  • I can edit the template / Theme files and the CSS without any problem, but I cannot edit the pages (XML)
As far as I understand, all XML - options are active on my host, please check: https://www.lyriktext.de/wasistdas.php

The website is online again, with PHP 7.4.33 and GS 3.3.16 

It took me nearly one day to have a half-operable installation (Frontend), and I lost my trust to GS (you know I was an avid user years ago, user and contributor - now I feel like a victim Sad Sad )
|--

Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#8
(1 hour ago)Connie Wrote:
(5 hours ago)multicolor Wrote: Fresh install without any old plugins?

well, a fresh install without any old pages, plugins etc. produced the 500 message

what I did: 
  • I deleted the uploaded files
  • I set all PHP versions back  step by step , from 8.x to 7.4.33
  • uploaded and tried to install all versions back to 3.3.15
  • I ended up with GS 3-3-16
then I was desperate, always Apache Message 500
  • I then found hints in the .htaccess:
    # The following require certain allow overrides, if getting 500 error comment them out one by one
    # can be resolved in apache httpd.conf to ensure security alternatives

  • I then deactivated "# Options +FollowSymLinks"
  • I could finish the setup, login etc. => so I dared to upload the saved content / files etc. from the former place

  • The website worked, all pages there, menue works etc.
BUT:
  • I cannot edit pages, whenever I try to edit an existing  page,  => 500
  • I have to delete a page, create it new, modify it and publish it, after saving the page = 500!
  • I can go back to ... / admin and open the pages tab: the new page is there, but a new page without a name is created as well!
    I have to delete the new nameless page
  • I can edit the template / Theme files and the CSS without any problem, but I cannot edit the pages (XML)
As far as I understand, all XML - options are active on my host, please check: https://www.lyriktext.de/wasistdas.php

The website is online again, with PHP 7.4.33 and GS 3.3.16 

It took me nearly one day to have a half-operable installation (Frontend), and I lost my trust to GS (you know I was an avid user years ago, user and contributor - now I feel like a victim Sad Sad )

Hello Connie,
I know how frustrating it can be when you are having problems.
Not exactly sure what you mean by feeling like a victim though. :/

As you are probably aware, GS has been largely abandoned by both the original devs and most contributors.
We have been doing everything we can to keep it running, with very little feedback or monetary help.

I can confirm that it is being used and running fine up to php8.3, but not all plugins have been updated obviously.
It is possible that you have encountered a new issue that nobody has brought up, but more than likely it is a server issue.

There have been a few people that reported 500 & 403 errors, but they ended up resolving the issue after talking with their hosting provider and did not post any more info as to what the issue was.

So, a few questions:
  • Were you trying to use the latest v3.3.19.1?
  • What plugins are you trying to use with your install (or was this without plugins)?
  • Did you try to activate DeBug?
  • Do you have access to logs to see what is being reported?

Hopefully we can get this figure out for you.


GS Community Edition with php8.x compatibility, new features and much more!  Support Me


Reply




Users browsing this thread: 1 Guest(s)