Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pages and comments plugin
#51
Hi virtù,

do you use GS 321?. There is a problem with this version. I have to upload a new version with the problem fixed.

I send you a private.

Regards.
Reply
#52
Whats the problem, It should not have broken anything, it can be fixed in 3.2.2 if you let us know.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#53
Yes, please correct
Reply
#54
Let me know the problem duh.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#55
none of the plugins Cumbe does not work with version 3.2.1
Reply
#56
"There is a problem with this version. I have to upload a new version with the problem fixed."

What is the actual problem, maybe it is our fault.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#57
(2013-06-14, 06:11:29)shawn_a Wrote: "There is a problem with this version. I have to upload a new version with the problem fixed."

What is the actual problem, maybe it is our fault.

Thanks shawn_a;
it's a problem with variables of $_SESSION; I think that have fixed this problem, but I have to check it some time more.

At the moment, I have very little time and I have not could to check it with time.

Regards

PD: Within 2 weeks, I think that will have more time...
Reply
#58
Well we do not use sessions in GS, so we must have broken something else. We did restore functionality of the $data_index in 3.2.2, maybe you are using some global that changed, maybe 3.2.2 fixes it.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#59
http://getsimplecms.ru/gs/kontakty/
in version 3.2.2 contact form works, the rest do not
Reply
#60
Hey there.
I installed this plugin and unfortunately I don't see anything where the form should be (front-end).

In code-view there is an empty <p> and two script elements below. But there is no form or anything else.

I've put all pages to the news section (Add button) and enabled commenting. However, no matter what settings I use (with or without captcha, moderating, etc.) there is no output I can see.

I am using 3.2.1 and downloaded just the latest plugin from this site.

Hope someone can help. Any advice appreciated. Thanks!
Reply
#61
Ill try to install this tomorrow and see if there is something in this release that is broken.
I have an install of about 30 plugins I try to test a bunch now and then do not think this is on dev install.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#62
(2013-06-15, 03:44:31)suntrop Wrote: Hey there.
I installed this plugin and unfortunately I don't see anything where the form should be (front-end).

In code-view there is an empty <p> and two script elements below. But there is no form or anything else.

I've put all pages to the news section (Add button) and enabled commenting. However, no matter what settings I use (with or without captcha, moderating, etc.) there is no output I can see.

I am using 3.2.1 and downloaded just the latest plugin from this site.

Hope someone can help. Any advice appreciated. Thanks!

Hi suntrop,
Have you activated the plugin in admin >plugin?

This weekend i upload a new version with the problems fixed ( I think :) )

Regards.
Reply
#63
Hi and thanks for your reply.

Yes, plugin was activated. A couple hours ago I just deleted all files and installed it again. Now it works :-) Perhaps there was an error on save/read the files?!

Anyhow, thanks!
… and cool you made this plugin :-)
Reply
#64
Thanks suntrop.
Reply
#65
I get also this message. I use GS321
Quote:*** THERE WAS AN ERROR SENDING YOUR COMMENT. ***

Redirection in 4 seconds. If you are not redirected push Back.
Back

Is the problem solved?
some help Sad ?

thanks.
Reply
#66
(2013-07-03, 07:06:44)karel Wrote: I get also this message. I use GS321
Quote:*** THERE WAS AN ERROR SENDING YOUR COMMENT. ***

Redirection in 4 seconds. If you are not redirected push Back.
Back

Is the problem solved?
some help Sad ?

thanks.

Hi karel.

Attached a beta version that I think it is fixed this problem.

Regards
Reply
#67
Hi Cumbe and thanks for your reply.

I install your beta version on GS321.
Im still getting the same error message

I also install GS312 for sure, with the normal and beta version of your plugin. But still
getting the same error. May be I'm doing something wrong Sad

regards
Reply
#68
Hi Karel,

Yes, you are right. I have to check again.

Regards
Reply
#69
Hi karel.

Attached another V2beta version that I think it is fixed this problem.

Regards


Attached Files
.zip   pages_comments_V2beta.zip (Size: 282.95 KB / Downloads: 17)
Reply
#70
Hi Cumbe

Beta version already installed and working Smile ..

Many Many Thanks
Reply
#71
Thanks karel for you test.

I´m glad that is working right.

Regards.
Reply
#72
in the form of answers to receive this
Code:
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/website.ru/gs321/theme/Innovation/header.inc.php:18) in /home/website.ru/gs321/plugins/pages_comments.php on line 1070
Reply
#73
Hello Cumbe. Smile
First of all, I wanna thank you for your great work!

But i also have a question:
Is there a way to disable the "Reply to Comments" function?
...so that people can leave a new comment on the page, but they should not be able to reply to any other comments.

Thank you in advance. Smile

Erik
Reply
#74
Hi,

I did a small update to make comments working with plugins like News Manager and GS Blog where all posts content is displayed in a page with the same slug.
Example: for News Manager I define a page with a slug 'news'. Current pages & comments version rely on slug to store and show comments. Therefore all comments for all news are stored in news.xml, i.e. we cannot have separate comments for different news.

The update is to store news related comments to separated xml files like 'newspost1.xml', 'newspost2.xml, etc.
1. In pages_comments.php, function sv_pages_first, line 249
PHP Code:
$fich=return_page_slug();
$log_name $fich.'.log'
change to
PHP Code:
$fich=return_page_slug();
$post = isset($_GET['post']) ? $_GET['post'] : '';
$log_name $fich.$post.'.log'

2. In pages_comments.php, function sv_pages, line 309
PHP Code:
$fich=return_page_slug();
$log_name $fich.'.log'
change to
PHP Code:
$fich=return_page_slug();
$post = isset($_GET['post']) ? $_GET['post'] : '';
$log_name $fich.$post.'.log'

In addition, if we don't need comments on search page (slug 'news' without 'post' parameter) we have to disable comments in code
3. In pages_comments.php, function sv_pages_first, line 277
PHP Code:
if ($com =='Y') { 
change to
PHP Code:
if ($com =='Y' && isset($_GET['post'])) { 

Note that point 3 disables comments on all regular pages which do not manage parameter 'post', therefore it can be ignored.

If you find it useful you may add this beahviour in next version.

Best regards,
Zhivko

P.S. I forgot to mention that this update works with Friendly URL disable. I'll try to figure out how to make it wuork with Friendly URL soon.
Reply
#75
Hi Schamass, in next version this option will be configurable...

Hi zhivko, thanks for you work. I will look like to adatp this modification to core in next version...

Regards
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels