Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Oops! Page Not Found."
#1
I tried a plugin on a site that I was near completion of. The plugin made it so that I could not navigate to the front-end of my site, however, I could still access the admin area and see all of my content for editing, etc.

In an effort to fix this problem, I installed a new copy of GetSimple on the server and copied the data folder from the old installation to the new. I can now see most of the edits I had originally made: theme edits, images, galleries in sidebar, widget, etc.

I cannot see any of my page content and only get the "Oops! Page Not Found." error.

As a test, I created a new page and added it to the menu. The menu item appears, but I once again get the "Oops!" error. I had thought that copying my data folder over might have left me with missing UID's in cache or something. Creating a new page to test should have (potentially) confirmed that was the case.

I'm not real familiar with the inner workings of the CMS, but am hopeful there is a way to recover these pages and allow for the content to be found.

My environment:
  • GetSimple 3.1.2
    Simplico Theme
    Plugins: I18N, I18N Gallery, P01 Contact, I18N Base, News Manager, Innovation Theme Plugin
    Hosted on Network Solutions on Linux
    Need to install zip utility (advice on that with this provider appreciated)

Any and all assistance is appreciated.

Regards,

Jeremiah
Reply
#2
Try below steps
1. change theme to GS default one
2. disable all plugins you have installed
3. in settings tab make sure you have entered right website address
4. edit .htaccess file in your GS instance root directory, and make sure RewriteBase points to the right directory
Make also sure that above GS instace dir, there's no htaccess file from earlier installation, that overwrites rules in nested directories.

btw. if a plugin seems not working correctly, just delete its files from /plugins directory
Addons: getsimple theme, Online Visitors, Notepad
Reply
#3
also try deleting /data/other/pages.xml this will recreate the internal cache
My Github Repos: Github
Website: DigiMute
Reply
#4
n00dles101 Wrote:also try deleting /data/other/pages.xml this will recreate the internal cache

I tried that, but no luck. Still cannot find the pages.

GetSimple did recreate the pages.xml file upon reloading the site. I think it is a matter of the UID not matching, but I don't know where that information is kept. I have not done a lot of PHP coding before, and do not have my dev environment set up for it completely so I can step through the code (that is possible, right?)

I'm opting to just copy and paste content into a fresh install. Pain in the ass, but not knowing where that ID is stored, it seems the quickest option.

Jeremiah
Reply
#5
jeremiah.holder Wrote:I tried a plugin on a site that I was near completion of.

Just curious, what plugin did you try?
Reply
#6
Hello YoJoe,

I did not see your response earlier. I have started from scratch and have just put a new installation on my XAMPP server. All systems check 'OK' (with exception to ZipArchive feature).

With a fresh install out of the box, I create a new page, save it, and when attempting to view it, I get the Oops! error.

My settings tab has my localhost address while developing. The site I originally complained about was hosted on Network Solutions. It had been working fine and I was nearly complete with the site, when I attempted to use the Sharebar plugin (stupid mistake....so little reward for the risk)

I am not sure what settings/changes to make to the .htaccess files.

Thank you for your help.

Jeremiah

yojoe Wrote:Try below steps
1. change theme to GS default one
2. disable all plugins you have installed
3. in settings tab make sure you have entered right website address
4. edit .htaccess file in your GS instance root directory, and make sure RewriteBase points to the right directory
Make also sure that above GS instace dir, there's no htaccess file from earlier installation, that overwrites rules in nested directories.

btw. if a plugin seems not working correctly, just delete its files from /plugins directory
Reply
#7
Resolved!

I am not sure how the .htaccess file became corrupted (maybe the plugin modified it?).

I just had to change the last line in the .htaccess file:

From this...
Quote:RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule /?([A-Za-z0-9_-]+)/?$ index.php?id=$1 [QSA,L]

To this...
Quote:RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule /?([A-Za-z0-9_-]+)\.html$ index.php?id=$1 [QSA,L]
Reply
#8
none of plugins I know adds automatically a rewrite rule with .html suffix at the end of URL.
You had to do this manually, or you have overwritten .htaccess by a mistake.

btw. with such rewrite rule, you'd just have to add .html to custom link structure, ending with %parent%/%slug%.html Wink
Addons: getsimple theme, Online Visitors, Notepad
Reply
#9
My rewrite rule was set as "%slug%.html within the admin settings.

I am not sure how the .htaccess was changed, but I did not manually edit it prior to the "Oops!" error.

Thanks for the feedback, though.

yojoe Wrote:none of plugins I know adds automatically a rewrite rule with .html suffix at the end of URL.
You had to do this manually, or you have overwritten .htaccess by a mistake.

btw. with such rewrite rule, you'd just have to add .html to custom link structure, ending with %parent%/%slug%.html Wink
Reply
#10
It appears I've come full circle. I believed I had the issue resolved because I regained access to my page content and no longer saw the "Oops!" error.

However, I now have the site complete and on the Network Solutions host, but am having difficulty gaining access to the site from any pc but the one I developed on (caching issue, I guess).

I have FancyURL's enabled with the definition as %slug%.html.

My root .htaccess looks like the following:

Quote:AddDefaultCharset UTF-8
Options -Indexes

# blocks direct access to the XML files - they hold all the data!
<Files ~ "\.xml$">
Order allow,deny
Allow from all
Satisfy All
</Files>
<Files sitemap.xml>
Order allow,deny
Allow from all
Satisfy All
</Files>

RewriteEngine on

# Usually it RewriteBase is just '/', but
# replace it with your subdirectory path
RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
#RewriteRule /?([A-Za-z0-9_-]+)\.html$ index.php?id=$1 [QSA,L]
#RewriteRule ([A-Za-z0-9-]+).html index.php?id=$1 [QSA,L]
RewriteRule ^(.*?/)?([A-Za-z0-9-_]+)/?$ index.php?id=$2&lang=en [QSA,L]

I have several ReWrite Rules here, as I am trying to find what will work with the public facing site. With the current rule enabled, I get access to the template structure, but still no access to the Page content found in the data xml files.

As I tweak those rules, I get varied results: Either the host 404 error, or some partial content loading from my site, but with missing components or the Oops! error.

A sound .htaccess file configuration would be much appreciated.

Regards,

Jeremiah
Reply
#11
jeremiah.holder Wrote:A sound .htaccess file configuration would be much appreciated.

Seems you still haven't discovered the power of wiki Smile
Everything you need has been grabbed from forums and put there: http://get-simple.info/wiki/config:htaccess
Addons: getsimple theme, Online Visitors, Notepad
Reply
#12
I had read that page already, and had in fact borrowed my rule from that page. However, it still did not work. I finally regained access late last night after modifying both rules and playing with results for a bit.

Thanks for your follow up.

yojoe Wrote:
jeremiah.holder Wrote:A sound .htaccess file configuration would be much appreciated.

Seems you still haven't discovered the power of wiki Smile
Everything you need has been grabbed from forums and put there: http://get-simple.info/wiki/config:htaccess
Reply
#13
jeremiah.holder Wrote:I had read that page already, and had in fact borrowed my rule from that page. However, it still did not work. I finally regained access late last night after modifying both rules and playing with results for a bit.

Thanks for your follow up.

Rewrite rule
Code:
RewriteRule ([A-Za-z0-9-]+).html index.php?id=$1 [QSA,L]
along with custom link structure set in backend still works perfectly, and I get URLs ending with .whatever string I can imagine. I wouldn't even say a word about that, if this solution somehow stopped working.

Considering the fact, that your last rule
Code:
RewriteRule ^(.*?/)?([A-Za-z0-9-_]+)/?$ index.php?id=$2&lang=en [QSA,L]
doesn't make any sense, I guess you did not test the custom link structure on a fresh GS instance.
Addons: getsimple theme, Online Visitors, Notepad
Reply




Users browsing this thread: 1 Guest(s)
Generate Leads from Documents vCard Hosting