Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Release 3.2.2 BETA
#1
Bug 
Medium sized update, fixes some long time major annoyances and some new features.

Things of note
New social options for innovation theme.
Globals for configuring ckeditor toolbar and options dynamically.
CDN failures fall back to local automatically.
General speed optimizations, mostly related to constant plugin loading and api calls.
Removed most branding and data leakage from public login pages, help with drive by exploitation.
CSRF on mutating IP fix.

Change Log
http://get-simple.info/start/changelog
svn: https://github.com/GetSimpleCMS/GetSimpleCMS/issues/556

Download: http://get-simple.info/download
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#2
Get yo tests on fools !
Smile

We really need some qa people
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#3
All looks good Shawn.

Just one error on innovationPlugin.php

Undefined index: template in \plugins\InnovationPlugin.php on line 33
My Github Repos: Github
Website: DigiMute
Reply
#4
hmm I somehow missed that. I think its time to add a requests wrapper for is() or something, those issets get real annoying.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#5
I actually do not get this notice.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#6
nm I was testing on the wrong damn branch
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#7
Just had a look at a fresh 3.2.2b - no additional plugins, themes; nothing.
Everything seems to work fine on apache + php 5.2.16

Minor things I've found:
- $site_version_no = '3.2.1'; <- just a reminder
- Share GetSimple modal window looks quite odd (no twitter img/box ?) <- I think that content in this modal window is broken for looong time.
Addons: getsimple theme, Online Visitors, Notepad
Reply
#8
Yeah versions do not get changed until they are tagged, i wonder if we can work betas in to that somehow though so the version checking doesn't act wierd. A beta flag or something perhaps.

Share works fine for me, in fact I actually test that on every release, no clue why I just do.

What browser?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#9
(2013-06-07, 06:36:13)shawn_a Wrote: Yeah versions do not get changed until they are tagged, i wonder if we can work betas in to that somehow though so the version checking doesn't act wierd. A beta flag or something perhaps.
Betas had got a "bleeding edge" note in health check.
(2013-06-07, 06:36:13)shawn_a Wrote: Share works fine for me, in fact I actually test that on every release, no clue why I just do.

What browser?
Should have see in other browsers.
Screenie taken in firefox.


Attached Files Thumbnail(s)
   
Addons: getsimple theme, Online Visitors, Notepad
Reply
#10
Ill take a look, works fine in chrome.
Looks ok in firefox as well, bottom is a little messed up.

What page are you on, do you get this on all pages ?

and now linked in isnt showing, something is definitely up with that.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#11
(2013-06-07, 07:23:29)shawn_a Wrote: Ill take a look, works fine in chrome.
This was 2nd browser I've looked after you mentioned everything is fine.

(2013-06-07, 07:23:29)shawn_a Wrote: What page are you on, do you get this on all pages ?
and now linked in isnt showing, something is definitely up with that.
Both ways: link in a footer and support page.
Addons: getsimple theme, Online Visitors, Notepad
Reply
#12
Some fixes to this beta so far.

Added Version

Fixed up share.php
I added some style fixes for share.php
I also used selectors on the styles so the page doesn't change when the popup is open.
There is an issue with linked in running a second time, the js tries to run again.
Apparently there are some bugs with fancybox ajax mode, it never destroys assets so js errors on duplicate sometimes, and default click is not prevented, so you get cancelled requests to share.php for example, i added a preventdefault chain to this to stop that.

I also fixed an issue with the api.

NOTE:
Betas are live, I am not doing traditional releases right now, hotfixes branch is live beta for now, its just me and its easier. So clicking the download will get you these changes, so beware this is not really a b2 yet, just work in progress.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#13
b3 updated changelog
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#14
Any suggestions on the timeline for this release?

A few more weeks ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#15
Hi Shawn,
I've upgraded yesterday, and i've no jquery library loaded in admin area. >
Uncaught ReferenceError: jQuery is not defined,
is this possible?
Reply
#16
What browser ? What page ?
Do you have console output on which line or backtrace ?
F12

I am not seeing this issue.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#17
i 've upload just admin files and root index.php, problem at every admin page on Chromium 28.0.1500.52 Ubuntu 12.04 (28.0.1500.52-0ubuntu1.12.04.2)

screenshot here > http://share.pho.to/2lXUp/original
Reply
#18
you cut off the line numbers, the only thing of importance.

click the arrow for the first one and paste the whole backtrace and line numbers.

If i had to guess you have a plugin conflict or incomplete upgrade.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#19
http://share.pho.to/2ldcj/original
http://share.pho.to/2ldjp/original
Reply
#20
I meant the "console" screen output

But its pretty obvious jquery is having problems.
But your console says nothing about any missing assets or 403s.

Can you goto console, and refresh and see if it says any 403s, also check your pages code and see if the <head> shows jquery in there, maybe send me a link or paste that also ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#21
Shawn, srry 4 delay, partytime is over Wink

i removed all admin directory & uploaded new admin dir from your branch > https://github.com/GetSimpleCMS/GetSimpl...e/hotfixes

but i see same issues > no jquery lib call > http://share.pho.to/2m7Jm/original
Reply
#22
i' ve disabled > jappix_chat.php plugin & everything it's OK now Smile
Srry 4 bumpin please Wink
Reply
#23
I've heard that before, I wonder whats up with this jappix chat plugin.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#24
There is 1 change in here that is a bit of concern to me, and I am not sure if its necessary, but I felt it needed to be done for security and consistency.

Please see
https://github.com/GetSimpleCMS/GetSimpleCMS/issues/592

Quote:This change removes back end hooks from public auth pages to prevent data leakage and unintended consequences via bad plugin programming.

Does anyone know of any plugins this will break ?
The auth pages no longer have header and footer hooks called.

I am pretty sure these were inconsistent anyway and probably only worked on resetpassword page.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#25
Release worthy ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels